• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 698
  • Last Modified:

Allow remote access to a server from Win SBS2008 RWW

I have setup a server on our network for user to RDP and use internal network applications when they are not on site.  We are running a SBS2008 server and the other server is called RemoteDeskTop.
I ave in the SBS2008 console allowed each user as a standard user under computers for the ReoteDeskTop server (which is by the way a Windows 2008 Enterprise R2)  

When a user uses the RWW it shows in the list of avable computers to connect with but when they try to connect to it they get an error message that says (see image) "To log on to this computer you must be granted the Allow log on throught Terminal Services right."

The funny part is if the same user, from his desktop computer, while connected to our network, starts an RDP session directly to that server they are able to logon.

I stumped. I ve looged att he TS gate rights, and group polocy rights and I can find anything that will amke this work.

Any ideas?
Error.png
0
mcrman
Asked:
mcrman
  • 3
  • 2
1 Solution
 
Dave_ANDCommented:
Go in to each user, click "computers" and give them remote access to the TS box you have, see if that helps.
0
 
jhill777Commented:
Is the server a DC?
0
 
jhill777Commented:
There are a few places that need to be configured properly for TS to work.

1) The “allow logon through terminal services” right must be assigned to the user or group in question. This can be done through group policy or local policy. By default, remote desktop users is granted this right locally, you can do the same with a domain policy for good group organization.

2) Permissions to the RDP protocol must be added in (admin tools->Terminal services config->connections->RDP-tcp properties->Permissions). Usually remote desktop users is already listed but you may have to add it.

3) The “HKLM\system\currentcontrolset\control\terminal server\fDenyTSConnections” dword must be set to “0¿. This can also be accessed by right clicking “my computer” and choose properties, go to the “remote” tab, and check the box for “enable remote desktop on this computer.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
mcrmanAuthor Commented:
The users are allowed access to the server (see picture)

The server is not a DC

The allow logon through terminal services right is enabled.  Remeber the user CAN RDP to the server if used on the network, they get this error only when they use RWW to connet to a computer.

They have permissons to RDP and enable remote desktop on this computer is set as they CAN access the server via RDP when on the local network.
User.png
0
 
mcrmanAuthor Commented:
OK, the sotiation gets even stranger.  I logged onto RWW with the administrator to see if I could RDP to the RemoteDesk server.  When i choose that name and conencted I was connected to another server!!??  How does this happen?  I understand why I have the issue above with the users but now I have no idea how to fix this redirection issue.

Thoughts?
0
 
mcrmanAuthor Commented:
Ok, i was able to fix this issue by renameing th server.  Not sure why this fixed it, but it did and all is good.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now