Solved

Extremely slow SOAP call

Posted on 2010-09-10
9
6,160 Views
Last Modified: 2013-11-19
Good day everyone,

I've been having performance issues with the consumption of my web service on my web application. Precisely, every single SOAP request is extremely slow.

To begin with, here is my setup:

- PHP SOAP extension
- PHP v.5.2.14 (Latest)
- The server is running under Linux
- The setting in php.ini soap.wsdl_cache_enabled=1 (Switching this to 0 doesn't seem to affect the performances in any way)
- The SOAP server is situated on the same server (same IP address) as the SOAP client.

I've narrowed my researches and I am 100% sure the problem comes from the server, but I just cannot find where the problem comes from.

When I execute the code below on my local machine using WampServer (PHP 5.2.11), the request is almost instantaneous whereas if I execute the same code on my server, it takes about 5 to 10 seconds before I get the response.

I must be missing something. Normally, the request should be faster when executed on the server since it's consumming a web service locally.

Thank you.




 
$client = new SoapClient('http://www.mywebserveraddress.gov/inventory.wsdl');

try {	
	$response = $client->getProductDescription(5467);	
	
  	echo '<pre>';
	print_r($response);
  	echo '</pre>';
}
catch (SoapFault $exception) 
{
  	echo $exception;
}

Open in new window

0
Comment
Question by:dom_solariumdeparis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
9 Comments
 
LVL 20

Expert Comment

by:virmaior
ID: 33653599
so we know:
(1) the server is running linux and you are running windows.
(2) minor difference in version numbers


(a) are both using the built-in SOAP extension?
(b) what are the php.ini settings for soap, ssl, and curl?


I have seen similar issues before with SOAP.  I think the SOAP implementation in 5.3 is worse than 5.2.

have you looked at the print_r($client) and compared those two?
0
 

Author Comment

by:dom_solariumdeparis
ID: 33661968
a) Yes, both my local setup and the online server are using the built-in SOAP extension
b)

######
Local:#
######

SSL: There is no settings for SSL in the php.ini (This extension is not activated)
CURL: There is no settings for CURL in the php.ini (This extension is not activated)

SOAP:
soap.wsdl_cache_enabled=0
; Sets the directory name where SOAP extension will put cache files.
soap.wsdl_cache_dir="/tmp"
; (time to live) Sets the number of second while cached file will be used
; instead of original one.

#######
Server:#
#######

CURL (According to phpinfo()):
cURL support       enabled
cURL Information       libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

OpenSSL (According to phpinfo()):
OpenSSL support       enabled
OpenSSL Version       OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008

SOAP:
; Enables or disables WSDL caching feature.
soap.wsdl_cache_enabled=1
; Sets the directory name where SOAP extension will put cache files.
soap.wsdl_cache_dir="/tmp"
; (time to live) Sets the number of second while cached file will be used
; instead of original one.
soap.wsdl_cache_ttl=3600


Comparison of print_r($client):

Local: SoapClient Object ( [_soap_version] => 1 [sdl] => Resource id #3 )
Server : SoapClient Object ( [_soap_version] => 1 [sdl] => Resource id #3 )

Both are identical.
0
 

Author Comment

by:dom_solariumdeparis
ID: 33661980
I missed the following for my local setup in php.ini:

soap.wsdl_cache_ttl=86400
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 20

Expert Comment

by:virmaior
ID: 33662502
i think there are some differences in the php socket implementations between the windows and linux versions.


(1) try this:
make your soapclient with the following parameter:

$client = new SoapClient('http://www.mywebserveraddress.gov/inventory.wsdl',array('trace' => true));

and see if the print_r does not get more verbose.

(2) do you know if the slow step is the call, making the client, or waiting for the response?
0
 

Author Comment

by:dom_solariumdeparis
ID: 33663759
1)

The output does not give more verbose besides the additional parameter:

SoapClient Object ( [trace] => 1 [_soap_version] => 1 [sdl] => Resource id #3 )


2)

I am sure the problem is not the server-side of the SOAP since as I mentionned, my local performs the SOAP request to the server and it works perfectly and I get a response within a few miliseconds.

The problem comes from the client (on the online server), which means it's either the client call or "making the client".
0
 

Author Comment

by:dom_solariumdeparis
ID: 33663807
3 )  we made a test for client-side SOAP with another dedicated server.
the client side calls the server-side and the result is the same than local call within few milliseconds.

but client-side with server-side on the same server, we get 10 secs for the same request.

0
 
LVL 20

Accepted Solution

by:
virmaior earned 500 total points
ID: 33663846
re:1
are you doing so at the end of the page or immediately after making the object?  It should have more information if you do it at the end.

try a var_dump($client) at the very very end and compare the two outputs between your local machine and the live box.

re:2, my question was not about the server side code.  I guess I am saying tell me which of the following are slow:

a) exit immediately after making the soapClient
or
b) exit after making the call to the server

if it is happening at a), then it's an issue with the sockets more generally.  if b), then there's something specific going wrong to this type of call.

issues can happen from self-addressing.

0
 

Author Comment

by:dom_solariumdeparis
ID: 33702535
I seem to have solved the problem with a little config in the php.ini.

I changed the following settings on my online server:

soap.wsdl_cache_ttl=3600 to soap.wsdl_cache_ttl=86400

For some odd reason, the "time to live" drastically affects the performances.

Since then, it is working perfectly fine and everything executes in a record time !

Thank you for your help virmaior. Much appreciated.
0
 

Author Closing Comment

by:dom_solariumdeparis
ID: 33702552
Although you didn't provide the direct answer to my problem, your guidance helped me to play with the configuration and I finally ended up with the answer.
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article discusses four methods for overlaying images in a container on a web page
Many old projects have bad code, but the budget doesn't exist to rewrite the codebase. You can update this code to be safer by introducing contemporary input validation, sanitation, and safer database queries.
The viewer will learn how to count occurrences of each item in an array.
The viewer will learn how to create a basic form using some HTML5 and PHP for later processing. Set up your basic HTML file. Open your form tag and set the method and action attributes.: (CODE) Set up your first few inputs one for the name and …

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question