• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 921
  • Last Modified:

SSRS reportviewer text is missing from textbox when viewed in IE but OK in Firefox

I have several SSRS reports on a website. On several of these reports there is a textbox containing a % calculation e.g "=ReportItems!Text20.Value/ReportItems!Text35.Value"  - Format= "P1" - Font ="Normal, Arial, 8pt, Normal" - Hidden ="False"

This textbox refuses to display data when viewed in the report viewer in IE from the live website. The data appears fine when exported to PDF, Excel etc and appears fine in Firefox and appears fine when previewed in Visual Studio designer.

I am at a complete loss as to the reason for this. Any ideas please?
0
Al230762
Asked:
Al230762
1 Solution
 
Al230762Author Commented:
Problem solved. For anybody else having this problem. Apparently a textbox containing a calculation e.g. ""=ReportItems!Text20.Value/ReportItems!Text35.Value" must have TextAlign = "Left" otherwise, if left as the default TextAlign = "General" the data will not appear in the reportviewer when viewed in Internet Explorer - all other browsers are unaffected as far as I can tell as is export to PDF, Excel etc. Strange but true.
0

Featured Post

Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now