[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

How do I get a network scanner to work with a Macbook?

Posted on 2010-09-10
14
Medium Priority
?
708 Views
Last Modified: 2013-12-27
We have a new Kyocera multifunction machine (300ci) in our small office and have successfully configured it to scan to a PC.  We want to scan to a Mac, and have set up folder sharing (folder named "scans") on a Macbook (OSX 10.5), have set up the host/path/user/pw on the scanner, and we can ping the Mac (Macintosh-18) on the network, but when we try to scan to the  Mac, the send transaction takes FOREVER and then fails with a connect error.  We've  tried both sharing a  folder within the user's "Public" folder on the Mac:

(path: /Macintosh-18/[username]/Public/scans),

and also sharing a folder right on the Mac HD:

(path: /Macintosh-18/scans).  

I'm not all that Mac-savvy.  Are my path names correct for a Mac?  If not, what is the correct path to use? And if my path names ARE correct, how do I resolve this problem?

Thanks!
0
Comment
Question by:MHCrooks
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
  • +1
14 Comments
 
LVL 20

Expert Comment

by:woolnoir
ID: 33652367
Can you browse to that share on the mac from another PC ? The first step is to determine if the problem is the scanner or the mac and the best way of doing this is to verify connectivity from another PC. The mac by default can only share using AFP - so im presuming you have enabled windows(smb) sharing from within system preferences ?

0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 33652618
If it is an SMB share, and the mac is called macintosh-18, the path should be //macintosh-18/scans
0
 

Author Comment

by:MHCrooks
ID: 33653025
SMB sharing is enabled on the mac through system preferences, and  I can see the mac from another PC (in Workgroup Computers), but cannot browse to the share...but I think that is is because the PC "user" was not authorized is system preferences. Connectivity from the scanner to a PC if fine, and on the scanner I have the path to the mac correctly set, so I am pretty sure the problem is on the mac end.  Since I have SMB sharing enabled and the user (i.e. scanner) correctly authorized in system preferences on the mac, I don't know what else to troubleshoot.   I may not be able to have another go at this until sometime next week.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 53

Expert Comment

by:strung
ID: 33653075
Do you have the folder in question on the Mac shared with read and write privileges?
0
 

Author Comment

by:MHCrooks
ID: 33653213
Yes, the folder is shared read/write.
0
 
LVL 20

Accepted Solution

by:
woolnoir earned 1000 total points
ID: 33653317
you need a like for like test, give a test user the same permissions as the scanner user and try to browse to the share. Be aware that on a mac you have two sets of permissions the same as a PC... the permissions on the share panel in system prefs and the system permissions (right click, get info ) make sure both are set as they should be.
0
 

Author Comment

by:MHCrooks
ID: 33653335
Hmmmm.....I only set permissions on the share panel in system prefs.....maybe the system permissions is my problem (I didn't know that, siince I am not too familiar with mac).  Once I can get the mac back into the office (next week), I will give it a try and let you know.  Thanks!
0
 
LVL 20

Expert Comment

by:woolnoir
ID: 33653342
yeah basically find the folder, right click, get info, expand permissions and make sure that the user you want to have access has it... it may be that its already added but you cant always be sure. Mac's (ive found at least) have always been dodgy in the SMB sharing situation, specially if its 10.5 , 10.6 seems a lot better in that regard.
0
 

Author Comment

by:MHCrooks
ID: 33807070
Sorry - this is a volunteer job, and I am only sporadically in the office.  Checked all the permissions, think I have them right, but cannot browse to the Mac.  I must be missing something, but don't know what else to try.
0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 33990658
path slashes in SMB scanning are:

\\servername\sharename

i.e.

\\Macintosh-18\[username]\Public\scans

\ is for windows, / is for unix
0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 33990702
additionally, kyoceras often need the username to include the SMB domain, as in

domainname\username
0
 

Author Comment

by:MHCrooks
ID: 33990800
Will check next time the MacBook and I are in the office at the same time.  However, the path is set on the user interface on the Kyocera (separate input fields) so I don't think the slashes are the problem, and probably the same goes for the SMB domain.  Thx
0
 
LVL 21

Assisted Solution

by:wyliecoyoteuk
wyliecoyoteuk earned 1000 total points
ID: 34004445
Well, all the MFDs that I work on (including Kyoceras) need the right slashes, although they will accept the wrong ones!

The backward slash is used for SMB (Windows) network names, the forward slash is for Unix (Mac and Linux etc) names.

Most MFDs expect an SMB path to include the servername, the server field is for NCP (Novell) servers.

The Kyocera itself runs a version of Unix, but SMB scanning runs on Samba, the Unix version of windows networking.

Also, the username and password have to be set up with full permissions, and it won't work with a blank password.
I found that one I recently set up only accepted the IP address of the target Computer for some reason (DNS failed), so that might be an idea.
If it is not in a domain, the username may need to be something like:

Macintosh-18\username

Unfortunately, Kyoceras are among the hardest to troubleshoot, simply because their error messages don't tell you much about why they fail.



0
 

Author Closing Comment

by:MHCrooks
ID: 34115569
Double-checked the permissions on the Mac (which were incomplete), and corrected the slashes (duh!) on the Kyocera, and all is well!  Many thanks guys, for the help and your patience with my slow responses!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Well I am not sure whether i deserve anything (credit or points) for this article, since I have not written the source code but discovered the same while browsing the net. I only wish to help EE users save some money and probably help the environmen…
While there are many new features for iOS 11, these are the five that can improve your digital lifestyle.
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question