Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2202
  • Last Modified:

NFSv4 permission denied when using chmod

I have encountered a strange problem when trying to chown a file mounted as nfsv4 on Solaris 10?

Config:

Netapp Filer - exporting volume /test as nfsv4, with unix style security, read/write access and root
Solaris 10 - mounting /test as nfsv4, rw

When using Solaris NIS, there are no issues using chown to change permissions to a nis user. However I use LDAP ( Windows 2003 domain ) to authenicate users on Solaris and when using chown with the LDAP account get permission denied. The files are owned by root, root can create directories and files, just can't chown.

Anybody have any experience in this combination?

0
xeyeclan
Asked:
xeyeclan
1 Solution
 
jghelfman40Commented:
I believe you need to be running cifs on the filer. CIFS is specifically for windows.Try running:> cifs setupThe now site will have  more information on it if you don't have man pages installed, otherwise you could probably just run 'man cifs' on your filer.

This also seems like something that should be put in the Netapp Storage Zone.
0
 
yuzhCommented:
If you try to use chomd/chown to a NFS filesystem from the NFS client, you need to set the NFS share promissions to allow the root in the NFS client to do the job.
eg,  if Your NFS server is Solaris, in the /etc/dfs/dfstab file, should have
root=client1:cline2:clinetN
as the option in the NFS share
if clent, client2, clientN is not defined in DNS, or NIS/NIS+, you need to put them in /etc/hosts file.
man dfstab
to learn more details.
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now