Solved

cannot add a 2008 R2 as a DC on my domain

Posted on 2010-09-10
12
574 Views
Last Modified: 2012-05-10
cannot add a 2008 R2 as a DC on my domain I have 2 DC's 1 is a 2k3 R2 standard sp2 x32 and a 2k8 standard (non R2) x64 sp2, I'm trying to add a 2k8 R2 as a DC but after addind the ADDS role DCpromo error reads to run adprep/forestprep. I ran adprep fine on both the 2k2 and the 2k8 non R2, but the 2k8R2 fails because the server is not a domain controller, but I cant make it a DC because DCpromo is waiting for adprep/forestprep  
0
Comment
Question by:MFRMLS_IT
  • 5
  • 3
  • 2
  • +2
12 Comments
 
LVL 20

Expert Comment

by:Lazarus
ID: 33649171
Did you run:
ADPREP /forestprep
ADPREP /domainprep
adprep /rodcprep
0
 

Author Comment

by:MFRMLS_IT
ID: 33649205
I ran ADPREP /forestprep
0
 
LVL 20

Expert Comment

by:Lazarus
ID: 33649227
You need to runn all of the above not just forestprep
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 20

Expert Comment

by:Lazarus
ID: 33649248
0
 
LVL 12

Expert Comment

by:FDiskWizard
ID: 33649431
Domain admins may not have the needed permissions - think delegation...
See this for details:
http://support.microsoft.com/kb/232070
0
 

Author Comment

by:MFRMLS_IT
ID: 33649597
I'm not so sure about  the "all the above" as an answer especially the "adprep /rodcprep" since i'm not setting up a Read Only DC and "ADPREP /domainprep" has to be run after ADPREP /forestprep has been run.  

0
 
LVL 20

Expert Comment

by:Lazarus
ID: 33649760
Even if you are not setting up RDOC, you need to run it, and yes, the order in which I gave them is the order in which you run them:
ADPREP /forestprep
ADPREP /domainprep
ADPREP /rodcprep
0
 
LVL 3

Expert Comment

by:gs121
ID: 33650223
Not sure if the above comments take into account OS type (32 or 64 Bit).....

You should only have to run ADPREP /forest once on a forest.  Not for each domain in the forest.
Just run it on the Root domain once, and the forest is done.  ( IF YOU ONLY HAVE 32 BIT os dcs use adprep32)

adprep /domainprep needs to run on each domain.  you can run the 32 bit version if you do not have A 64 BIT os dc.  The adprep or adprep32 should be on the schema master for the forest.
ADPREP32 /DOMAINPREP

You should be running adprep on a domain controller.
If I understand you, you are trying to run adprep /domainprep on a non DC?
Run it on a DC in the domain, if the domain does not have a 2008 DC, run the adprep32 version of the command on a 32 bit os server (2003 or 2008 (non 64 bit).

The adprep or adprep32 should be on the schema master and then on infrastructure master for each domain.  If it 64 bit OS use adprep, or use ADPREP32 for a 32 bit os DC.

0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33650588
You need to to run adprep32 /forest on your schema master and adprep /domainprep on your infrastructure master.

Read article below

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/A_3644-Windows-2008-Server-R2-adprep-adprep32.html
0
 
LVL 20

Expert Comment

by:Lazarus
ID: 33650659
MFRMLS_IT,   QS121 is correct in what he's saying there. I should have added that myself, but somethng I tend to think certain things are obvious when they are not.  As well running the RODCPREP is not a must but should be done. It will prep the domain for a possible RODC even if you do never use it.
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 500 total points
ID: 33650694
@gs121

Sorry didn't mean to repeat what you said I must have read over your post but the article I posted is a pretty good one to read over still.

@MFRMLS_IT

To find out what DCs hold these roles run the below command

netdom query fsmo
0
 

Author Closing Comment

by:MFRMLS_IT
ID: 33789001
this is not a solution but I need to close this thanks everyone for their imput
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The password reset disk is often mentioned as the best solution to deal with the lost Windows password problem. In Windows 2008, 7, Vista and XP, a password reset disk can be easily created. But besides Windows 7/Vista/XP, Windows Server 2008 and ot…
It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question