Link to home
Start Free TrialLog in
Avatar of SimpleJoe
SimpleJoeFlag for United States of America

asked on

DNS propagation question

Hello, 48 hours ago DNS was modified to point website to one host (BlueHost) and
email to another host (Liquidweb)

Today when I ping from my Comcast connection it shows the correct IP for the
website (74.220.207.179) and the correct IP for mail (69.167.173.234) but when
I send a test email through Comcast it's still going to BlueHost.

Domain is luxuryvillaslanzarote.com

Mail sent from within the email host server (Liquidweb) routes correctly to his email address, but all other mail goes to BlueHost.

any ideas?
Avatar of Rodney Barnhardt
Rodney Barnhardt
Flag of United States of America image

I tried checking using mxtoolbox.com and the domain for mail on the Internet is still showing 74.220.207.179. Maybe you need to contact your ISP and see if there is a propagation issue on their part. I remember making a change several years ago with MCI, and when I called back, told me they were having DNS issues.
Avatar of kf4zmt
kf4zmt

Is this a bind dns server?  If so, did you restart the bind service after making the changes?
;; ANSWER SECTION:
luxuryvillaslanzarote.com. 503      IN      A      74.220.207.179


atomant@neteng01 ~ $ dig mail.luxuryvillaslanzarote.com +short
69.167.173.234



You need to update the MX record to point to mail.luxuryvillaslanzarote.com

Billy
meaning the MX record is pointing to the parent domain:

atomant@neteng01 ~ $ dig mx luxuryvillaslanzarote.com +short
0 luxuryvillaslanzarote.com.
You may have changed the A records but not the MX records. An "A" record change would ping the correct spot.  E-mail can still go somewhere else though as it depends upon the MX records.  Go to mxtoolbox.com and put in your domain to see what your MX records are pointed too.  I checked it and it is pointed to 74.220.207.179.  Ask whoever holds your dns records to erase that enry and put the correct one in.
Avatar of SimpleJoe

ASKER

it's a cpanel server, here's a screenshot of the DNS as we have it setup, and he is using our nameservers:
dns.jpg
Not on the server. Your MX record with your ISP. That is where you need to make the MX record change.
ASKER CERTIFIED SOLUTION
Avatar of rfc1180
rfc1180
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Sorry, mis read you last post. on the MX record, you need the IP on the right side instead of the domain name.
bad practice to use the IP; besides, there is an A record already defined for the IP (mail):
rfc1180: thank you very much, you were absolutely correct.

48 hours and multiple techs and it took experts exchange to correct it within minutes

thanks again
awesome