Solved

Need to get internet access to the companyweb on Sharepoint 3

Posted on 2010-09-10
28
674 Views
Last Modified: 2012-06-27
I'm running sharepoint 3 on sbs2008. Ithe http://companyweb page displays fine from the local server.

I need to have access to the page from https://sharepoint.myconpany.com:987.

I have an alternate access mapping to https://sharepoint.myconpany.com in the default part of central administration and port 987 is open on the router. The server firewall has been disabled.
0
Comment
Question by:jimmylew52
  • 17
  • 10
28 Comments
 
LVL 32

Expert Comment

by:Rodney Barnhardt
Comment Utility
OK, so have you purchased a domain name for the website, and registered that domain with the external IP address with your ISP? If so, can you just not get to the site?
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
I can reach the site

https://sharepoint.myconpany.com:987

But this is what I get.

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.0
Date: Fri, 10 Sep 2010 19:59:16 GMT
Connection: close

Instead of the web site
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
I can also telnet to sharepoint.mycompany.co 987
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
Couple of problems come to mind.  If you are using the SBS 2008 self signed cert..it only supports 1 URL.  By default that would be remote.domainname.com (or .net or . whatever)  
When you ran the Setup your internet address wizard...did you click on the advanced link and change remote to sharepoint?
Secondly, does RWW or OWA work?   what URL do you use for those?
 
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
Using a multi cert for the server.

Don't remember running the Letup you internet address wizzard but an address is set up and exchange works fine. did not click on advandes link and change remote to sharepoint.

OWA works at mail.mycompany.com/owa

don't know what RWW is.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
I would suggest trying  https://mail.mycompany.com:987 and see what happens
Secondly, is an A records setup on your public DNS for sharepoint pointing to your public IP?
SBS doesn't handle multi certs well
RWW (remote web workplace) is one of the truly great features in SBS
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
https://mail.mycompany.com:987 does not work.

Yes A records are established for all names.

Read up on RWW, sounds cool

I don't find an advanced link in the internet access wizard to click on.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
The advanced link is at Setup my internet address wizard at the point where you enter your domainname (underneath the text box)
Was the certificate added to the server using the Trusted 3rd party cert wizard?
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
No, it was added using exchange management shell and added to IIS in server certificates.
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
Sorry, it has been a year ago I installed the certificate. After checking the server, I did use the add a trusted 3rd party cert wizard.

I am sure the certificates are not the problem. I can reach the site using https. I just get this

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.0
Date: Fri, 10 Sep 2010 19:59:16 GMT
Connection: close

instead of the web page.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
https://mail.companyname.com/remote    gives this

The page cannot be displayed because an internal server error has occurred.

https://mail.companyname.com:987/remote      gives this

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.0
Date: Sat, 11 Sep 2010 15:48:41 GMT
Connection: close
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
https://mail.companyname.com/remote would be the URL for Remote Web Workplace...so obviously that's not working either.   https://mail.companyname.com:987/remote   is not valid for anything with SBS.
If you go to IIS Manager > Expand Sites > Right Click on SBS Sharepoint > Edit Bindings > Right click on HTTPS what does it show for the certificate?
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
http    companyweb    80       *

https                            987     *

portal.companyname.com     80     *

certificate is mail.companyname.com

  https://mail.companyname.com:987 used to access the sharepoint site
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
I've reviewed my own...my suggestion is that you remove portal.companyname.com from the bindings...doesn't belong there.
You may wish to then run the Fix My Network Wizard...let it fix whatever it finds..then reboot
Then try https://mail.domainname.com.:987/
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
Where is the fix my netwark wizard found?
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
SBS Console > Network (top bar) > Connectivity Tab  
Wait for everything to finish   Fix my network link is on the right under Connectivity Tasks
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
Found it. It appears to have shut down the server. Is that normal?
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
The wizard changed the servers IP address.

removed portal.companyname.com from the bindings

https://mail.domainname.com.:987/ gives the following

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.0
Date: Sun, 12 Sep 2010 01:33:43 GMT
Connection: close

https://mail.companyname.com/remote  gives the following error

404 - File or directory not found.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
were you able to change it back successfully
not sure I have any other suggestions...I'd be curious   have you tried the external address from within the LAN?
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
I had to go to the NOC and log in on a console but I was able to change it back. Yhe address the wizard assigns does not work on  my network. Tried from within the lan also

I deleted the web application and built a new one. I will do some testing and get back to you.
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
Nothing works
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
Forgot to run the "sharepoint products and technologies wizard"

Tried to nun it and it errored out.

SharePoint Products and Technologies Configuration Wizard  event id 104



deleted this key after reading from the following website:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server

Extensions\12.0\WSS\Services\Microsoft.SharePoint.Search.Administration.SPSearchService

http://objectmix.com/sharepoint/298633-failed-register-sharepoint-services.html

I am back to where I was to start with. I have local access but not internet access.
0
 
LVL 35

Expert Comment

by:Cris Hanna
Comment Utility
well without direct access to your server..I'm not sure how much more I can offer
But I did find this...probably most of what you know already
http://www.winvistatips.com/external-companyweb-url-sbs-2008-stopped-working-t674067.html
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
I had to extend the website to the internet. I now have access to http://sharepoint.mycompany.com.

However, I cannot get access to https://sharepoint.mycompany.com:987
0
 
LVL 1

Author Comment

by:jimmylew52
Comment Utility
New problems, when I can access sharepoint, exchange shuts down. When I get exchange back share point shuts down.

I have resolved the problem by installing the free sharepoint 3.0 sp2 package from Microsoft on a windows 2003 server. I am not having any problems with share point or exchange now.

I appreciate all you help. Please enter this as a fix so I can give you the points for helping me.
0
 
LVL 35

Accepted Solution

by:
Cris Hanna earned 500 total points
Comment Utility
you would have to select one of my posts and mark it as "helpful" by pressing yes.  it will walk you the rest of the process
0
 
LVL 1

Author Closing Comment

by:jimmylew52
Comment Utility
Solution was reached but not provided by expert
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now