Link to home
Start Free TrialLog in
Avatar of XGIS
XGISFlag for Australia

asked on

ASPMaker Upload Files to SQL 2008 R2 with IIS 7.5

We are having timeout issues uploading the file to the server using ASPMaker (max uploads set to 100Mb).  The actual ASP application is nested in an ASP.NET application and the files being uploaded are from 2Mb to 20Mb.  These are SWF files and ONLY the file name is being stored in the database, where the files go to a folder.  BOTH machines are Windows Server 2008R2 64x.

Note the application is served as a virtual directory for editing outside of the ASP.NET application in the browser.

The IIS settings should be inherited from the primary ASP.NET application through the ASP settings. We have increased the max uploads in the ASP settings to 100Mb but we are still getting the following message on failure (progress bar at 100%);

Server Error500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

Is there another IIS consideration? or could it be a web.config issue?
SOLUTION
Avatar of simonseztech
simonseztech
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of XGIS

ASKER

I made the following modifications to IIS as well as checked permissions. I then tested each but the result was the same.
IIS75-Modifications-Timeouts-Siz.gif
Avatar of XGIS

ASKER

I changed this value in ASPMaker which I have not had to modify in the past versions. We were also serving on a W2K3 server which required the equivalent changes both of you suggested. Thankyou for your time. I may have to reduce the timeouts in IIS75 now just so my ASP.NET app doesn't go to sleep for 10min.
ASPMaker-Video-Upload-Timeout-So.gif
Avatar of XGIS

ASKER

Thanks simonseztech
always a pleasure.