• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 606
  • Last Modified:

Connecting two windows 2008r2 servers

Hi

I have two servers each with two network cards.  The first card is linked to the public internet, the second are used to link the two servers together internally via a direct cable between the two machines.

I setup the internal card to use IP addresses 10.10.11.10 and 10.10.11.11 and left the gateway and dns blank.  This is what I have done with win2003 in the past but with win2008 it refuses to connect.

So I tried setting the gateway of 10.10.11.10 to 10.10.11.11 and the reverse on the other server.  That worked and now the machines can communicate but for some reason that breaks the DNS which was working on the other card just fine.  Basicially I have not been able to get both networks connected without problems at the same time.

What are the correct settings to link two 2008r2 servers together?
0
meagord
Asked:
meagord
  • 5
  • 3
1 Solution
 
amr-itCommented:
Did you define a subnetmask for the private network?
0
 
meagordAuthor Commented:
Yes

Server A
IP 10.10.11.10
subnet 255.255.255.0
Gateway/DNS blank

Server B
IP 10.10.11.11
subnet 255.255.255.0
Gateway/DNS blank

Does not connect at all

Also tried
Server A
IP 10.10.11.10
subnet 255.255.255.0
Gateway 10.10.11.11

Server B
IP 10.10.11.11
subnet 255.255.255.0
Gateway 10.10.11.10

Connects and works perfectly but DNS then fails on the server, it somehow interferes with the dns setting on the internet facing nic..
0
 
amr-itCommented:
I'm not sure i have a solution, but i'm sure that a gateway on both is net the way.
did you try to ad a route on each server as this on the first:
route add -p 10.10.11.11 mask 255.255.255.0 10.10.11.10
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
meagordAuthor Commented:
No idea how to "add a route".

All I've done is change the values in the network interface/ip4 settings.
0
 
amr-itCommented:
remove gateways from private nic's

type in command promt on server 1 -  route add -p 10.10.11.11 mask 255.255.255.0 10.10.11.10

type in command promt on server 2 -  route add -p 10.10.11.10 mask 255.255.255.0 10.10.11.11
0
 
meagordAuthor Commented:
No difference, it still says "Unidentified Network".
0
 
meagordAuthor Commented:
I changed the unidentified network to be a Private network and now I can ping the other server but file transfers all go through the slow public nic rather than the direct connection (even after your routing commends.)

I also disabled the firewall for that nic on both machines.
0
 
meagordAuthor Commented:
Ok for anyone reading this here's what I found.

OK it would seem that the routing is fine but WINS always operates on the internet facing network card by default, I couldn't find a way to override this behaviour.  Sending files using the IP address works fine though.

Also apparently Windows 2008 shows any network without a gateway as unidentified and then sets it to Public.  To permanently change the network to Private so that the change survives a reboot you have to complete the changes here.  The only other way is to remove the firewall from the nic as far as I can tell.

http://social.technet.microsoft.com/Forums/en-US/winserverPN/thread/58e53691-64cd-44b9-98a2-ff1697e3ea83

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now