update model from database

Hi experts, I can not update the model. edmx file from visual studio. I upgraded a stored  procedure in the database (add 2 parameters) and I can not give yourself visual studio upgrade. I get success message, but I can not update
Here's how
1. right click on the file. edmx file
2. select updating model
3. update tab select the stored procedure
4. I press end
5. the procedure is not updated in the model

i am using visual studio 2008
usp.jpg
modelEXPLORER.jpg
enrique_aeoAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Kevin CrossConnect With a Mentor Chief Technology OfficerCommented:
Hmmmm.  Worked fine for me, but I am using VS 2010.  Just in case, this is what I did (which to me seems like what you did -- but listing out in case you catch something).

(1) Updated Stored Procedure Parameter Definition in SQL Server
(2) Opened Entity Model Browser
(3) Right-click on {model file name}.edmx or {ModelName}.Store
(4) Select Update Model from Database
(5) Click on Refresh tab
(6) Expanded Stored Procedure and highlighted {procedure name} OR highlight Stored Procedures (updates all)
(7) Click Finish

Got these results:
Generated model file: Model1.edmx.
Loading metadata from the database took 00:00:03.6419677.
Generating the model took 00:00:01.5014046.

After that, using Model Browser, the changes to my procedure parameters are now visible in VS.
0
 
Gautham JanardhanCommented:
are you referring to the function ?  was the return type of the stored proc changed ?
0
 
Gautham JanardhanConnect With a Mentor Commented:
The function import wont get updated automatically on refreshing the model. You will have to delete the function import and then add a new one so that the new parameters will be recognised by the entity container
0
 
enrique_aeoAuthor Commented:
Thanks experts, if we look closely the graph if the parameter is added, only the alphabetically ordered by visualization studio
0
All Courses

From novice to tech pro — start learning today.