Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Apache subdirectory Not Found

Posted on 2010-09-11
7
Medium Priority
?
650 Views
Last Modified: 2012-08-13
i am a complete newbie to apache, but have got the server to work on Windows 2003 serving a folder "www" where index.html is displayed nicely.
however, i have a created a subfolder under "www", and i cannot manage to give access to another index.html file under that subfolder? what is wrong with my directives below? when i browse to http://localhost/expo/ on the server machine i get the error message:
---
Not Found
The requested URL /expo/ was not found on this server.
---
<Directory "C:/Program Files/csvn/www/expo">
  AllowOverride All
  Options All
  Order allow,deny
  Allow from all
</Directory>

Open in new window

0
Comment
Question by:KristjanLaane
  • 4
  • 2
7 Comments
 

Author Comment

by:KristjanLaane
ID: 33652601
sorry, i got that to work, my question is actually when i browse to teh expo directly and there is no index.html in there , why does it not show me a listing of the files in that directory, because Options All is on, which shoudl incorporate Indexes:

Indexes:       If a URL which maps to a directory is requested, and there       is no DirectoryIndex       (e.g., index.html) in that directory, then       mod_autoindex will return a formatted listing       of the directory.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 33654831
You may have a problem with it being under "C:/Program Files/" because that requires special privileges.  You should put it under "C:/csvn/www/expo" so it only has to deal with it's own privileges.
0
 
LVL 21

Accepted Solution

by:
Julian Matz earned 2000 total points
ID: 33654841
Do you have the mod_autoindex module installed/loaded?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 

Author Comment

by:KristjanLaane
ID: 33656096
i see! autoindex seems not to be loaded, but when i add the below line to httpd.conf then the server refuses to start?



LoadModule autoindex lib/modules/mod_autoindex.so

Open in new window

0
 
LVL 21

Assisted Solution

by:Julian Matz
Julian Matz earned 2000 total points
ID: 33657130
You should be able to get more information about why Apache won't start from Apache's error log.

You could also try running a config test. In Linux, this can be done by running one of these commands:

apachectl configtest
apache2ctl configtest

I'm not sure what it is in Windows, but check if there might be a shortcut in the Windows Start menu - called "Configuartion Test".
0
 

Author Closing Comment

by:KristjanLaane
ID: 33660129
thanks, ill try to find the config test! (im using a special install of apache from collabnet, so will ask them where it might be)
0
 

Author Comment

by:KristjanLaane
ID: 33669576
just to let anyone with similar issues know, i found a solution:

to do config test:
httpd -t -f data\conf\httpd.conf

(see http://subversion.open.collab.net/ds/viewMessage.do?dsForumId=4&dsMessageId=382859 )

the above syntax was wrong, the line should be:
LoadModule autoindex_module lib/modules/mod_autoindex.so

(see http://subversion.open.collab.net/ds/viewMessage.do?dsForumId=4&dsMessageId=382916)
0

Featured Post

Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question