Solved

NO AUDIO ON VOICEFLEX SIP TRUNK WITH ALCATEL OMNI PCX (WATCHGUARD X750e)

Posted on 2010-09-11
17
1,704 Views
Last Modified: 2012-05-10
Hello all - I have an annoying problem with SIP calls. the call goes through but no audio in both directions. Apparently you cant add a stun setting on the omni PCX? Apparently the PABX is passing the local 192.168.1.x address to the SIP provider, however noone seems to know a resolution! Will give 500 points as rtearing my hair out now!

Thanks
0
Comment
Question by:datafocus
17 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
Comment Utility
HI,

Please show the netwrork topology...
0
 
LVL 6

Expert Comment

by:dinkon4u
Comment Utility
Place/Enable Session Border Controller in between Provider and your PBX.
I know cisco has device for SBC.
HTH
0
 
LVL 32

Expert Comment

by:dpk_wal
Comment Utility
Do you get any deny messages in the System Manager->Traffic monitor when this happens; this would help understand if firewall is blocking any traffic.

Few questions:
1. Is NAT configured for PBX.
2. If yes, then what type, dynamic or 1-1.
3. Which policy is configured on firewall.

If feasible for testing configure ANY policy and 1-1 NAT and check if this helps.

Thank you.
0
 

Author Comment

by:datafocus
Comment Utility
Hi,
Yes - tried ANY first - calls come up but no Audio. Tried Dynamic & 1 to 1 NAT...
have set logging but nothing seems to get allowed or denied in traffic manager.
Thanks
0
 
LVL 32

Expert Comment

by:dpk_wal
Comment Utility
If possible put PBX outside the firewall and then check the behavior.

Thank you.
0
 

Author Comment

by:datafocus
Comment Utility
Hi,
Not really possible. Voiceflex are saying the PABX is advertising its internal IP & this is clearly what the problem is... What I need to know is how to get it to display the external IP.
However, Alcatel doesnt have a STUN setting & Watchguard say this isnt possible?
 
Any one any ideas?
0
 
LVL 32

Expert Comment

by:dpk_wal
Comment Utility
Sorry dont think this comment is of much help to you but still putting it:

As you said PABX is on private IP; so it must be using firebox external interface IP by default; if you setup 1-1 NAT then it would advertise the 1-1 NAT public IP.

Am not sure if this is an option; but can you open web browser on PABX and go to http://www.whatismyip.com; this would show the public IP of PABX as seen to everyone. OR may be initiate any session from PABX and do packet capture on external interface of firebox and see what the packets have as the source IP for the specific port/protocol/destination.

Thank you.
0
 

Author Comment

by:datafocus
Comment Utility
The SIP Provider states that it is advertising the PRIVATE ip....
Thanks

policy.PNG
advanced.PNG
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:datafocus
Comment Utility
When I change to 1 to 1 NAT it no longer makes or receives calls....
0
 
LVL 32

Expert Comment

by:dpk_wal
Comment Utility
Do not configure policy based NAT. Revert to "Use Network NAT Settings".

Current policy only allows outbound traffic from internal host 192.168.1.246 to external host 146.x.x.x.

Assuming you wish to allow all inbound traffic from 146.x.x.x to 217.y.y.202, add 1-1 NAT and add one more ANY service and configure as below:
Enabled and allowed; from 146.x.x.x; to 217.y.y.202

To ensure 1-1 NAT is configured properly, please look at link below:
http://watchguard.custhelp.com/app/answers/detail/a_id/1545/kw/1-1%20NAT/p/214%2C215/sno/1

Finally make sure that 217.y.y.202 IP is not listed under external alias [used for static NAT]:
http://watchguard.custhelp.com/app/answers/detail/a_id/1497/kw/adding%20external%20alias

Thank you.
0
 

Author Comment

by:datafocus
Comment Utility
202 is the main IP address - i.e. not an alias. Is this what you mean?
0
 

Author Comment

by:datafocus
Comment Utility
So I have created a separate outbound policy as below... with 1 to 1 NAT
nat-SIPRTP.JPG
0
 

Author Comment

by:datafocus
Comment Utility
Policy
sip-RTP.JPG
0
 
LVL 32

Accepted Solution

by:
dpk_wal earned 500 total points
Comment Utility
202 is the public IP of firebox external interface; then you cannot use it for 1-1 NAT and also the incoming part of the service would not get configured the way explained above.

I thought you have .202 dedicated only for PBX. If so, then ensure that .202 is not added as alias [to be used in policies using static NAT (what I tried to list in the my earlier post)].

Most of times PAT causes problems with voice protocols hence using 1-1 NAT is preferred but for 1-1 NAT you must have one public IP dedicated only for PBX other than the public IP of your firebox.

Let me know if I got you confused.

Thank you.
0
 

Author Comment

by:datafocus
Comment Utility
Are you saying I need a spare IP that is not an alias? I dont have any spare.
0
 

Author Closing Comment

by:datafocus
Comment Utility
Great! Thanks for that. I think it was just the alias thing I hadnt tried... works fine with an aliased IP.

Thanks for your help!
0
 
LVL 32

Expert Comment

by:dpk_wal
Comment Utility
Welcome; Happy to be of assistance.

Thank you.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now