[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1245
  • Last Modified:

exchange 2007 smtp help

exchange 2007 sp3 enterprise 64bit edition

I have a command line utility febooti that i use in cmd files to send email

on my exchange server it works great if I point to another smtp server

but when I try to point it to the exchange server (server5) it fails

here is the command

c:\util\febooti\febootimail -from tgcs005@tgcsnet.com -to thomasrgrassijr@tgcsnet.com -msg "http://www.broadcom.com/support/ethernet_nic/netxtreme_desktop.php" -subj "Web Site Link" -smtp 192.168.xxx.26

.26 is server5 exchange 2007

.25 is server4 exchange 2000

if I change .26 to .25 it works

the error I get is

smtp error an unexpected responce after mail from command
couldn't send message server responce 530 5.7.1 client was not authenticated

now on exchange 2000 I was able to configure smtp with no problem

Not too familar with 2007


Any help would be great

Thanks

Tom

0
Inserachof
Asked:
Inserachof
  • 28
  • 27
  • 8
  • +2
2 Solutions
 
craig_j_LawrenceCommented:
Hi you will need to configure your recieve connector to accept connections from the IP address you are sending from, and allow unauthenticated connections.

Best practice is to create a receive connector that is "locked down" when enabling unauthenticated connections.
From the Exchange Management shell run the following command to create a new receive connenctor:
new-receiveconnector -name "febooti connector" -usage custom -authmechanism none -bindings 192.168.xx.26 -remoteipranges <ipaddress of host sending email>

Refer to this technet article for more details: http://technet.microsoft.com/en-us/library/bb125139(EXCHG.80).aspx
0
 
InserachofAuthor Commented:
thanks craig

I tried the command but not sure what i did wrong here can you take a look

[PS] C:\Documents and Settings\Administrator.OUR>new-receiveconnector -name "tgc
snet connector" -usage custom -authmechanism none -bindings 192.168.69.26 -remot
eipranges 192.168.69.10 192.168.69.15 192.168.69.12
New-ReceiveConnector : Cannot bind parameter 'Bindings'. Cannot convert value "
192.168.69.26" to type "Microsoft.Exchange.Data.IPBinding". Error: "The separat
or between the IP address and the port number is missing. The format for an IPB
inding is <IP address>:<port number>."
At line:1 char:91
+ new-receiveconnector -name "tgcsnet connector" -usage custom -authmechanism n
one -bindings <<<<  192.168.69.26 -remoteipranges 192.168.69.10 192.168.69.15 1
92.168.69.12
    + CategoryInfo          : InvalidArgument: (:) [New-ReceiveConnector], Par
   ameterBindingException
    + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.Exchang
   e.Management.SystemConfigurationTasks.NewReceiveConnector

thanks

tom
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
craig_j_LawrenceCommented:
Hi Tom - you need to add the port to the binding as well: -bindings 192.168.69.26:25
0
 
craig_j_LawrenceCommented:
you will also need commas in between each IP address in the remote IP ranges
0
 
InserachofAuthor Commented:
craig
thanks the command workled now

I have two other receive connectors that where defined by installation and are enabled
I disabled both of them and the one we just created is the only one enabled

Does the change take effect imeediately or do I have to restart something

only reason is I still cannot send email out

I also have a send connector in the organization configuration

that i created via the gui

could that be the problem?

0
 
craig_j_LawrenceCommented:
Hi Tom - you need both send a receive connectors. Are you getting the same error? Can you manually try and send an email from the command line with the following command:

telnet 192.168.69.26 25

mail from:tgcs005@tgcsnet.com
rcpt to:thomasrgrassijr@tgcsnet.com
data
test msg
.

please post back the results
0
 
craig_j_LawrenceCommented:
I wouldnt disable the other ones, you wont be able to receive mail from anywhere else if you do that!
0
 
dccjCommented:
If you are on the Exchange server, you can also just copy a formatted file to a folder in the Exchange tree. Are you one the server? This works for 2003 and 2007 anyway. You can easily create the file with with a batch file. Let me know if this helps and I'll post the format.
0
 
craig_j_LawrenceCommented:
i forgot a command in the manual telnet above:

telnet 192.168.69.26 25
helo
mail from:tgcs005@tgcsnet.com
rcpt to:thomasrgrassijr@tgcsnet.com
data
test msg
.

Also, take a look at the netometer video from the link above my original reply
0
 
InserachofAuthor Commented:
Craig

was not able to telnet until I enabled the other two connectors

but now I can

220 tgcs005.our.network.tgcsnet.com Microsoft ESMTP MAIL Service ready at Sun, 1
2 Sep 2010 00:33:12 -0400
helo
250 tgcs005.our.network.tgcsnet.com Hello [192.168.69.100]
mail from:admin02@tgcsnet.com
530 5.7.1 Client was not authenticated


Connection to host lost.


this is what I got
0
 
craig_j_LawrenceCommented:
You have added the .100 address to the receive connector you create, therefore it will attempt to use the default connector.

I recommend looking at this link: http://www.netometer.com/video/tutorials/allow-relay-in-exchange-server-2007/

It will provide a video that you can follow to configure the connector correctly

HTH
Craig
0
 
dccjCommented:
Remember that after you get all of this working, you need to go back and make sure you haven't turned on relaying or some other security nightmare. That's why the file copy method is safe and simple.
0
 
craig_j_LawrenceCommented:
@dcci - what file copy method are you describing?? the method that I an describing is the best practice method of allowing another computer to send email
0
 
dccjCommented:
If you have access to teh Exchange foleder tree, you can create a file with the from, to, subject and data and copy it to a particular folder. I don't have it all in front of me, but I can supply an example if need be. I use it for a script I wrote that uses robocopy to mirror a folder to a backup drive. I log all of the information, write it all to a file including the pass/fail status of teh backup in teh subject, and then copy it over. Exchange picks it up (it may be the pickup folder) and automatically mails it. The security configuration of Exchange doesn't matter. It's purely a file copy process. No smtp, just a formatted file. It's simple.
0
 
InserachofAuthor Commented:
craig

the telnet is now working I was doing the telnet from my workstation I did it on the server one of the ip addresses that I added in the connector and after I made three changes to the connector it works the video gave me some ideas
the connector properties in the permission tab I checked Exchange servers clicked apply
the in the authenciation tab I checked Externallysecured clicked apply
and i checked transport layer security click apply and then ok

the telnet seesion then sent the email to the que

I never got the email tho

could that be a problem with the send connector I defined smtp?

Where can I look to find what is in the queue to be sent I know iin 2000 but not in 2007 still trying to figure this out
0
 
endital1097Commented:
you can go to the tools in the exhange management console
there is a queue viewer tool inside the tools

where is the destination of the message, a mailbox on the 2000 or 2007 server?
if it is the 2000 server, verify you have a routing group connector in place
get-routinggroupconnector
0
 
InserachofAuthor Commented:
thanks I found that while i was poking around the tools that is

good call on exchange 2000 yes one of the email addresses is going to my exchange 2000 mailbox

I did a get-routinggroupconnector and received no results I guess I do not have one

could this be why I am getting this event
Type :            Warning
Date :            9/12/2010
Time :            9:33:02 AM
Event :            5006
Source :            MSExchangeTransport
Category :      Routing
User :            N/A
Computer :      TGCS005
Description:
The description for Event ID ( 5006 ) in Source ( MSExchangeTransport ) could not be found. It contains the following insertion string(s): .
CN=TGCS004,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=TGCSNET,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com
CN=Mailbox Store (TGCS004),CN=First Storage Group,CN=InformationStore,CN=TGCS004,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=TGCSNET,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com
9/12/2010 1:33:02 PM


since I am a exchange 2007 newbie

what would the command be I need to define a routing group connector for this


As you can tell I am in the process of migrating from 2000 to 2007 I will need this only till I get all the mailboxes over to 2007 I can then disable this connector


The other email I was sending to was an external email address which I checked and that is still in the queue also it is to my cell phone email address  I think my smtp connector is the problem need help on that also

Thanks
0
 
endital1097Commented:
you want to run the following
New-RoutingGroupConnector -Name "Some Name" -SourceTransportServers ex2007 -TargetTransportServers ex2000 -BiDirectional:$true

this will create the connector in both the 2007 and 2000 routing groups
0
 
endital1097Commented:
the route for the external may be destined for the smtp conector on 2000 which it can't reach
let's get mail flowing between the two first
0
 
InserachofAuthor Commented:
my pc outlook is stil on 2000 server and I tried to send to one of the email account on 2007 and it gave me a delivery failure notices

you want to run the following
New-RoutingGroupConnector -Name "Some Name" -SourceTransportServers ex2007 -TargetTransportServers ex2000 -BiDirectional:$true

this will create the connector in both the 2007 and 2000 routing groups

I tried to send to my email address from the mailboxx on 2007 and never received the message

The routing connector is defined

here is the defintion

New-RoutingGroupConnector -Name "TGCSNET Routing Connector" -SourceTransportServers tgcs005.our.network.tgcsnet.com -TargetTransportServers tgcs004.our.network.tgcsnet.com -BiDirectional:$true

this will create the connector in both the 2007 and 2000 routing groups



[PS] C:\Documents and Settings\Administrator.OUR>get-routinggroupconnector

Name                      SourceRoutingGroup         TargetRoutingGroup
----                      ------------------         ------------------
TGCSNET Routing Connector Exchange Routing Group ... First Routing Group
TGCSNET Routing Connector First Routing Group        Exchange Routing Group ...

after this do I need to restart a service? on either exchange server?

0
 
endital1097Commented:
i would restart smtp on 2000
and the transport service on 2007
0
 
InserachofAuthor Commented:
after restarting the services still no luck here

checking withqueue viewer I found in the messages tab the messages i am trying to send to the 2000 ex mailbox from the 2007 mb they have a scl of -1 message source name is fromlocal  no last error info

i am missing something here
0
 
endital1097Commented:
you could alway attempt to connect ot the 2000 server from 2007
telnet ex2000 25

then try the reverse from 2000 to 2007
0
 
InserachofAuthor Commented:
ok here are the results of telnet


this is exchange 2000 server going to exchange 2007

220 tgcs004.our.network.tgcsnet.com Microsoft ESMTP MAIL Service, Version: 5.0.2
195.7381 ready at  Sun, 12 Sep 2010 12:09:44 -0400
250 tgcs004.our.network.tgcsnet.com Hello [192.168.69.25]
500 5.3.3 Unrecognized command
250 2.1.0 thomasrgrassijr@tgcsnet.com....Sender OK
250 2.1.5 admin01@tgcsnet.com
354 Start mail input; end with <CRLF>.<CRLF>
250 2.6.0 <TGCS004ihBhgCHev1Ff00000002@tgcs004.our.network.tgcsnet.com> Queued m
ail for delivery

this is exchange 2007 going to exchange 2000

220 tgcs004.our.network.tgcsnet.com Microsoft ESMTP MAIL Service, Version: 5.0.2
195.7381 ready at  Sun, 12 Sep 2010 12:11:50 -0400
helo
250 tgcs004.our.network.tgcsnet.com Hello [192.168.69.26]
mail from:thomasrgrassijr@tgcsnet.com
501 5.5.4 Invalid Address
mail from:admin01@tgcsnet.com
501 5.5.4 Invalid Address

2007 having an issue getting to the 2000 server????
0
 
endital1097Commented:
you're connecting and that is the important part
your syntax is off
mail from: thomasrgrassijr@tgcsnet.com

you need the space
0
 
InserachofAuthor Commented:
yes bad eyes today

I got this in my inbox

Your message did not reach some or all of the intended recipients.

      Subject:      
      Sent:      9/12/2010 12:33 PM

The following recipient(s) cannot be reached:

      Admin 001 on 9/12/2010 12:34 PM
            A configuration error in the e-mail system caused the message to bounce between two servers or to be forwarded between two recipients.  Contact your administrator.
            <tgcs004.our.network.tgcsnet.com #4.4.6>

any thoughts
0
 
endital1097Commented:
go into queue viewer and see what the error is
can you attempt to send from a 2000 mailbox to a 2007 mailbox
0
 
endital1097Commented:
0
 
InserachofAuthor Commented:
that was from an exchange box 2000

from the queue I see no error messages

a status of ready

i made the registry change on 2000 and still no email

here is the entry from the queue

Identity: tgcs005\5\29
Subject: testing after registry updates
Internet Message ID: <A02C505A23234948850038B581EF80DC020540CEFB@tgcs005.our.network.tgcsnet.com>
From Address: admin02@tgcsnet.com
Status: Ready
Size (KB): 4
Message Source Name: FromLocal
Source IP: 255.255.255.255
SCL: -1
Date Received: 9/12/2010 12:57:33 PM
Expiration Time: 9/14/2010 12:57:33 PM
Last Error:
Queue ID: tgcs005\5
Recipients:  ThomasRGrassiJr@tgcsnet.com


0
 
endital1097Commented:
what is the queue name where this message is
0
 
InserachofAuthor Commented:
here is a export list of my entire queue

From Address      Status      Size (KB)      SCL      Queue ID      Message Source Name      Subject      Last Error
admin01@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      testing exchange routing connector      
admin01@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      testing exchange routing connector 2      
admin01@tgcsnet.com      Ready      5      -1      tgcs005\5      FromLocal      lets test all 3      
admin01@tgcsnet.com      Ready      2      -1      tgcs005\Unreachable      FromLocal      lets test all 3      A matching connector cannot be found to route the external recipient
admin01@tgcsnet.com      Ready      5      -1      tgcs005\5      FromLocal      testing all 3 again      
admin01@tgcsnet.com      Ready      2      -1      tgcs005\Unreachable      FromLocal      testing all 3 again      A matching connector cannot be found to route the external recipient
admin02@tgcsnet.com      Ready      1      0      tgcs005\Unreachable      SMTP:tgcsnet connector            A matching connector cannot be found to route the external recipient
admin02@tgcsnet.com      Ready      1      0      tgcs005\5      SMTP:tgcsnet connector            400 4.4.7 Message delayed
admin02@tgcsnet.com      Ready      1      0      tgcs005\Unreachable      SMTP:tgcsnet connector            A matching connector cannot be found to route the external recipient
admin02@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      Testing routng connector      
admin02@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      testing after registry updates      
PublicFolderDatabase@tgcsnet.com      Ready      3      -1      tgcs005\5      FromLocal      Hierarchy      
PublicFolderDatabase@tgcsnet.com      Ready      3      -1      tgcs005\5      FromLocal      Hierarchy      
PublicFolderDatabase@tgcsnet.com      Ready      3      -1      tgcs005\5      FromLocal      Status      


does that help
0
 
endital1097Commented:
check this, i'll review what you just posted
http://technet.microsoft.com/en-us/library/cc411329(EXCHG.80).aspx
0
 
endital1097Commented:
i'll be heading out soon and just wanted to follow up to see how things were going
0
 
endital1097Commented:
on your exchange 2000 server go to the smtp virtaul server settings
under the access tab (i believe) there should be authentication
verify that  windows integrated authentication is enabled
0
 
InserachofAuthor Commented:
checked it is set to anonymous

I was able to telnet mx1.hotmail.com 25 on both 2000 and 2007 servers
0
 
endital1097Commented:
enable windows integrated
0
 
InserachofAuthor Commented:
I cant the server is hosed

My outlook clients now cannot connect to the 2000 server at all

they say trying to connect

Type :            Error
Date :            9/13/2010
Time :            9:57:50 AM
Event :            36871
Source :            Schannel
Category :      None
User :            N/A
Computer :      TGCS004
Description:
A fatal error occurred while creating an SSL server credential.

Type :            Error
Date :            9/13/2010
Time :            9:57:50 AM
Event :            36871
Source :            Schannel
Category :      None
User :            N/A
Computer :      TGCS004
Description:
A fatal error occurred while creating an SSL server credential.

Type :            Error
Date :            9/13/2010
Time :            10:01:57 AM
Event :            10009
Source :            DCOM
Category :      None
User :            OUR\Administrator
Computer :      TGCS004
Description:
DCOM was unable to communicate with the computer TGCS005 using any of the configured
protocols.

these are the errors I am getting now I am very upset this is not good no email anywhere even the 2007 server is not working now

I want to take the 2000 server offline and get the 2007 up and working but now I am at a loss
0
 
endital1097Commented:
are the services still running on the 2000 server?

are messages between 2007 mailboxes being delivered?
0
 
InserachofAuthor Commented:
yes all the services are up and running
funny thing I am getting the email from 2000 on my blackberry but not to my outlook client

on the 2007 boxes

I get this
sending complete
Microsoft exchange serer error
Task microsoft exchange server reported error 0x8004010f the operation failed
an object could not be found

but I can send email to and from a 2007 box still but I get this error everytime doing so

I have no hair left on this
0
 
endital1097Commented:
that send/receive error is most likely an oab error

go into exchange management console
go to tools
open queue viewer

verify that no messages are getting stuck in the queue
0
 
endital1097Commented:
0x8004010f is object not found
click view more details it should show the offline address book

also look for SharePoint Lists in your folder list of Outlook, this could also be a cause
0
 
InserachofAuthor Commented:
I removed the entries in the queue and still get the same error

I have no offline address book listed

and no sharepoint lists in my outlook folders

I do still have three enteries stuck in the queue

they are in public folder database ????? the details show that they are going to the 2000 server???
0
 
endital1097Commented:
yes, you need to run the MoveAllReplicas.ps1 script from the 2007 server to end public folder replication
the script is located in c:\program files\microsoft\exchange server\scripts
0
 
endital1097Commented:
you can also use this site to test smtp
https://testexchangeconnectivity.com/
0
 
InserachofAuthor Commented:
I will run the scrip and post

here is the test results hum????

Testing Inbound SMTP Mail flow for domain thomasrgrassijr@tgcsnet.com
 Failed to test inbound SMTP mail flow.
 Test Steps
 Attempting to retrieve DNS MX records for domain tgcsnet.com
 One or more MX records were successfully retrieved from DNS.
 Additional Details
 MX Records Host smtp.tgcsnet.com, Preference 0
, Host mail.tgcsnet.com, Preference 10


Testing Mail Exchanger smtp.tgcsnet.com.
 One or more SMTP tests failed for this Mail Exchanger.
 Test Steps
 Attempting to resolve the host name smtp.tgcsnet.com in DNS.
 The Host could not be resolved.
  Tell me more about this issue and how to resolve it
 Additional Details
 Host smtp.tgcsnet.com could not be resolved in DNS Exception details:
Message: The requested name is valid, but no data of the requested type was found
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()

I think we have a problem houston
0
 
endital1097Commented:
i see two mx records for you
smtp and mail
i'm going to guess that mail is referring to the 2000 and smtp was created for 2007
if yes, you should just update your firewall to forward all smtp traffic (port 25) to the 2007 server

if not,
there is no A record in your external DNS for smtp, you need to create one
you also need to update the MX record cost for smtp so that it does not equal 0
0
 
endital1097Commented:
i verified that mail goes to 4 and not 5
update your configuration as need to accomplish the switch
0
 
InserachofAuthor Commented:
yes I was just checking my cisco router and I see what I need to change

After I make that change I will post
0
 
endital1097Commented:
great, you'll want to consider removing the other MX record
0
 
InserachofAuthor Commented:
I figured out what is wrong with the 2007 boxes that are getting that error you will never guess

Remember I told you my 2000 box outlookclients are not connecting well I know why both are the same issue

On the 2000 server I went into exchange server management
expanded the mailboxes and guess what

the two test boxe on 2007 that I moved are back on the 2000 server and my 2000 boxes are gone

dont know how that happend and not sure if I want to know

I am not in a hurry up mode to get all mb moved over doing it manually very painful but needs to be done

got to get rid of this 2000 server asap so I can constrate on the 2007 issues

will post later

I only have one external mx record and a cname record

but i will doube check  once I change the router and take the 2000 server offline we will see what happens
0
 
endital1097Commented:
waiting to hear more
0
 
InserachofAuthor Commented:
can you try your test to see if mail is going to 5 now instead  of 4

I got the router changed

but still no external email
0
 
endital1097Commented:
connection to mail times out
smtp still not found
0
 
InserachofAuthor Commented:
I ran and outbound smtp test per you link here are the results of that

Performing Outbound SMTP Test
 Outbound SMTP Test Successful
 Test Steps
 Attempting reverse DNS lookup for IP 72.88.223.20
 Successfully resolved IP 72.88.223.20 via Reverse-DNS lookup
 Additional Details
 Resolved IP address 72.88.223.20 to host static-72-88-223-20.nwrknj.fios.verizon.net

Performing Real-Time Blackhole List (RBL) Test
 Your IP address wasn't found on any of the block lists selected.
 Test Steps
 Checking Block List "SpamHaus Block List (SBL)"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "SpamHaus Exploits Block List (XBL)"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "SpamHaus Policy Block List (PBL)"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "SpamCop Block List"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "NJABL.ORG Block List"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "SORBS Block List"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "MSRBL Combined Block List"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "UCEPROTECT Level 1 Block List"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL

Checking Block List "AHBL Block List"
 The address isn't on the block list.
 Additional Details
 IP 72.88.223.20 was not found on RBL



Performing Sender ID validation
 Sender ID validation performed successfully
 Test Steps
 ExRCA is attempting to find the SPF record using a DNS TEXT record query.
 ExRCA wasn't able to find the SPF record.
 Additional Details
 No records were found.

here is the inbound test again

Testing Inbound SMTP Mail flow for domain thomasrgrassijr@tgcsnet.com
 Failed to test inbound SMTP mail flow.
 Test Steps
 Attempting to retrieve DNS MX records for domain tgcsnet.com
 One or more MX records were successfully retrieved from DNS.
 Additional Details
 MX Records Host smtp.tgcsnet.com, Preference 0
, Host mail.tgcsnet.com, Preference 10


Testing Mail Exchanger smtp.tgcsnet.com.
 One or more SMTP tests failed for this Mail Exchanger.
 Test Steps
 Attempting to resolve the host name smtp.tgcsnet.com in DNS.
 The Host could not be resolved.
  Tell me more about this issue and how to resolve it
 Additional Details
 Host smtp.tgcsnet.com could not be resolved in DNS Exception details:
Message: The requested name is valid, but no data of the requested type was found
Type: System.Net.Sockets.SocketException
Stack trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at Microsoft.Exchange.Tools.ExRca.Tests.ResolveHostTest.PerformTestReally()

0
 
InserachofAuthor Commented:
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\thomas r grassi jr.OUR>nslookup
Default Server:  tgcs001.our.network.tgcsnet.com
Address:  192.168.69.10

> set q=mx
www.tgcsnet.com
Server:  tgcs001.our.network.tgcsnet.com
Address:  192.168.69.10

tgcsnet.com
        primary name server = tgcs001.our.network.tgcsnet.com
        responsible mail addr = hostmaster.our.network.tgcsnet.com
        serial  = 16
        refresh = 900 (15 mins)
        retry   = 600 (10 mins)
        expire  = 86400 (1 day)
        default TTL = 3600 (1 hour)
> server 4.2.2.1
Default Server:  vnsc-pri.sys.gtei.net
Address:  4.2.2.1

> set q=mx
www.tgcsnet.com
Server:  vnsc-pri.sys.gtei.net
Address:  4.2.2.1

Non-authoritative answer:
www.tgcsnet.com canonical name = tgcsnet.com
tgcsnet.com     MX preference = 10, mail exchanger = mail.tgcsnet.com
tgcsnet.com     MX preference = 0, mail exchanger = smtp.tgcsnet.com
>

this was a nslookup test
0
 
endital1097Commented:
mail is not accepting connections at this time
there is no A record for smtp
0
 
InserachofAuthor Commented:
is it something we did on the 2007 server for conectity to exchange 2000?

I shutdown the 2000 server
0
 
endital1097Commented:
what was updated for inbound mail
did you switch the firewall/router to send to 2007
0
 
InserachofAuthor Commented:
no firewall on this server

router was updated changed to point port 25 to the 2007 server
0
 
endital1097Commented:
can you check your router because the connection is timing out

also can you post the results:
get-receiveconnector | fl name,remote*,perm*
0
 
InserachofAuthor Commented:

         Welcome to the Exchange Management Shell!

 Full list of cmdlets:          get-command
 Only Exchange cmdlets:         get-excommand
 Cmdlets for a specific role:   get-help -role *UM* or *Mailbox*
 Get general help:              help
 Get help for a cmdlet:         help <cmdlet-name> or <cmdlet-name> -?
 Show quick reference guide:    quickref
 Exchange team blog:            get-exblog
 Show full output for a cmd:    <cmd> | format-list

Tip of the day #78:

The Exchange Management Shell can log all the Exchange-related commands that mod
ify objects in some way. Exchange-related command activity is logged to the Powe
rShell event log. To enable Exchange-related command logging, run the following
command:

Set-ItemProperty HKLM:\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microso
ft.Exchange.Management.PowerShell.Admin -Name LogpipelineExecutionDetails -value
 1

[PS] C:\Documents and Settings\Administrator.OUR>get-receiveconnector | fl name,
remote*,perm*


Name             : Default TGCS005
RemoteIPRanges   : {0000:0000:0000:0000:0000:0000:0.0.0.0-ffff:ffff:ffff:ffff:f
                   fff:ffff:255.255.255.255, 0.0.0.0-255.255.255.255}
PermissionGroups : ExchangeUsers, ExchangeServers, ExchangeLegacyServers

Name             : Client TGCS005
RemoteIPRanges   : {0000:0000:0000:0000:0000:0000:0.0.0.0-ffff:ffff:ffff:ffff:f
                   fff:ffff:255.255.255.255, 0.0.0.0-255.255.255.255}
PermissionGroups : ExchangeUsers

Name             : tgcsnet connector
RemoteIPRanges   : {192.168.69.26, 192.168.69.12, 192.168.69.15, 192.168.69.10}
PermissionGroups : ExchangeServers



[PS] C:\Documents and Settings\Administrator.OUR>


check my router for what the config change was made


my dns records externally are fine just got of the phone with support

can it be internal dns?
0
 
endital1097Commented:
go into properties of Default TGCS005 and add Anonymous on the PermissionsGroup tab

no it's external DNS
so the router was updated so traffic to mail now goes to 2007?
0
 
InserachofAuthor Commented:
try now found a typo in the router config
0
 
endital1097Commented:
now you just need to add the anonymous permission group setting on teh default receive connector

i did connect but got the not authentiacted error
0
 
InserachofAuthor Commented:
smtp now workinginternal and external
0

Featured Post

Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

  • 28
  • 27
  • 8
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now