• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 498
  • Last Modified:

rsyncd - can't set "log file" to module

This works on fedora 7 but it's not on centos 5.5.

I've setup an rsync server.  I have "log file" in the global parameters of rsyncd.conf and "log file" in the module section also.  My main log "/var/log/rsync.log" keeps saying "Global parameter log file found in service section!"

I've validated the path to the module log file.  There is nothing there. I even did a touch rsync_pas.log first with the same permissions that the /var/log/rsync.log had but still it doesn't log anything to that file.

The files do backup fine but the logging is in the /var/log/rsync.log instead of where I've specified for that module.

Any help would be greatly appreciated...


gid = nobody
uid = 0
max connections = 100
timeout = 300
use chroot = true
log file = /var/log/rsync.log

        path = /rsyncd_backup/pas
        read only = false
        list = no
        gid = nobody
        uid = 0
        auth users = jason
        secrets file = /etc/rsyncd.secrets
        log file = /rsyncd_backup/logs/rsync_pas.log
1 Solution
I have a suspicion that global settings override settings for modules.
Try to remove "log file = /var/log/rsync.log" from global section and see how it'll go.
If it will not help, you can use some script to filter messages for different modules,
like this:


jasonsloganAuthor Commented:
I tried that first but then it pushed the logs to the local syslog server.  According to the link above you can use both. You can have authentication logs and so forth but logging the modules can be done individually.
Check the versions of rsync.  the CentOS version might be slightly different.  Does "man rsyncd.conf" on the CentOS server say it's a module parameter or only global parameter?
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Or 32 bit version if you are using that.

jasonsloganAuthor Commented:
man rsyncd.conf does say you can put "log file" in the module but after updating with Joshua's suggestion it worked fine.  The fedora 7 version 2.6.9 and the centos 5.5 version was 2.6.8.  Now I am running 3.0.7...
jasonsloganAuthor Commented:
This answer was the solution to my problem not just commenting.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now