Solved

exchange 2007 external email not working

Posted on 2010-09-12
39
431 Views
Last Modified: 2013-11-30
just setup exchange 2007 SP3 enterprise 64bit on Windows 2003 r2 SP2 enterpriese 64 bit edition member server.

I got email working internally using outlook and smtp command program

Still working on getting email to my legacy 2000 exchange server also

but this is for external email

when I sned to an extternal email address I get this in the queue

Identity: tgcs005\Unreachable\24
Subject: lets test all 3
Internet Message ID: <A02C505A23234948850038B581EF80DC020540CEF9@tgcs005.our.network.tgcsnet.com>
From Address: admin01@tgcsnet.com
Status: Ready
Size (KB): 2
Message Source Name: FromLocal
Source IP: 255.255.255.255
SCL: -1
Date Received: 9/12/2010 11:10:00 AM
Expiration Time: 9/14/2010 11:10:00 AM
Last Error: A matching connector cannot be found to route the external recipient
Queue ID: tgcs005\Unreachable
Recipients:  thomasgrassi@vzw.blackberry.net

I created an smtp connector but not sure how to get external email going


2007 newbie here

0
Comment
Question by:Inserachof
  • 20
  • 19
39 Comments
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
ID: 33657285
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33657293
also make sure you have a routing group connector
get-routinggroupconnector

if you are missing this then you need to add one
New-RoutingGroupConnector -Name "RGC Name" -SourceTransportServers ex2007 -TargetTransportServers ex2000 -BiDirectional:$true -Cost 10

0
 

Author Comment

by:Inserachof
ID: 33657320
we created a routing group connect in another question i have posted that you and i are working on

quesstion on the send connector do i need to use a smart host or not?
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33657333
you do not
you should be able to configure it as 2000 was
0
 

Author Comment

by:Inserachof
ID: 33657351
in this question http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26466952.html#a33657332

I posted a listing of my queue and the errors can you take a look at it

we are both working on these two issues

thanks for your help we are getting close to fixeing this
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33657360
after you created the send connector were you able to send a message out to the internet from a 2007 mailbox?
0
 

Author Comment

by:Inserachof
ID: 33657370
no they are all sitting in the queue

From Address      Status      Size (KB)      SCL      Queue ID      Message Source Name      Subject      Last Error
admin01@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      testing exchange routing connector      
admin01@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      testing exchange routing connector 2      
admin01@tgcsnet.com      Ready      5      -1      tgcs005\5      FromLocal      lets test all 3      
admin01@tgcsnet.com      Ready      2      -1      tgcs005\Unreachable      FromLocal      lets test all 3      A matching connector cannot be found to route the external recipient
admin01@tgcsnet.com      Ready      5      -1      tgcs005\5      FromLocal      testing all 3 again      
admin01@tgcsnet.com      Ready      2      -1      tgcs005\Unreachable      FromLocal      testing all 3 again      A matching connector cannot be found to route the external recipient
admin02@tgcsnet.com      Ready      1      0      tgcs005\Unreachable      SMTP:tgcsnet connector            A matching connector cannot be found to route the external recipient
admin02@tgcsnet.com      Ready      1      0      tgcs005\5      SMTP:tgcsnet connector            400 4.4.7 Message delayed
admin02@tgcsnet.com      Ready      1      0      tgcs005\Unreachable      SMTP:tgcsnet connector            A matching connector cannot be found to route the external recipient
admin02@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      Testing routng connector      
admin02@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      testing after registry updates      
admin02@tgcsnet.com      Ready      4      -1      tgcs005\5      FromLocal      test from tgcs002      
admin02@tgcsnet.com      Ready      2      -1      tgcs005\Unreachable      FromLocal      testing external after smtp connector change      A matching connector cannot be found to route the external recipient
PublicFolderDatabase@tgcsnet.com      Ready      3      -1      tgcs005\5      FromLocal      Hierarchy      
PublicFolderDatabase@tgcsnet.com      Ready      3      -1      tgcs005\5      FromLocal      Hierarchy      
PublicFolderDatabase@tgcsnet.com      Ready      3      -1      tgcs005\5      FromLocal      Status      

here is the list hope it helps

0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33657380
is anything production on 2007, can it be rebooted
0
 

Author Comment

by:Inserachof
ID: 33657389
yes it can will do that now
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33657406
if the messages don't go out, then go into the 2007 mgmt console and tools
run thru the mail flow troubleshooter
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33657473
how's it going?
0
 

Author Comment

by:Inserachof
ID: 33659592
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33661069
attempt to telnet to an external mail system from this server
telnet mx1.hotmail.com 25

is your firewall allowing outbound smtp traffic from this ip address
0
 

Author Comment

by:Inserachof
ID: 33662063
i was able to telnet mx1.hotmail.com 25 on both 2007 and 2000 servers

Do I really need the 2000 server any more?

I only have two mailboxes to move over then everyone is on 2007

Just need to get external email working
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33662114
in that case, you just need to have the send connector for 2007 created and working
once everyone is moved you can remove the smtp connector from 2000
0
 

Author Comment

by:Inserachof
ID: 33662360
bad news my exchange 2000 server just stopped working all together no email flow at all
I am screwed and not happy

0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33662371
what was the last change made?
0
 

Author Comment

by:Inserachof
ID: 33662644
just ran the flow report

I noticed on my 2000 box I have a yellow ? on my smtp server

The server is very sluggish and slow

these two errors appear

Type :            Error
Date :            9/13/2010
Time :            9:57:50 AM
Event :            36871
Source :            Schannel
Category :      None
User :            N/A
Computer :      TGCS004
Description:
A fatal error occurred while creating an SSL server credential.

Type :            Error
Date :            9/13/2010
Time :            10:01:57 AM
Event :            10009
Source :            DCOM
Category :      None
User :            OUR\Administrator
Computer :      TGCS004
Description:
DCOM was unable to communicate with the computer TGCS005 using any of the configured
protocols.

we added this recently

New-RoutingGroupConnector -Name "TGCSNET Routing Connector" -SourceTransportServers tgcs005.our.network.tgcsnet.com -TargetTransportServers tgcs004.our.network.tgcsnet.com -BiDirectional:$true

how do I remove this

I will save my email cleints via creating a pst file and createing them new in 2007 instead of moving them

my outlook cleints on 2000 can no longer conect to the server

from the client I can telnet to the 2000 server

help help help
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33662693
the outlook clients no longer connecting has nothing to do with anything we have done
all the changes we've made are routing changes between the two servers

you can remove the connector by running
remove-routinggroupconnector "TGCSNET Routing Connector"

what about mail flow within the 2007 environment?
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:Inserachof
ID: 33663053
can we get external mail working without the 2000 server in the picture?

what do we need to do?

yes mail flow is working on 2007 with one error it is in my other post

if we can get external email working on 2007 without the 2000 server then we can work on that other error  I can deal with a sned/receive error as loong as I can send mail back and forth for now

can we try the figure the extenal email issue now
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33663372
can you confirm outbound mail is working from 2007? i posted a comment regarding inbound
0
 

Author Comment

by:Inserachof
ID: 33663423
no outbound

but i think like you posted in my other question we need to change my router config to point port 25 to the 2007 server and not the 2000 server
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33663461
yes, check all setting for port 25 and make sure that it will allow the 2007 server
0
 

Author Comment

by:Inserachof
ID: 33665008
back
I have all clients now on 2007 mb

still not getting external email flowing

shutdown the 2000 server

got my router configed to point port 25 to 2007 server

where do we go from here
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33665048
i can no longer connect to mail
check your receive connectors
post the results

get-receiveconnector | fl name,remote*,perm*
0
 

Author Comment

by:Inserachof
ID: 33665441

         Welcome to the Exchange Management Shell!

 Full list of cmdlets:          get-command
 Only Exchange cmdlets:         get-excommand
 Cmdlets for a specific role:   get-help -role *UM* or *Mailbox*
 Get general help:              help
 Get help for a cmdlet:         help <cmdlet-name> or <cmdlet-name> -?
 Show quick reference guide:    quickref
 Exchange team blog:            get-exblog
 Show full output for a cmd:    <cmd> | format-list

Tip of the day #78:

The Exchange Management Shell can log all the Exchange-related commands that mod
ify objects in some way. Exchange-related command activity is logged to the Powe
rShell event log. To enable Exchange-related command logging, run the following
command:

Set-ItemProperty HKLM:\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microso
ft.Exchange.Management.PowerShell.Admin -Name LogpipelineExecutionDetails -value
 1

[PS] C:\Documents and Settings\Administrator.OUR>get-receiveconnector | fl name,
remote*,perm*


Name             : Default TGCS005
RemoteIPRanges   : {0000:0000:0000:0000:0000:0000:0.0.0.0-ffff:ffff:ffff:ffff:f
                   fff:ffff:255.255.255.255, 0.0.0.0-255.255.255.255}
PermissionGroups : ExchangeUsers, ExchangeServers, ExchangeLegacyServers

Name             : Client TGCS005
RemoteIPRanges   : {0000:0000:0000:0000:0000:0000:0.0.0.0-ffff:ffff:ffff:ffff:f
                   fff:ffff:255.255.255.255, 0.0.0.0-255.255.255.255}
PermissionGroups : ExchangeUsers

Name             : tgcsnet connector
RemoteIPRanges   : {192.168.69.26, 192.168.69.12, 192.168.69.15, 192.168.69.10}
PermissionGroups : ExchangeServers



[PS] C:\Documents and Settings\Administrator.OUR>

0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33665564
once anonymous is added to Default TGCS005 you just need to verify that traffic to mail is routed to TGCS005

right now the connection times out which means that it is not being sent to the correct destination
0
 

Author Comment

by:Inserachof
ID: 33665760
try now just found a typo in the router config
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33665786
update anonymous permission and you are good
0
 

Author Comment

by:Inserachof
ID: 33665829
where and how do i do that
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33665852
exchange management console
server configuration
hub transport server
highlight the server at the top
properties of the Default TGCS
permissions group tab
check the box for anonymous
0
 

Author Comment

by:Inserachof
ID: 33665909
on the default tgcs005 properties page

transport layer security is checked
basic authenication is checked
   offer basic authenciation only is checked
exchange server auth is checked
integrated windows auth is checked
externally secured is not chekced

am i in the right place
0
 

Author Comment

by:Inserachof
ID: 33665914
ok got it

leave everything else checked
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33665946
yes, successfully sent a test
0
 

Author Comment

by:Inserachof
ID: 33665973
yeah looks like I am now receiving external email

can you send me one

thomasrgrassijr@tgcsnet.com

I still cant send out tho
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33665998
can you post the results
get-sendconnector | fl
0
 

Author Comment

by:Inserachof
ID: 33666068
I got your email thanks

here you go

[PS] C:\Documents and Settings\Administrator.OUR>get-sendconnector | fl


AddressSpaces                : {SMTP:192.168.69.26;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ForceHELO                    : False
Fqdn                         :
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : TGCS005
Identity                     : TGCSNET
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 10MB
Name                         : TGCSNET
Port                         : 25
ProtocolLoggingLevel         : None
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {TGCS005}
UseExternalDNSServersEnabled : False
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 500 total points
ID: 33666122
you need to update the address space
organization config
hub transport
send connector tab
properties of your send connector
address space tab
remove what you have and add * with cost = 1
send.PNG
0
 

Author Closing Comment

by:Inserachof
ID: 33666180
email flowing incoming and outgoing
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now