Link to home
Start Free TrialLog in
Avatar of okamon

asked on

access: cannot open database which is being opened by other pc

on xp pc, I shared access database that was created by access 2007. If I opened it on other pc (win 7) which running access 2010, then I will not be able to open it from xp pc, but the opposite way will work.

the other thing I also noticed that if I edit data on win 7, it will not get saved in database...
Avatar of Scott McDaniel (EE MVE )
Scott McDaniel (EE MVE )
Flag of United States of America image

You must insure that your users have at least Modify permissions on the FOLDER hosting the database.

Does the Windows7 machine network correctly with the XP machine? There have been some reports of problems getting those two platforms to talk.
perhaps locking mechanism is different (the ldb file that is). is this one db that is shared by all? have u thought of splitting it up to front end and backend? frontend is your forms and code and contains tables linked to the backend db (which is data only). Each user has their own copy of the frontend. This might allow you to share the db,

Otherwise it could be the way the db is opened on 2010. Its not open for exclusive lock?
Also, make sure the "other" machine is not opening the database in Exclusive mode. This can be a setting done in Access or can be achieved through the method used when opening the file. It can also happen is a user opens the database in Design mode (or any object in the database).
Avatar of okamon


the share folder is done by the simple share method on xp machine. So by default other user should have modify permission. I do see there is a lock icon on the ldb file. How can I set the mode in access?
how are users currently opening the db, are they using some kind of shortcut?

in msaccess 2010, ms have realised that ribbons is a pile of crap and brought back menus in some form thank god! anyways if you click on File/Options, on the general tab settings for new blank database is 2007? this doesnt matter too much if you could try set it back to 2003
Then in Client Settings, scroll down to Advanced and check the default open mode.
I have had this problem for a couple of years now.  You need to have a front end and a back end database.  Give all users their own front end linked to the common back end.

Since I make modifaction to the front end of my databases, I set up bat files that copy the front end from the server down to the user's PC each time they login.  It's worked like a charm for years.
<So by default other user should have modify permission>

Please don't assume that this is the case, especially when you're talking about a Windows7 machine interacting with an XP machine.  The newsgroups are replete with postings about issues exactly like this, and in a very large portion of those postings the end solution is permissions. Check those permissions, then check them again.

Maybe this will help, if you're having network issues:

I do agree that the best method is splitting the database, but that's not the root cause of your issue. While doing so may help with locking issues on the FE file, you'd still have permission issues on the BE file.

rocki: MS is fully committed to the Ribbons. As they told us at the MVP summit last year: Learn to love 'em, cause they're not going anywhere.
Avatar of okamon


thanks. I will try and update soon
Avatar of rockiroads
Flag of United States of America image

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Yeah, that's a popular addon. I used it myself at first, but once I "got my head around" the ribbons I have no trouble with them.
Avatar of okamon


is there any open source addon like this?
for excel, word and ppt there is a free version (not open source) but doesn't cover msaccess. I assume you want an msaccess one.