We help IT Professionals succeed at work.

Ubuntu can't be found after installing OpenSuse 11.3

srikanthrad
srikanthrad asked
on
670 Views
Last Modified: 2013-12-16
I had Ubuntu 10.4 before and after I have installed OpenSuse 11.3, It can't recognize Ubuntu 10.4 image while booting.
Please explain how can I get Ubuntu to show up while grub2 shows boot menu during startup..

linux-445p:~ # fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xecd0e75a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         608     4883728+  82  Linux swap / Solaris
/dev/sda2   *       13357       21867    68364607+  83  Linux
/dev/sda3             609       11705    89128620   83  Linux
/dev/sda4           21886       60801   312592739+   5  Extended
/dev/sda5           57763       60801    24410736   83  Linux
/dev/sda6           54724       57762    24410736   83  Linux
/dev/sda7           37967       54723   134600571   83  Linux
/dev/sda8           21886       33710    94984281   83  Linux
/dev/sda9           33711       37966    34186288+  83  Linux

Partition table entries are not in disk order


I think /dev/sda6 contains root partition for ubuntu 10.04. But, I am not sure of it. It's been a long time since I have installed ubuntu 10.04.

If it were /dev/sda6, can I edit the boot/menu.lst file and paste this in there:

#Don't change this comment - YaST2 identifier: Ubuntu 9.04 2.6.28-11#
title   Ubuntu 9.04, kernel 2.6.32-25-generic (/dev/sda6)
root    (hd0,5)
kernel  /boot/vmlinuz-2.6.32-25-generic root=/dev/sda6 ro quiet splash
initrd  /boot/initrd.img-2.6.32-25-generic


boot-menu-lst.png
Comment
Watch Question

Josef PospisilIT-Systemelektroniker
CERTIFIED EXPERT

Commented:
Hi, OpenSuse is using grub 0.97 with ext4 patch while Ubuntu 10.04 using grub2...
Could you post the whole "menu.lst" and the output of "df".

In your posting you say that the boot partition of Ubuntu is sda6.
You have to also find out where the root partition is with Directories like etc, bin, sbin etc.
Assuming that the root partition is sda7. The menu.1st would look like this:


#Don't change this comment - YaST2 identifier: Ubuntu 9.04 2.6.28-11#
title   Ubuntu 9.04, kernel 2.6.32-25-generic (/dev/sda6)
root    (hd0,5)
kernel  /boot/vmlinuz-2.6.32-25-generic root=/dev/sda7 ro quiet splash
initrd  /boot/initrd.img-2.6.32-25-generic



You could also try to boot from Ubuntu live CD. And install grub2 of Ubuntu again hoping it will detect your OpenSuse Linux. The howto is placed here https://wiki.ubuntu.com/Grub2

Author

Commented:
menu.lst in the code section.

linux-445p:~ # df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2              65G  3.8G   58G   7% /
devtmpfs              1.9G  236K  1.9G   1% /dev
tmpfs                 1.9G  4.0K  1.9G   1% /dev/shm
/dev/sda3              84G  319M   80G   1% /home
/dev/sda9              33G  229M   31G   1% /tmp
/dev/sda7             127G   75G   46G  63% /media/disk
/dev/sda8              90G  6.6G   79G   8% /media/disk-1
/dev/sda5              23G  174M   22G   1% /media/disk-2


Boot and Root seems to be in the same partition. As far as I remember, I didn't create a seperate boot partition. I created only /, /home, /tmp, and /var partitions.


linux-445p:~ # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Sun Sep 12 22:55:21 CDT 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 2
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.3 - 2.6.34.4-0.1 (default)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34.4-0.1-default root=/dev/disk/by-id/ata-ST9500420ASG_5VJ0KEHC-part2 resume=/dev/disk/by-id/ata-ST9500420ASG_5VJ0KEHC-part1 splash=silent quiet showopts vga=0x314
    initrd /boot/initrd-2.6.34.4-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34.4-0.1 (default)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34.4-0.1-default root=/dev/disk/by-id/ata-ST9500420ASG_5VJ0KEHC-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
    initrd /boot/initrd-2.6.34.4-0.1-default


###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 11.3 - 2.6.34.4-0.1
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34.4-0.1-desktop root=/dev/disk/by-id/ata-ST9500420ASG_5VJ0KEHC-part2 resume=/dev/disk/by-id/ata-ST9500420ASG_5VJ0KEHC-part1 splash=silent quiet showopts vga=0x314
    initrd /boot/initrd-2.6.34.4-0.1-desktop


###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34.4-0.1 (desktop)
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34.4-0.1-desktop root=/dev/disk/by-id/ata-ST9500420ASG_5VJ0KEHC-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
    initrd /boot/initrd-2.6.34.4-0.1-desktop

Open in new window

Author

Commented:
I have added the following configuration to my /boot/grub/menu.lst.

###Don't change this comment - YaST2 identifier: Original name: Ubuntu 9.04 2.6.32-25###
title   Ubuntu 9.04, kernel 2.6.32-25-generic (/dev/sda6)
    root    (hd0,5)
    kernel  /boot/vmlinuz-2.6.32-25-generic root=/dev/sda6 ro quiet splash
    initrd  /boot/initrd.img-2.6.32-25-generic

If any of the above configuration were to be incorrect, will I be able to boot??

I didn't change the defaults though.

default 2
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

Author

Commented:
The attached is the Image I see in the boot loader settings. I am not sure whether the ubuntu configuration is correct.
boot-loader-settings.png
Josef PospisilIT-Systemelektroniker
CERTIFIED EXPERT

Commented:
Hi, yes you will be able to boot since you did not change the other settings. If the grub configuration you added to your menu.1st is wrong (it won't find the Ubuntu kernel and root partition) you will still be able to boot into SuSE.

Author

Commented:
I got an Error 15: File Not Found when I tried to boot through Ubuntu. But,as you said if Ubuntu entries are incorrect, I can still load into OpenSuse 11.3
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
IT-Systemelektroniker
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
What I thought was the root and boot partition was an Incorrect partition. Thanks for your time.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.