Solved

How can I configure Wireless Network in OpenSuse 11.3

Posted on 2010-09-12
15
1,959 Views
Last Modified: 2013-12-15
First I have done with root.
sudo /usr/sbin/install_bcm43xx_firmware

I have installed b43-firmware, b43-fwcutter through Yast, but Network Manager can't find wireless .. wireless is disabled. Please suggest what should I do.

nm-tool:
~~~~~~~~~

linux-445p:/boot # nm-tool

NetworkManager Tool

State: connected


** (process:6417): WARNING **: error: failed to read connections from org.freedesktop.NetworkManagerUserSettings:
    The name org.freedesktop.NetworkManagerUserSettings was not provided by any .service files
- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             connected
  Default:           yes
  HW Address:        00:22:19:F7:A5:52

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         10.0.0.9
    Prefix:          24 (255.255.255.0)
    Gateway:         10.0.0.1

    DNS:             10.0.0.1

0
Comment
Question by:srikanthrad
  • 7
  • 5
  • 2
  • +1
15 Comments
 
LVL 2

Expert Comment

by:rupeshsaini
ID: 33659826
---change the wireless router's settings from WPA-PSK to WPA2-PSK

--Also follow following link

http://forums.opensuse.org/english/get-help-here/wireless/
0
 

Author Comment

by:srikanthrad
ID: 33659893
Where can I change the wireless router's settings from WPA-PSK to WPA2-PSK
I am new to OpenSuse. Please suggest.
0
 
LVL 3

Expert Comment

by:h4himanshu
ID: 33660002
Hi Srikanth,

You will need to login to your wireless router's configuration page via http, i.e. http://router's ip address e.g http://192.168.1.1, http://10.0.1.1 etc.

You can do this by connecting to the router through Ethernet port or through any other PC that can connect to the wireless network. Please refer to the manul/documentation that was supplied with your router.

Regards.
0
 
LVL 2

Expert Comment

by:rupeshsaini
ID: 33660512
you have to set the wireless router setting to urs router ip address
So you need to Type in Browser the IP  Address ie: Http://192.1.1.1

Then you will be able to set the settings.
0
 
LVL 7

Expert Comment

by:expert1010
ID: 33660679
Is the driver used at all?

Try this:

lspci -vnn | grep 14e4

You should see something similar to this:
03:00.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318]

After that you try this, but change 03:00.0 to what you have:
lspci -vnn -s 03:00.0

At the bottom you should see what kernel driver is used. Post the result so that we can see what card you have.
0
 

Author Comment

by:srikanthrad
ID: 33661303
linux-445p:/ # lspci -vnn | grep 14e4
06:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)


I don't know how to check the domain, bus, slot and function. How do I check which ones I have?

linux-445p:/ # lspci -vnn -s 03:00:0
linux-445p:/ #
0
 

Author Comment

by:srikanthrad
ID: 33661359
My ip address is 10.0.0.1 according to ifconfig under eth0

eth0      Link encap:Ethernet  HWaddr 00:22:19:F7:A5:52  
             inet addr:10.0.0.9

Page not found for http://10.0.09 or 192.1.1.1 or 10.0.1.1 or  http://192.168.1.1, http://10.0.1.1 etc.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 7

Expert Comment

by:expert1010
ID: 33661626
srikanthrad:

You should have written 06:00:0 in the lspci-command according to the first output.     .

Try this
lspci -vnn -s 06:00:0
0
 

Author Comment

by:srikanthrad
ID: 33661647
nothing shows up.

inux-445p:~ # lspci -vnn | grep 14e4
06:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
linux-445p:~ # lspci -vnn -s 06:00:0
linux-445p:~ #
0
 

Author Comment

by:srikanthrad
ID: 33661653
Oh wait sorry typo.

linux-445p:~ # lspci -vnn -s 06:00.0
06:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
        Subsystem: Dell Wireless 1510 Wireless-N WLAN Mini-Card [1028:000d]                                                                                                        
        Flags: bus master, fast devsel, latency 0, IRQ 21                                                                                                                          
        Memory at f0400000 (64-bit, non-prefetchable) [size=16K]                                                                                                                    
        Capabilities: [40] Power Management version 3                                                                                                                              
        Capabilities: [58] Vendor Specific Information: Len=78 <?>                                                                                                                  
        Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+                                                                                                                  
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel
        Capabilities: [160] Device Serial Number 5b-dc-5e-ff-ff-26-00-26
        Capabilities: [16c] Power Budgeting <?>
        Kernel driver in use: b43-pci-bridge
0
 
LVL 7

Expert Comment

by:expert1010
ID: 33661774
I think your problem is that you shouldn't use "b43" but "wl". I had this problem with my wife's laptop although it was 14e4:4315. Have you tried wl?
0
 

Author Comment

by:srikanthrad
ID: 33661796
I haven't tried wl. What is wl and how do I do that? Please suggest.
0
 
LVL 7

Expert Comment

by:expert1010
ID: 33661848
wl is the prefered driver for a lot of  broadcom drivers now days. To test if this is ok. Do this.

remove b43 from insmoded drivers:

  modprobe -r b43

install wl through zypper:

  zypper in broadcom-wl

insert wl:

  modprobe wl

Proceed with normal configuring as you would have done before.
0
 

Author Comment

by:srikanthrad
ID: 33661915
linux-445p:~ # modprobe -r b43
linux-445p:~ # zypper in broadcom-wl
Loading repository data...
Reading installed packages...
'broadcom-wl' is already installed.
No update candidate for 'broadcom-wl-5.60.48.36-7.pm.8.3.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.
linux-445p:~ # modprobe wl
linux-445p:~ # lspci -vnn | grep 14e4
06:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
linux-445p:~ # lspci -vnn -s 06:00.0
06:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
        Subsystem: Dell Wireless 1510 Wireless-N WLAN Mini-Card [1028:000d]
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at f0400000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Vendor Specific Information: Len=78 <?>
        Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [d0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [13c] Virtual Channel
        Capabilities: [160] Device Serial Number 5b-dc-5e-ff-ff-26-00-26
        Capabilities: [16c] Power Budgeting <?>
        Kernel driver in use: b43-pci-bridge


I don't know what configuration you were talking about. I am a total new-bie to Opensuse and not sure what I have done. Just changing everything previously. Please suggest what should I do now.
0
 
LVL 7

Accepted Solution

by:
expert1010 earned 500 total points
ID: 33662025
Ok. Sorry.

You should have knetworkmanager installed in the systray. If not run it from the panel or from terminal. It should be run as normal user.

check if it is installed:
ps waux | egrep -i networkmanager

If it's installed you should see it in the tray. Click on it and configuration (think it says something with .... connection). Add your network there.

If you want to read up on it here's a link.
http://projects.gnome.org/NetworkManager/users/

PS. Need to pop out for an hour or two. DS.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now