outlook 2007 and 2010 very slow to send emails under Windows Vista and Windows 7

I have a laptop running windows 7 and MSO 2010 and using a VODACOM 3g card to pop off emails. Internet access is fast and working perfectly. The only problem is when sending emails, emails immediately gets sent to outbox and hangs for 2 minutes before sending to relevant email address.

This laptop is not part of a domain and has never been connected to exchange server. However the user does have an existing exchange mail box in exchange server.

I also have identical symptoms on 2 laptops that are in the domain with exchange accounts as well as pop accounts.
Who is Participating?
goyal_251Connect With a Mentor Commented:
have you applied latest service pack on both 2007 and 2010
Disable Useless Outlook Add-ins
open outlook, go to Tools from the top menu and then Trust Center ,Click on Add-ins in the left hand menu and then click on the Go button at the very bottom of the dialog where it says Manage and has a drop down box .Now you’ll get a list of add-ins that you can uncheck. It is suggest that you un-check ALL of the add-ins except for the Windows Indexing.
Disable RSS feeds in Outlook 2007
go to Tools, Account Settings and then click on RSS Feeds.

Lacretta IncorvaiaCommented:
Good Morning,
Does this particular user have the same problem when using a different computer?  Have you tried re-creating the Mail profile?
Lacretta IncorvaiaCommented:
Good Morning Velavke,

Are there any updates?

Have you tried disabling your Antivirus software to make sure its not the program thats hanging up your emails as they are trying to be sent out?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.