Link to home
Start Free TrialLog in
Avatar of zingab
zingab

asked on

exchange 2007 logs

I have enabled circular logging on my exchange 2007 server and all logs are still there, i have restarted the server/and services. I have a full backup that runs and is exchange aware, but still not purging logs.
Avatar of sunnyc7
sunnyc7
Flag of United States of America image

Circular logging >> please disable immediately.
Set-StorageGroup -Identity "First Storage Group" -CircularLoggingEnabled $false

You need to disable that. After that normal log generation process will start and full backups will purge logs.
you must dismount and mount the database for circular logging once enabled
Avatar of raj_tom
raj_tom

Can you please provide more details on your environment.
exchange version, is ccr / scr applied etc....

if you have enabled ccr and exchange sp2, then this is a known bug.A hotfix has not yet been released for this yet.
Avatar of zingab

ASKER

I had lcr enabled but have since disabled this, i have sp2 installed as well. Anything that i can do in the mean time?
the best course of action is to get the full backup of your information store/storage group
that will purge committed logs
Avatar of zingab

ASKER

i have done full backups and it is not purging...
what backup soln are you using ? ntbackup or any other 3 party soln
Avatar of zingab

ASKER

i am using exchange aware - this issue just started a couple of weeks ago, up until then i havent had any issues.
did you install any windows /exchange security updates.

Open IE
Tools > options > windows updates
on the left tab check update history.

Please post back the KB # of the updates installed since you were having this issue.

thanks
check your application log for ESE and/or ESE Backup warnings and error events
post any you find
Avatar of zingab

ASKER

i do not see any...
When you say you disabled LCR how did you do it?
Can you run Get-StorageGroupCopyStatus for the SG you had in LCR?

Have a look through ADSIEdit and see if the disabled LCR SG still exists in there, if so you may need to delete it to get the logs to truncate.
Avatar of zingab

ASKER

used the management console.- ran the command and athe storage group comes up as copy status disabled...
Avatar of zingab

ASKER

if i were missing any log files - would doing a full backup clear that up?
Avatar of zingab

ASKER

i ran a windows server backup - still not truncating logs - i see the last full backup date is up to date in the excahnge management console. we had previosuly enabled lcr, but is no longer enabled...any help?
what did you see in ADSIEdit was the LCR SG still in there?
Avatar of zingab

ASKER

i am not sure where in adsiedit i need to check? can you specify?

thanks!
ASKER CERTIFIED SOLUTION
Avatar of MegaNuk3
MegaNuk3
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
are you sure you are not seeing any events in the event log when you back these SGs up?
Avatar of zingab

ASKER

Ty
Thanks for the points, can you confirm you cleared the entry in ADSIEdit and then ran a full backup and all the transaction logs got purged?
Avatar of zingab

ASKER

yes that was it
Thanks 4 confirming