exchange 2007 logs

I have enabled circular logging on my exchange 2007 server and all logs are still there, i have restarted the server/and services. I have a full backup that runs and is exchange aware, but still not purging logs.
zingabAsked:
Who is Participating?
 
MegaNuk3Connect With a Mentor Commented:
msExchStandbyCopyMachines attribute for the SGs
0
 
sunnyc7Commented:
Circular logging >> please disable immediately.
Set-StorageGroup -Identity "First Storage Group" -CircularLoggingEnabled $false

You need to disable that. After that normal log generation process will start and full backups will purge logs.
0
 
endital1097Commented:
you must dismount and mount the database for circular logging once enabled
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
raj_tomCommented:
Can you please provide more details on your environment.
exchange version, is ccr / scr applied etc....

if you have enabled ccr and exchange sp2, then this is a known bug.A hotfix has not yet been released for this yet.
0
 
zingabAuthor Commented:
I had lcr enabled but have since disabled this, i have sp2 installed as well. Anything that i can do in the mean time?
0
 
endital1097Commented:
the best course of action is to get the full backup of your information store/storage group
that will purge committed logs
0
 
zingabAuthor Commented:
i have done full backups and it is not purging...
0
 
raj_tomCommented:
what backup soln are you using ? ntbackup or any other 3 party soln
0
 
zingabAuthor Commented:
i am using exchange aware - this issue just started a couple of weeks ago, up until then i havent had any issues.
0
 
sunnyc7Commented:
did you install any windows /exchange security updates.

Open IE
Tools > options > windows updates
on the left tab check update history.

Please post back the KB # of the updates installed since you were having this issue.

thanks
0
 
endital1097Commented:
check your application log for ESE and/or ESE Backup warnings and error events
post any you find
0
 
zingabAuthor Commented:
i do not see any...
0
 
MegaNuk3Commented:
When you say you disabled LCR how did you do it?
Can you run Get-StorageGroupCopyStatus for the SG you had in LCR?

Have a look through ADSIEdit and see if the disabled LCR SG still exists in there, if so you may need to delete it to get the logs to truncate.
0
 
zingabAuthor Commented:
used the management console.- ran the command and athe storage group comes up as copy status disabled...
0
 
zingabAuthor Commented:
if i were missing any log files - would doing a full backup clear that up?
0
 
zingabAuthor Commented:
i ran a windows server backup - still not truncating logs - i see the last full backup date is up to date in the excahnge management console. we had previosuly enabled lcr, but is no longer enabled...any help?
0
 
MegaNuk3Commented:
what did you see in ADSIEdit was the LCR SG still in there?
0
 
zingabAuthor Commented:
i am not sure where in adsiedit i need to check? can you specify?

thanks!
0
 
MegaNuk3Commented:
are you sure you are not seeing any events in the event log when you back these SGs up?
0
 
zingabAuthor Commented:
Ty
0
 
MegaNuk3Commented:
Thanks for the points, can you confirm you cleared the entry in ADSIEdit and then ran a full backup and all the transaction logs got purged?
0
 
zingabAuthor Commented:
yes that was it
0
 
MegaNuk3Commented:
Thanks 4 confirming
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.