Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

403 - Forbidden error even for HTTP after removing HTTPS binding

Posted on 2010-09-13
6
Medium Priority
?
1,314 Views
Last Modified: 2012-08-14
I have an SBS2008 server that I installed a GoDaddy UCC SSL certificate on over the weekend. Today, users trying to get to a timesheet applicaiton that runs on the SBS Server are getting a 403 - Forbitten error when they try to access the site. They had not used HTTPS before, onmly HTTP.

The timesheet applicaiton was installed on the Default website. It is a virtual directory. I went the the bindings of the default website and removed the HTTPS protocol from the bindings in IIS7. I performed IISReset but I am still getting the 403 error.  

I stopped and started the entire IIS through the IIS7 manager interface and I still get the error.

Any ideas?

Thanks,

Dave
0
Comment
Question by:dcadler
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 

Author Comment

by:dcadler
ID: 33663089
Here is the message I am getting when I try to access the web page.

"HTTP Error 403.4 - Forbidden
The page you are trying to access is secured with Secure Sockets Layer (SSL)."

However, I only have HTTP as the bound protocol in the Website bindings. T
0
 
LVL 30

Expert Comment

by:Rich Weissler
ID: 33663148
On the Default Web Site, under 'SSL Settings', confirm you don't have Require SSL selected.

Looking at odder instances...
Also on the Default Web site, under HTTP Redirect, confirm that under the Redirect requests to this destination, the next box is blank.   (http://www.dotnetnuke.com/Community/Forums/tabid/795/forumid/107/threadid/361291/scope/posts/threadpage/2/Default.aspx)
0
 

Author Comment

by:dcadler
ID: 33663339
If I select the virtual directory, dovtimesheet, under default Website and then select SSL settings, it shows that the "Require SSL" check box is checked but it is grayed out and I can't uncheck it.
0
WEBINAR - Latest Cyber Tips for Defense

Join the WatchGuard Threat Research Team on October 26th for an informative webinar featuring expert tips and tricks for defending your organization from today's latest cyber threats. Don't leave yourself vulnerable to attack. Register for the webinar today!

 

Author Comment

by:dcadler
ID: 33663361
the "redirect request to this destination" field is blank
0
 
LVL 30

Accepted Solution

by:
Rich Weissler earned 2000 total points
ID: 33663364
Ah... rebind port 443 to https with any certificate.  Then go back and uncheck 'require ssl'...
Then go back and remove the binding for https again.
0
 

Author Closing Comment

by:dcadler
ID: 33665006
That did the trick - Thanks
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question