Adding power state alarms to vm clients

Hi All,

Have been given the task of looking after our virtual servers / clients. problem i am facing is trying to set an alarm that will tell me when the vm machine has shut down for example. There are pre-defined alarms within the "host" that can do this but I want alarms set for the individual clients themselves. When I try creating such a new alarm with a trigger of VM State for example it gives me the condition of "equal to" and "not equal to" and then there is the Warning category which gives me "Powered on" Powered Off" "Suspended" and "None" Then finally the alerts which are the same as the Warning categories. The problem i have is when I try setting one to say a warning of Powered Off and then choose a category of Powered Off it just reverts to Powered On? I basically need it running so that if a VM machine shuts down out of hours then I will be notified via email - I can set the email options etc just not the actual alarm itself so Im obviously doing this wrong - can anyone help!!!!
speedwellJetAsked:
Who is Participating?
 
speedwellJetAuthor Commented:
hi there - thanks for the speedy response but I looked at this earlier and couldnt really understnad it - I just want an alarm setting that emails me if the vm machine shuts down but i dont think it can be down can it?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
BijuMenonCommented:
1) Go to Home ->vCenter Server Settings - Configure SMTP and sender email address.
2) Search for a VM and Right Click on it a select Alarm -> Add Alarm
3) Under General tab, Select Monitor as Virtual Machine and select "Monitor for specific events occuring on this object"
4) Enable this Alarm
5) Under Triggers Tab -> Select "VM Powered Off"
6) Under Actions Tab Select action as "Send a notification email"
7) Configuration with your email address. Yellow to Red tab "Once" and Click OK.

You should receive an email now.
0
 
BijuMenonCommented:
1) Go to Home ->vCenter Server Settings - Configure SMTP (exchange server name like excg01.hp.com)and sender email address (this can be vmware@yourdomain.com not necessary to be an existing one).
2) Search for a VM and Right Click on it a select Alarm -> Add Alarm
3) Under General tab, Select Monitor as Virtual Machine and select "Monitor for specific events occuring on this object"
4) Enable this Alarm
5) Under Triggers Tab -> Select "VM Powered Off"
6) Under Actions Tab Select action as "Send a notification email"
7) Configuration with your email address. Yellow to Red tab "Once" and Click OK.

You should receive an email now.
0
 
speedwellJetAuthor Commented:
okay have set up that alrm and it indeed does put a red icon on the vm - when i shut down the machine howver no email is generated - I have looked in the alarm setup and it does say under "Triggers" that there are "Advanced settings are associated with this trigger" so i click on "ConditionS but this is blank - does it need something in here??
0
 
BijuMenonCommented:
Triggers -> Advanced settings can be blank. If the red alert is generated and you have configured the SMTP settings correctly then you should have received an email.
0
 
speedwellJetAuthor Commented:
perhaps there is an issue with the smtp setup then as no mail is coming through. It may be worth noting that I had to point it to a simple SMTP relay that I have setup as I cannot point it to our exchange server due to restrictions placed on it bythe network manager
0
 
BijuMenonCommented:
Are you able to send test email via your SMTP relay?
0
 
SysExpertCommented:
Test email with command line BLAT program to see if you can send via the relay.

I hope this helps !

0
 
SysExpertCommented:
* Blat ................... http://www.blat.net/

0
 
speedwellJetAuthor Commented:
Hi all, sincere apologies for the delayed response - was away on hols!

Okay so have managed to set up alarms, it seems it was an issue with our internal smtp as mail was not being routed on port 25 - we have had to set the port to 2525 and this seems to work.

One thing that is stillpuzzling me however is the actual alarm state - if i switch off the VM it sure enough pings me an email BUT the alarm is set to repeat every 5 minutes, Im only getting the one alarm ??
0
 
speedwellJetAuthor Commented:
have split the point between two of you as both your answers were helpful in sorting this
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.