How to set up Integrated Windows Authtentication for IIS 7 directory and eliminate the challenge dialog

I have to migrate a ColdFusion app from a W2003 server to a W2008R2 server running IIS 7 on my company intranet.  I don't believe that the issue has anything to do with cold fusion but IIS settings somewhere.

In the w2003 environment, one directory in the app was set to integrated windows security.  When folks went to that page, since they were logged in on their company PC under their company ID, I could grab that ID from the server variables and use it to auto log them into the application.  
 How I set up IIS directory security under w2003When I try the same paradigm on w2008, IIS 7, I get a challenge dialog.
And if I enter the domain\\userid and pwd, it works but I don't want the dialog to occur but act as it did before in w2003
 w2008 ChallengeAnonymous is permitted at all the other directories levels.
 IIS directory authentication under w2008The server and all the client machines are in the same domain.
What am I missing?
E43509Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Brad HoweConnect With a Mentor DevOps ManagerCommented:
Hi,

Give this a shot.

Add Logon all intranet
1. Go to Menu go to Tools - Internet Options - Security and then click on the "Local Intranet" zone.
2. Click on the "Custom Level" toward the bottom of the pane and a new popup will appear.
3. Under the User Authentication/Logon, make sure "check" is on "Automatic Logon only in intranet zone"

If it is still not auto logging on, try the following.

Add site URL to local intranet
1. Go to Menu go to Tools - Internet Options - Security and then click on the "Local Intranet" zone.
2. Click on Sites.
3. Click "Advanced" and add the full address of the website in question eg: (http://your.domain.com)

Let us know,
Hades666
0
 
E43509Author Commented:
Since I was going to the site via the IP address as the DNS was not in place yet, I got that popup dialog message.  In the meantime the DNS name work was done and the popup challenge went away.  You were right on with your solution.  Thx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.