Centos OS 5.4 Shows tiney screen when I run it in vmware

How do I make the screen size resolution bigger when I am running Centos OS 5.4 under vmware.

I have a 24 in monitor and right now it's resolution when I go to the resolution settings in centos is only

800 X 600

It doesn't give me the option to make the resolution greater then that. How can I fix this so I can have a huge resolution.

Screen Shot below Screen 1Centos-OS-5.4-32bit-2010-09-13-1.png
sobeservices2Asked:
Who is Participating?
 
ddiazpConnect With a Mentor Commented:
What's your host (your physical machine) resolution set to?

If it's higher than 800x600, do this on your VM under root:

init 3 (will switch to runlevel 3)
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
system-config-display --reconfig --set-resolution=1024x768 --set-depth=16   (set resolution to whatever you wish)

After this, switch back to runlevel 5 (graphic interface) with the command

init 5

If it fails, recover the previous change with:

cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

and overwrite, then try init 5 again

0
 
chapmanjwCommented:
Have you install the VMWare tools?  The OS needs the drivers for the VMWare "display" in order to goto higher resolutions.
0
 
sobeservices2Author Commented:
Yes I have installed the vmtools.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
ddiazpCommented:
How did you start vmware tools? have you restarted the machine after installing VMWare Tools?

Are you using VMWare workstation, VMWare Server or VMWare vSphere?
0
 
sobeservices2Author Commented:
I am using VMWare workstation

I started it by going to the VMtools nav bar up top and selecting INSTALL VM TOOLS

Then it opened up a folder inside my centos OS which I just double clicked on the icon. It said it installed
I rebooted

And still nothing
0
 
sobeservices2Author Commented:
0
 
ddiazpCommented:
In VMWare Workstation, right click the VM and go to VM Settings.

Under the hardware tab, click on 'Display' on the list and on the right side, enable 3D Acceleration (to improve response time), but underneath you have options to use the host settings for monitor (will attempt to use the same resolution as your host PC), or you can specify a custom resolution under the second option
0
 
sobeservices2Author Commented:
I specified a custom setting I will now try Useee host setting for monitor I will post out come when done
0
 
sobeservices2Author Commented:
Nop did not work
0
 
sobeservices2Author Commented:
didn't work
faild at init 3
and did not do anything at init 5
0
 
ddiazpCommented:
try using telinit instead of init then.

telinit3, telinit5
0
 
sobeservices2Author Commented:
Nop nothing
0
 
ddiazpCommented:
did you switch to root user?

does your command prompt end with a  > or with a #?


To switch to root, type:

su -

then type the root password.

Then try init 3 again.
0
 
sobeservices2Author Commented:
Command prompt ends with a #
I did switch to root

I just hangs when i do init 3
see screen
Centos-OS-5.4-32bit-2010-09-13-1.png
0
 
ddiazpCommented:
Weird; can you check /var/log/messages after you try to switch runlevels? you have a service that is not stopping or is hanging; seems to be iptables.

Try service iptables stop and then try init 3 again
0
 
ddiazpCommented:
If all else fails, edit this file:

/etc/inittab

and look for a line that says:

id:5:initdefault:

in that line, change that 5 to a 3, save the file and restart your VM.
0
 
sobeservices2Author Commented:
what is this command actually doing what is 5 or 3
0
 
ddiazpConnect With a Mentor Commented:
5 and 3 are runlevels.

In short, runlevels are configured set of services that run on your machine.  By default, the average linux installation will have a runlevel of 5 while booting which means all the X Server services (the Desktop GUI) will load and you'll have a cursor, etc.

By switching to runlevel 3, you're telling the server to load runlevel 3 services which do not include the desktop graphic interface, etc.

When you execute  init 3 you're telling the machine to shut down the Graphic interface, and when changed on the file /etc/inittab it will affect the default runlevel applied when the computer boots up.


The reason we're going to runlevel 3 is to shutdown the graphic interface so we can make the changes directly on the configuration file; otherwise it could give you problems.

Under runlevel 3, we can do this:



cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
system-config-display --reconfig --set-resolution=1024x768 --set-depth=16   (set resolution to whatever you wish)

After this, switch back to runlevel 5 (graphic interface) with the command

init 5

If it fails, recover the previous change with:

cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

and overwrite, then try init 5 again
0
 
sobeservices2Author Commented:
No difference not change nothing

I followed your directions exactly
0
 
ddiazpCommented:
I would probably try re-installing VMWare Tools again then,.. it's the only problem I can think of.

Right click your VM in VMWare Workstation, and do you see an option that says 'Install VMWare Tools', or 'Reinstall VMWare Tools'?
0
 
sobeservices2Author Commented:
I tried it said already installed. I tried to uninstall and reinstall still same thing
yucj
0
 
ddiazpCommented:
Can you show us the output of your /etc/X11/xorg.conf file, specifically, the section "Screen" (Near the bottom)?

Also Try running  'yum update'  to download and install all updates just in case
0
 
sobeservices2Author Commented:
I have installed all yum updates before even doing this entire process

I am attaching screen shots below
Centos-OS-5.4-32bit-2010-09-14-1.png
Centos-OS-5.4-32bit-2010-09-14-1.png
Centos-OS-5.4-32bit-2010-09-14-1.png
0
 
ddiazpConnect With a Mentor Commented:
I have a Section "Monitor" that looks like this:

Section "Monitor"
    Identifier      "vmware"
    VendorName      "VMware, Inc"
    HorizSync       1-10000
    VertRefresh     1-10000
EndSection


Additionally, this is what my CentOS 5.5 installation on VMWare Workstation 7 shows for the "Screen" Section.


You could try to add the monitor section and the "Display" subsections on your file (leaving Identifier as "Screen0" and Device "Videocard0");


If you wanna go this route, make sure to backup your xorg.conf file before you touch it, and restart the VM to apply changes.


Section "Screen"
    Identifier     "Screen0"
    Device      "VMware SVGA"
    Monitor     "vmware"
    Subsection "Display"
        Depth       4
        Modes       "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       8
        Modes       "400x300"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       15
        Modes       "400x300"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "400x300"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "400x300"
        ViewPort    0 0
    EndSubsection
EndSection

Open in new window

0
 
sobeservices2Author Commented:
Ok this threw an error durring reboot which I think was good in a way because it brought be to X server screen resolution setup screen where I could pick my video card resolution and LCD screen
I picked the LCD with the highest resolution

Rebooted nothing happened let me check some more
0
 
sobeservices2Author Commented:
I think I am on to something will post results
0
 
ddiazpCommented:
Don't pick the highest resolution; increase it by steps. First select 1024x768, if that works keep going up.
0
 
sobeservices2Author Commented:
That's what I am doing now.. posting screen shots in a bit
0
 
sobeservices2Author Commented:
0
 
sobeservices2Author Commented:
I ended up figuring it out it wasn't exactly like what they said but lead me in the right direction
0
 
sobeservices2Author Commented:
Hay looking to do this on my solaris box with screen resolution issues any assistance because what ive tried hasn't worked
0
All Courses

From novice to tech pro — start learning today.