• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1004
  • Last Modified:

Windows 7 -- I'm the Administrator, but I can't access files?

Something weird is going on. I have a home office, and my account is set up as an Admin and the ONLY account. Let now it's telling me I don't have permission to move certain files.

Why would this happen?

How do I reset access for ALL files on the computer so that I have absolute omnipotent authority over all the files on my OWN computer?
0
freshjuice
Asked:
freshjuice
  • 5
  • 4
  • 3
  • +4
3 Solutions
 
dufydCommented:
what types of files are you trying to move? maybe some system files?

anyways this is what you need to do.

restart your computer and as its starting up press F8, this will get you a menu select safe mode.
once in safe mode you can go to the files, select them, right click and select properties. Then go to security and you can take ownership of the file, then you can do what ever you want with them.

Be careful of what you are moving.

I can give you more detailed instructions but this should be enough. let me know :)
0
 
jkurantCommented:
I have seen this happen on my Windows 7 system when I actually do have access to the file, but it is in use at the time I try to write to it, delete it, move it, etc. I get the message that I don't have permissions, but the real problem is that the file is in use. It seems that the code generates the error message about permissions without really investigating the reason why the change failed.
0
 
burdsjmCommented:
Try to "Run as Administrator" or turn your User access control down or off.
0
Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

 
woolnoirCommented:
Right click, properties, security, advanced, owner tab ... what is this set to for the files in question ? if they arent system files, take ownership and you can access.

As for reset all files... i wouldnt recomend it, changing permissions en mass as you are requesting is asking for trouble. if the problematic files are only a small set deal with them , dont use a sledgehammer to crack an egg :)
0
 
ken2421Commented:
I see this from time to time using windows explorer. Double click on a folder and then it will start elevating your authority. After it finishes you can do as you will.

Ken
0
 
freshjuiceAuthor Commented:
These are just plain old PDF files. Nothing special. I can't even open them!

Trying suggestions right now...
0
 
jkurantCommented:
I would guess that you have an instance of adobe acrobat reader running in the background that has the files locked. Check your task mgr.
0
 
freshjuiceAuthor Commented:
I noticed the folder in question was set to "read only" for some files. I unchecked it to change that for all files and subfolders and got this message:
9-13-2010-12-21-25-PM.png
0
 
ken2421Commented:
That is the nature of .pdf files. They cannot be modified.

Ken
0
 
freshjuiceAuthor Commented:

I would guess that you have an instance of adobe acrobat reader running  in the background that has the files locked. Check your task mgr.


Nope. Not applicable. This applies to other files that are not PDF as well.
0
 
jkurantCommented:
I think you should consider @dufyd's suggestion that you reboot, using F8 to get access to the file system via Safe Mode and see if you can wrestle control of the files that way. I still suspect they are in use, somehow, because I can't understand otherwise why you would not be able to set permissions on them, as you found when trying to make them read/write.
0
 
freshjuiceAuthor Commented:
@ken - That is incorrect, and not the issue.  PDFs are very editable if you have Acrobat Pro, which I do.
0
 
ken2421Commented:
My bad about pdf.



Windows 7 has implemented addition security mechanism to prevent accidental or intentional file or folder modification by not allowing users other then owner of file or folder to access it. Hence incase if you need to access, modify or delete such files or folder you need to take ownership first then assign rights or permission to respective users. Here is Guide on How to take Ownership and Grant Permission in Window 7.
How to Take Ownership in Windows 7
1. Locate the file or folder on which you want to take ownership in windows explorer

2. Right click on file or folder and select “Properties” from Context Menu

3. Click on Security tab



4. Click on “Advance”

5. Now click on Owner tab in Advance Security Settings for User windows



6. Click on Edit Button and select user from given Change Owner to list if user or group is not in given list then click on other users or groups. Enter name of user/group and click ok.



8. Now select User/group and click apply and ok. (Check “Replace owner on subcontainers and objects” if you have files and folder within selected folder)

9. Click ok when Windows Security Prompt is displayed



10. Now Owner name must have changed.

11. Now click Ok to exist from Properties windows

Once you have taken the ownership of file or folder next part comes is Granting Permissions to that file/folder or object.

How to Grant Permissions in Windows 7
1. Locate the file or folder on which you want to take ownership in windows explorer

2. Right click on file or folder and select “Properties” from Context Menu

3. Click on Edit button in Properties windows Click ok to confirm UAC elevation request.

4. Select user/group from permission windows or click add to add other user or group.

5. Now under Permission section check the rights which you want to grant i.e check “Full Control” under the “Allow” column to assign full access rights control permissions to Administrators group.



6. Click Ok for changes to take effect and click ok final ok to exit from Properties window.


Now you can access files of folder in windows 7 with full permissions and take full control. Here is another simplest method to take ownership, Method to Add Take ownership Option in Right Click Menu.
0
 
torimarCommented:
You could use Unlocker to check what is locking those files: http://ccollomb.free.fr/unlocker/

Are those files on an external media? Were they copied there from another computer? And is that media formatted Ntfs by any chance?
Then it's the NTFS file permission and security system that is causing this. You may be an administrator on your present PC, but you are not identified as the one who created those files on the media.
Hence you will have to first take ownership, as described above or in this link:
http://www.blogsdna.com/2159/how-to-take-ownership-grant-permissions-to-access-files-folder-in-windows-7.htm
0
 
freshjuiceAuthor Commented:
Issue was solved by changing the inherited permissions for all children subfolders and files within main documents folder for the HomeUsers group.

 (Properties, Security, Permissions, Change Permissions "HomeUsers" Allow all, Select "Replace all child object permissions..." Apply)

Apparently HomeUser Permissions can override an administrator? That seems screwed up to me!
0
 
jkurantCommented:
Freshjuice, would you mind sharing how you blurred out that pdf filename that was displayed on the error dialog you included in this question? I know I could do it with The Gimp, but is there a quickie utility out there for capturing screenshots and blurring out stuff?
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 4
  • 3
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now