We help IT Professionals succeed at work.

LDAP/Authentication isseu

670 Views
Last Modified: 2013-12-24
Hello Experts,

For some time now (few weeks) we have had a systemic issue with one of our applications that uses LDAP to authenticate.

We use a program called Presenter, that uses the LDAP protocol to authenticate users from Active Directory. When the users open internet explorer and go to the site it display an error message.

ERROR MESSAGE
An unexpected error occurred.
Could not open LDAP://CN=Desktop Users, OU=_DistributionGroups,DC= domainn,DC=com

When the user gets this error message they do not get directed to the login page or anything just a white IE page with this message. The interesting thing is that if they continually "refresh" "F5" the page if this error message appears after say about 5-10 times of "refreshes" they will get to the login page.

I have found this MS KB Artical which describes symptoms we are having but I do not what to apply this fix until I have done some more troubleshooting.

If any one has any ideas as where to start any suggestions would be greatlty appreciated.

I have attached the exact screenshot of what a user will encounter when trying to access this site (internal site).
LDAP-error-meesage.JPG
Comment
Watch Question

Did you try different browser ?
Software Engineer
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Author

Commented:
Thanks for the responses...
@ Roads - We have tried different broswers and this does not make a difference.

@ noci - This is the link that the users have been using for quite awhile now. It has always worked before. I do not administer the "Presenter" server. I have asked the development team and they have said that no changes have been made.

Where could we start to diagose this issue? Is there any tools out there that could be helpful?

Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Author

Commented:
When we use the syntax you have stated before (ldap://ldapserver[:port]/query[?filter]) it does not work. All that happens is we get a "searching directory services" dialog box and then it times out.
LDAP-search-dialog-box.JPG
nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Besides syntax, if the backend LDAP / AD server is to slow with a respons it will also be taken as a refusal.
That would at least explain the F5 behaviour.

So try to find out if there are any differences in performance between the presenter server and the ldap server.
nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
the ldap port is 389 (default). not 24500.... and default can be omitted.
and ldapserver is the actual ldapserver not  a webserver server.
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Author

Commented:
24500 is the port that they have always used. Nothing has change (that I know of). Here is the KB artical that explains our symptoms. Take a look and let me know what you think. I have not tried this yet...

http://support.microsoft.com/kb/908370
nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Well that article also mentions LDAP access problems, where the underlying cause is lsot packets in the teaming and or lower driver(s).

They suggest a particular installation order in the Resolution section. That seems at least a viable start to at least exclude that the problem is in that area.
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Author

Commented:
We have used a work-a-round solution for this as the following KB artical has not solved this issue.

Thanks for the suggestions.
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Author

Commented:
Thanks for your help.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.