Solved

Authentication Not Working in Reporting Services

Posted on 2010-09-13
4
408 Views
Last Modified: 2012-05-10
I am hoping you can help me out with this issue.   If I go the link http://<computername>/reports/pages/folder.aspx and try and enter in my credentials it eventually fails citing "HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)"
However if we use the ip address of the server http://<ip address>/reports/pages/folder.aspx  you are logged in without issue.  I am trying to determine if it is an IIS issue or a DNS problem.  It seems changing the authentication methods in IIS does not make a difference.  Any ideas?  Please advise
0
Comment
Question by:Shumai1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 2

Expert Comment

by:Newco
ID: 33667157
Make sure the report website (ReportServer) is in the default website; then look at the default website properties and make sure the IP is se to (All Unassigned).

You may be specifying the server IP and that's why the name does not work.

Cheers,
0
 

Author Comment

by:Shumai1
ID: 33667180
It meets the following conditions you referred to.  Is there anything else I should check?
0
 
LVL 2

Assisted Solution

by:Newco
Newco earned 125 total points
ID: 33667264
Can you double check your permissions within the report services site? look at this thread: http://www.experts-exchange.com/Microsoft/Development/MS-SQL-Server/Q_21848418.html
0
 

Accepted Solution

by:
Shumai1 earned 0 total points
ID: 33668623
In order to get it to work I had to enable anonymous and basic authentication in the default website properties in IIS.  I was able to pull up the reporting services home page but there were no options.  I then had to add the specific usernames in SSMS under reporting services.  By right clicking on the home directory and going to properties you can add the individual users.
0

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question