Solved

Adobe SVG Viewer won't load in .NET browser control on a Windows 7 64bit OS

Posted on 2010-09-13
4
2,391 Views
Last Modified: 2013-11-29
I have a VB.NET windows application running on the 64bit version of Windows 7 that utilizes a
browser control. The browser control loads a page which uses the Adobe SVG viewer to load
a GIS map. The control works fine when loaded directly in the 32bit version of IE but when I try
to load the SVG viewer within the browser contol I only get the outline of the map with a red X in
top left corner.

It's well known that the Adobe SVG viewer is not supported by the 64bit version of IE8. Is there
any way to force the browser control to use the 32bit version of IE rather than the 64 bit? I would
like to continue to use the browser control as it works fine on any of the 32bit Windows systems
we have the application deployed on. The issues is with the Adobe SVG viewer loading in the
browser control on the Windows 7 64bit systems.

Any help would be greatly appreciated!
0
Comment
Question by:CaptainCrunch7777
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 19

Expert Comment

by:Rimvis
ID: 33805890
Hi CaptainCrunch7777, Check compilation settings for your app. If it is set to "Any CPU", try to use "x86". Maybe this way browser control will load 32-bit IE.
0
 

Author Comment

by:CaptainCrunch7777
ID: 33808683
Hi Sage,

I've tried that but the app will always load the 64 bit version of IE no matter which CPU it's compiled for.
0
 

Accepted Solution

by:
CaptainCrunch7777 earned 0 total points
ID: 33808725
I have solved the issue. It was the Windows Data Execution Prevention that was preventing the viewer from loading in the browser control. To disable DEP in the EXE you need to do the following:

Go to Project Properties -> Compile -> Build Events

Paste the following under post-build:

call "$(DevEnvDir)..\tools\vsvars32.bat"
editbin.exe /NXCOMPAT:NO "$(TargetPath)"

When creating the install package, use the EXE from the obj\Release folder rather than the bin\Release folder, so I had to add another post-build line to patch that one too
0
 

Expert Comment

by:Cut_OS
ID: 33842376
Good solution, thank you so much!
A better way: Go to the project-linker-settings and add under command-line options:

/NXCOMPAT:NO
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

On some Windows 7 (SP1) computers, Windows Update becomes super slow even the computer is reasonably fast.  There's one solution that seemed to have worked well for me (after trying a few other suggested solutions).
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question