Solved

Help with using GalSync

Posted on 2010-09-13
9
628 Views
Last Modified: 2012-05-10
HI,

I  followed the steps from the article below on how to configure GalSync.  Everything looks correct and I get a success message.  However, I do not see any contacts in the OU's created.  I checked the event logs and I do not see any errors.  I know Im missing something but cant seem to find it.
http://msmvps.com/blogs/clustering/archive/2004/10/06/15141.aspx

The only difference is that I installed this on a member server and not a DC.

Thanks
David
0
Comment
Question by:dross333
  • 5
  • 3
9 Comments
 
LVL 32

Expert Comment

by:endital1097
ID: 33668094
did you execute the run profiles? export is the one that performs the magic
check your metaverse for the objects
0
 

Author Comment

by:dross333
ID: 33673005
Thanks for the reply.  I just cheked my settings and had one step missing.  I added the step and ran the runs are per the article.  It runs successfully and I can see the data in the source server when doing a metaverse search.  However, if I go to the forestB>contacts OU, there is nothing in there.  Same on the other side.

There are no errors.  is there anywhere else I can look as to where a possible may be?

Thanks
0
 

Author Comment

by:dross333
ID: 33692607
I have been unable to get this to work in the last few days. All my tests run with success, but I do not see the contacts in either of the destination forest OU. Here are my settings.
 
Here are my ILM 2007 settings.  Any help would be appreciated.  I would think that if there was a permissions issues, I would see a failure somewhere.
Configure Active Directory Forest:
Forest name:abc.com
Domain name: abc.com

Configure Directory Partition:
DC=abc, DC=com
Container: I have checked the GALSynchronization folder. includes forestB >Contacts and abc>Contacts, Users, Groups
Configure GAL:
Target: OU=Contacts,OU=ForestB,OU=GALSynchronization,DC=nyc,DC=com
Source:OU=Contacts,OU=abc,OU=GALSynchronization,DC=nyc,DC=com
 
The above is almost the same on the other forest, just reversed.
 
All other settings are default.
 
Thanks
David
0
 
LVL 1

Expert Comment

by:jimjohnston
ID: 33762629
click on one of your users under metaverse search , select 'connectors', and validate that there are two connectors - one for the source MA and one for the target MA.

If not - under Tools, Options, validate that provisioning is enabled, and that you're calling the GALSync.dll .
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:dross333
ID: 33793081
Thanks for the above.  You may be on to something.  I only see one connector when I click on the user.  Also, when I click on Tools, Options, I do have provisioning enabled and using the GALsync.dll.  Any suggestions on where to go from here?

Thanks
David
0
 
LVL 1

Accepted Solution

by:
jimjohnston earned 500 total points
ID: 33793109
go to connectors, then click on the the single connector to open it up.  once it's open, do a 'preview, full preview.  see if you get a connector added under 'connector add'

i'm also going to assume that you've done a Full Import of your target MA?  if you don't have your target OU structure populated in the connector space, provisioning will fail with a No Parent Object error.
0
 

Author Comment

by:dross333
ID: 33793895
Thanks Much.  I am almost there.  I think my problem was, I hate to admit this, I had created 2 servers for ILM.  1 in each forest.  Based on your post above, I created both MA's on the ILM server in the destination forest.  I ran, Full Import (Stage), Full Sync, Export, and Delta Import.  They all ran successfully,   A contact was created in the destination forest for the user in the source forest.  but not the other way around.  Also, what sequence of run commands to I need to perform for a future sync
0
 

Author Closing Comment

by:dross333
ID: 33794162
OK, I got everything working.  I have setup a scheduled task to run the Galsync nightly.  I appreciate your help as it provided the correct questions and advice to get me where I needed.

-David
0
 
LVL 1

Expert Comment

by:jimjohnston
ID: 33794259
fantastic!  post another question if you run into other issues.

jim
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
Familiarize people with the process of utilizing SQL Server views from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Access…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now