[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1765
  • Last Modified:

How do I get past "ASP.NET 2.0 has not been registered on the Web server" error?

I have a server that has been recently upgraded to Windows Server 2008.  I am trying to open an ASP.Net application using Visual Studio 2008 on that machine, and when I try to open the project I receive the error "ASP.NET 2.0 has not been registered on the Web server.  You need to manually configure you[sic] Web server for ASP.NET 2.0 in order for your site to run correctly, Press F1 for more details.

It seems that every solution that I see is for a different OS, and the options have changed with WS 2008.  Can someone step me through this?  Thank you!
0
masterbeat
Asked:
masterbeat
  • 2
1 Solution
 
shalabhsharmaCommented:
You may open Control Panel -> Programs -> Turn Windows Features On or Off, in the prompted dialog, drill in until you find Internet Information Services –> World Wide Web Services –> Application Development Features and then make sure the ASP.NET box is checked.
0
 
masterbeatAuthor Commented:
Actually, after some more hunting, I found the location - the problem that I kept having is that the place to turn it on is NOT in the locations mentioned above.  For Windows Server 2008 you must go into Roles (Not Features), Web Server (IIS), Role Services, Application Development - and THEN you can turn on ASP.Net.
0
 
masterbeatAuthor Commented:
Nobody else submitted a valid answer, had to dig around and figure it out for myself.
0

Featured Post

Learn to develop an Android App

Want to increase your earning potential in 2018? Pad your resume with app building experience. Learn how with this hands-on course.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now