Solved

Companyweb not accessible after IIS reinstallation - "Service Unavailable"

Posted on 2010-09-13
8
976 Views
Last Modified: 2012-05-10
SBS2003, Exchange 2003 SP2

After experiencing many problems with IIS and OWA over the past couple of days, I decided to strictly follow the procedure for uninstalling/reinstalling IIS.  I uninstalled IIS, then reinstalled IIS, then reinstalled Exchange, installed service pack 2 for exchange, etc..   I can no longer browse to "companyweb", I just get "service unavailable", and error 2214 (isapi filter problem) keeps appearing in the event logs.  I also get the same error now when trying to browse to OWA, and (obviously) our activesync out to all iphones is broken as well because of this.  Can anybody help???
0
Comment
Question by:zagnutttt4
8 Comments
 
LVL 9

Accepted Solution

by:
v_9mhdrf earned 500 total points
ID: 33668578
Please try the following steps posted below:-

Compare the NTFS permissions on the files called in the event 2214 to a
working SBS 2003 server. Make the appropriate permission changes.

Also, look at the NTFS permissions on the following list of folders and
again make the appropriate permission changes, allowing them to propagate
to subfolders and files.

C:\Windows\Temp
C;\Windows\System32
C:\Documents and Settings
C:\Documents and Settings\Administrator
C:\Documents and Settings\Administrator\Local Settings\Temp
C:\Windows\Microsoft.NET\Framework\v1.1.4322\Tempo rary ASP.NET Files

C:\Inetpub
C:\Inetpub\backup
C:\Inetpub\clienthelp
C:\Inetpub\companyweb
C:\Inetpub\connectcomputer
C:\Inetpub\monitoring
C:\Inetpub\remote
C:\Inetpub\sbsflt
C:\Inetpub\wwwroot

C:\Program Files\ExchSrvr

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\50\Bin
C:\Program Files\Common Files\Microsoft Shared\Web Server
Extensions\50\Bin\fpexedll.dll
C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\60\Bin
C:\Program Files\Common Files\Microsoft Shared\Web Server
Extensions\60\Bin\stsfltr.dll

In addition, add Local Service and Network Service with Full Control to
permissions on the following:

C:\Windows\Microsoft.NET\Framework\v1.1.4322
C:\Windows\Microsoft.NET\Framework\v1.1.4322\Tempo rary ASP.NET Files

Restart the defaultapppool, the default web site and companyweb site.

If it is not the case, please check the following KBs to see if there is
any help:

You receive a "Service Unavailable" error message when you browse an IIS
6.0 Web page on a Windows Server 2003-based domain controller
http://support.microsoft.com/default...b;en-us;842493

Clients receive a "service unavailable" error message in their Web browsers
when you run many application pools under separate identities in IIS
http://support.microsoft.com/default...b;en-us;831135

"HTTP 503 service unavailable" error message if AppPoolQueueLength value Is
too low
http://support.microsoft.com/default...b;en-us;816995

How to troubleshoot the "503 Service Unavailable" error message in Outlook
Web Access in Exchange Server 2003
http://support.microsoft.com/default...b;en-us;823159

http://support.microsoft.com/kb/305030

If the above efforts do not solve the issue, please try the following KB to
recreate a the companyweb:

How to perform a disaster recovery operation of SharePoint Services
Companyweb and SharePoint Services Databases
http://support.microsoft.com/default...b;en-us;827701

0
 
LVL 4

Expert Comment

by:ashaw2009
ID: 33669159
What you may need to do is open the SBS administrative console from the administrative tools and then run the "connect to the internet wizard"  and the "Configure remote access wizard"

This should reconfigure the registry settings that were modified when you uninstalled IIS
0
 
LVL 3

Expert Comment

by:proadmin
ID: 33669182
Normally when IIS is broken its because its trying to boot an ISAPI filter that is not configured properly... I suggest you remove the role and re-add it. Then start from there.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:zagnutttt4
ID: 33672072
@ashaw:  I haven't run any of the SBS wizards in years, we no longer use ISA, we really don't use it like an SBS server anymore, just a domain controller that happens to be running Exchange and Sharepoint, basically.  Of course, I guess that IS SBS.  :)   Do you think running the wizards will fix?  I will try.

@proadmin:  When you say remove the 'role', do you mean remove the role of application server?  and then re-add?  It would seem to me that I already did that by manually uninstalling IIS and ASP.NET, and reinstalling them.. ?
0
 

Author Comment

by:zagnutttt4
ID: 33672257
@ashaw:  Just a quick update, the wizards did not fix the problem.  
0
 
LVL 4

Expert Comment

by:ashaw2009
ID: 33672844
The problem with SBS is that Exchange/OWA/COmpany web and Remote Web Workplace are all tightly integrated. The configuration is different to any normal IIS/Exchange setup and removing any one of those components tends to break things quick smart.

Can you tell me if RWW is still used on the SBS box? Also is it still working?

You probably need to look at the follwowing instructions on re-installing Sharepoint. This should get Company web working again however it may break RWW.
http://support.microsoft.com/kb/829114

Not sure how you uninstalled IIS, but there is an SBS way to do that. Please ensure you look at the following article and refer to the SBS section.:
http://support.microsoft.com/kb/320202
0
 

Author Comment

by:zagnutttt4
ID: 33673457
We do not still use RWW - I can test it to see if it's still working.  What's the internal link?  It's been years.

I managed to get companyweb working again by doing a system-state restore from the other day.  However, I still have broken OWA and broken ActiveSync, so I'm back to where I started on my other thread.  See http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26466827.html 

If I could just get Exchange ActiveSync working again it would be great, but I've tried EVERYTHING
0
 

Author Closing Comment

by:zagnutttt4
ID: 33684095
Permissions Issue fixed companyweb, so I'm closing this question out and awarding points.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

815 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now