Godaddy Hosted Account Setting max allowed packet setting

Hello I have a client that needs to change the "max allowed packet" settings on his godaddy account. He has a PHP program that is currently set at 32M but it needs to be 96MB. In phpmyadmin I can see its set to this "max allowed packet 33,554,432" However not being a linux guru we have no idea where to change this setting, if its a database setting of a php setting. I have found the php.ini file but it does not reference it. We have been trying to fix this for days and its outside of Godaddys support realm. Any help would greatly be appreciated. He do not currently have ssh access but have ftp.

(I know this is also in the Exchange category, I cant figure out how to remove it since the new layout of this website.)
borgmemberAsked:
Who is Participating?
 
Ray PaseurConnect With a Mentor Commented:
The advice here is exactly right:
http://forums.devshed.com/showpost.php?p=1061285&postcount=2

You do not want or need large binary columns in a data base.  Consider what will happen to performance when some novice programmer writes this line of code:

SELECT * FROM...

There are many alternatives to GoDaddy, and almost all of them have better tech support.  This question should have been answered on the first call immediately.  I use and recommend ChiHost.  Other good ones include DreamHost, HostGator, and Liquid Web.  I do not recommend GoDaddy or SiteGround because of the REPEATED HORRID tech support experiences I have had with those companies.

Good luck with the project (and upgrade the code to store the BLOBs on the file systems instead of the data base), ~Ray
0
 
proadminCommented:
Hello friend. Your right many times the php.ini file doesn't have the setting so it reverts to 'default', however you can over-ride this by manually putting the setting into the ini file.

Here's what to do:

Add this line to php.ini:

max_allowed_packet=96M

Reset web service or reboot. You can always create a info.php file that states:

<?php phpinfo(); ?>

If you run that it should show you all of your settings to make sure it took. Best of luck!
0
 
torimarCommented:
It's a MySQL setting.

You may try to (temporarily) increase the packet size by issuing this SQL statement inside phpMyAdmin:
SET GLOBAL max_allowed_packet=100663296;

In order to make the setting permanent (i.e. survive a restart of the MySQL daemon or the server) you would have to modify the MySQL config file - which you cannot do via FTP; you'd need direct root access to the server running the database.

You could also try to modify the value inside the respective PHP files of the PHP application by adding:

function max_packet_init(){
  //Set the value to 96 MB.
  db_query('SET SESSION max_allowed_packet=96*1024*1024');
}

However, for shared hosting, also mind this note: http://forums.devshed.com/showpost.php?p=1061285&postcount=2
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
madunixCommented:
see  mysql sample configuration (/etc/my.cnf) file

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
max_allowed_packet = 16M
# Default to using old password format for compatibility with mysql 3.x
# clients (those using the mysqlclient10 compatibility package).
# old_passwords=1
# old-passwords=1

# Disabling symbolic-links is recommended to prevent assorted security risks;
# to do so, uncomment this line:
# symbolic-links=0

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
0
 
borgmemberAuthor Commented:
See post.
0
 
Ray PaseurCommented:
Thanks for the points -- good luck with your project, ~Ray
0
 
torimarCommented:
borgmember,

in your question you asked how to increase the 'max_allowed_packet' size, because "it needs to be 96MB".
In my comment ID:33669202 I told you how this could be done; I also added a link to a resource which warns about proceeding this way and suggests an alternative.

You now chose a solution which comments the link I posted as being "exactly right", and then talks you out of the issue instead of solving it. Whereas I understand that the indubitable expertise and integrity of the expert giving that advice makes it tempting, if not imperative, to follow it, I must express my disappointment about the fact that my efforts at taking your original intentions seriously were not even deemed worth the credit of an assist.

0
 
borgmemberAuthor Commented:
Hello,

Nothing personal on this. I have been so busy this slipped under the radar, and when I noticed it was still opened I used my memory to quickly close it up. I do remember he couldnt make it work, but its been too long. Thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.