Solved

Send email do SharePoint Document Library - not working

Posted on 2010-09-13
9
942 Views
Last Modified: 2012-06-27
Hi all,

on a SBS2008 I set up a Document Library on Companyweb (http://support.microsoft.com/kb/961300) then assigned an email address, which matches my new contact created in Exchange 2007.

I then send a test mail from my mailbox to the new contact, hoping to see the test mail listed on my Document Library but... nope.

No NDR, no error logs, nothing...  Tried requesting a delivery receipt and a read receipt, nothing...

What's wrong here ?

Thanks.
0
Comment
Question by:DaBoags
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 11

Expert Comment

by:FastFngrz
ID: 33669275
There's a lot that has to go on before getting an attachment into a Doclib.

1.  Make sure IIS's SMTP server is installed and running on the farm
2. In Central Admin, define the address space that sharepoint will live in "*@my.domain.com"  .  Set it to automatic pickup
3. In your Exchange transport rules, you'll want to say *@my.domain.com" gets forward to an SMTP relay of your Sharepoint box.
4. Turn on verbose logging on both the SMTP Send Connector in Exchange and on the IIS connector in Sharepoint.
5. Watch your Sharepoint event viewer logs, they'll report every minute whether or not something was picked up.
6. Double check the email address of the document library, and change the permissions so that anyone can submit mail.  (Once you've got it running, you can lock down the permissions)

Basically, the flow is like this

email from outlook/internet/wherever goes into Exchange
Exchange has an SMTP relay assigned for that address space
Exchange pushes the mail to the IIS SMTP dropbox
Sharepoint monitors the dropbox every minute and
Sharepoint picks up the email, looks for a valid recipient match to a list/library.
Sharepoint checks permissions - the sender must have contribute rights by default!
If it's a document library, attachments turn into documents, other metadata is recorded as well.

With logging cranked up, you'll see the email leave Exchange, go to IIS SMTP, see Sharepoint pick it up and put it in a doclib.

Good luck!


0
 

Author Comment

by:DaBoags
ID: 33669290
Mmh thanks, you'd think they made it more straightforward.  Can u walk mw tru steps 2 & 3 please ? I think I've set it up already but I may have left a checkbox or two...

Txs
0
 
LVL 11

Expert Comment

by:FastFngrz
ID: 33673547
It would be best if you create a 3rd tier domain name for your sharepoint lists... for example, if your 'regular' exchange/internet domain name is "domain.com", assign sharepoint as "sharepoint.domain.com".  In your DNS server, create an MX record for "sharepoint.domain.com" that points to the Sharepoint server.

Sharing the same domain name as the rest of your exchange organization is somewhat difficult, as Exchange won't know how to route emails for doclib@domain.com to sharepoint, as opposed to doclib@sharepoint.domain.com, which then becomes it's totally own namespace.

Item #2 - checking Central admin, refer to
http://searchexchange.techtarget.com/generic/0,295582,sid43_gci1262914,00.html


0
Increase Agility with Enabled Toolchains

Connect your existing build, deployment, management, monitoring, and collaboration platforms. From Puppet to Chef, HipChat to Slack, ServiceNow to JIRA, Splunk to New Relic and beyond, hand off data between systems to engage the right people.

Connect with xMatters.

 

Author Comment

by:DaBoags
ID: 33688359
Thanks, I just created the MX record in my DNS but now I get NDR's "SMTPSEND.DNS.MxLoopback; DNS records for this domain are configured in a loop ##

This is an SBS so it's all on the same box... Exchange finds the contact @companyweb then looks for an MX, finds it to point to itself so there goes the loop... I'm following this basically http://blogs.technet.com/b/sbs/archive/2009/02/02/how-to-use-outlook-to-send-email-to-a-sharepoint-document-library-on-sbs-2008.aspx but it's obviously missing something...
0
 
LVL 11

Expert Comment

by:FastFngrz
ID: 33691774
Oh.. .SBS 2008?   that would have been good to know from the start.   In that case, SBS wizards set it all up for you, and the "smtp domain" of Sharepoint defaults to "companyweb".  In general, the more you deviate from SBS wizardry, the more challenges you'll face.

SO... let's get rid of the MX record, put the Central Admin back to
 - Enable sites: yes and "Advanced"
-  No to SharePoint directory Management
-  mylist @ "companyweb"
- C:\inetpub\mailroot\drop

IIS SMTP is NOT needed, and if it is on, will conflict with Exchange 2007.  Make sure IIS SMTP is off/disabled.

Monitor the \inetpub\mailroot\drop folder for files... if they show up there, then Exchange is doing it's job - and we can divide and conquor from there.
0
 

Author Comment

by:DaBoags
ID: 33712534
Done that. still no email showing up in Companyweb...  Followed all the wizardry I could find, all the blogs etc.  Darn thing won't work.
0
 
LVL 11

Accepted Solution

by:
FastFngrz earned 500 total points
ID: 33713641
Ok, what's the SMTP address of the list/library, and what's the SMTP address you are sending to?
Then, does anything show up in C:\inetpub\mailroot\drop?   Is there anything in that folder now?
SBS should allow you to 'track message' - see the Exchange Management Console-Tools-message tracking and it will tell you what it's doing with the emails.
0
 

Author Comment

by:DaBoags
ID: 33713789
Ok, here are the settings :

In SharePoint Central Admin :
Tab "Operations"
Outgoing :
- SMTP : CANCSBS.CANC.LOCAL
- Email : cancadmin@canc.nc

Incoming :
- Allow : yes
- Advanced
- Directory : yes (OU=SBSUsers,OU=Users,OU=MyBusiness,DC=canc,DC=local)
- SMTP : CANCSBS.CANC.LOCAL
- Authenticated only : no
- Distribution Group : yes
- Approval settings : Yes no no Yes
- Email : mylist@companyweb
- Drop : C:\inetpub\mailroot\drop

In Companyweb
Outgoing email settings :
- Authorise : yes
- Email address : presse@companyweb
- Attachments : all in root
- Replace : no
- Save original : yes
- Save requests : no
- Security : accept all

In Exchange
Contact : SMTP address : presse@companyweb

In DNS
Nothing

(translation may be approximate, server is in FR...)

Thanks
0
 

Author Closing Comment

by:DaBoags
ID: 33713803
HA ! Just going tru all my settings and your messages, now it works... go figure, I haven't changed anything :)

Anyways, thanks a lot, I'll award the points since you've been so helpful :)
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question