VxVM vxassist ERROR V-5-1-752 No volume can be created within the given constraints

Posted on 2010-09-13
Medium Priority
Last Modified: 2013-12-21
Tried to resize filesystem after 3par added disks. Can anyone help with this error message?
Question by:Rhiaanon44
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
LVL 13

Expert Comment

ID: 33669679
what does "vxassist -g dgname maxsize" give you?
Is vxvm aware of the new disks? can you see them? what is their status?
vxdisk -eo alldgs list

Author Comment

ID: 33669831
Hi. Why would I have duplicate file:
# vxdg free
GROUP        DISK         DEVICE       TAG          OFFSET    LENGTH    FLAGS
mss01dg      tormss01-01  c6t50002AC000B505E0d0s2 c6t50002AC000B505E0d0 0         2448      -
mss01dg      tormss01-01  c6t50002AC000B505E0d0s2 c6t50002AC000B505E0d0 62917008  4120944   -
LVL 13

Expert Comment

ID: 33669865
they're different space on the same device. Notice the offset and length values.
Get real performance insights from real users

Key features:
- Total Pages Views and Load times
- Top Pages Viewed and Load Times
- Real Time Site Page Build Performance
- Users’ Browser and Platform Performance
- Geographic User Breakdown
- And more


Author Comment

ID: 33670112
Great!  Disk 21 is missing. Can I run the import command without it being disruptive? We have already expanded the LUNS then noticed 21 was missing after running vxvg free.
mss01dg      tormss01-19  c6t50002AC000BC05E0d0s2 c6t50002AC000BC05E0d0 0         3216      -
mss01dg      tormss01-20  c6t50002AC000C905E0d0s2 c6t50002AC000C905E0d0 0         9616      -
mss01dg      tormss01-22  c6t50002AC0014105E0d0s2 c6t50002AC0014105E0d0 230607600 1808

Thanks for your help. You are a wizard!
LVL 13

Accepted Solution

Rowley earned 2000 total points
ID: 33670171
When you say "missing", do you actually know you have it?

vxprint -dg mss01dg      

Does  tormss01-21 show up anywhere? Is it part of any volumes that you know of?

vxprint -vthg mss01dg | grep tormss01-21

Author Comment

ID: 33670240
It is there thanks a million!

Author Closing Comment

ID: 33670250
Everything you typed was necessary. Thanks again!
LVL 13

Expert Comment

ID: 33670310
You are welcome.

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses
Course of the Month13 days, 10 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question