Solved

Manual Entry for DNS

Posted on 2010-09-14
56
552 Views
Last Modified: 2012-05-10
Hi I have inherited a domain which is in the format of companyname.co.uk not .local. The company use OWA which is accessed by http/s://name.companyname.com/exchange. The issue i have is that everyone can access the OWA external but not internal as i need to resolve the DNS entry for http/s://name.companyname.com/exchange to resolve to an internal IP while on the local domain.

IPAD/Phone users work fine externally but not when connected to the local LAN as the setup in the device is looking for the external IP not internal.

IS their anyway i can add http/s://name.companyname.com/exchange to DNS on the LAN to resolve to the internal IP address?

It is on a MS 2003 server with full AD.

Many thanks.
0
Comment
Question by:FattyPo
  • 20
  • 18
  • 13
  • +2
56 Comments
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33669840
Just create a Host A record in the dns zone companyname.co.uk (on your dns server) called www. or owa or whatever people type before the companyname.co.uk part when accessing externally. and point it to the internal IP of your mail server.

This is very common set up
0
 
LVL 11

Expert Comment

by:elbereth21
ID: 33669847
If I understood correctly your situation, you need to create a DNS zone on your internal DNS server, for companyname.com domain. Add an A record for your mail server to this zone and there you are.
0
 

Author Comment

by:FattyPo
ID: 33669859
I have tried that, i can ping name.companyname.com and it resolves fine to the internal IP address but when i add http:// before it it still tries to access the internet and external IP address. I have tried to add an A record with http://name.companyname.com but obviously it does not allow me to do this.
0
 
LVL 11

Expert Comment

by:elbereth21
ID: 33669891
Are you using a proxy? What DNS settings does the proxy use?
Check the results of nslookup, instead of ping.
0
 

Author Comment

by:FattyPo
ID: 33669899
if i use nslookup, set q=any then query name.companyname.com it resolves to the internal IP address. The server nslookup uses is the DC on the domain.
0
 

Author Comment

by:FattyPo
ID: 33669908
sorry if i ping name.companyname.com from my PC it resolves to the external IP. Is it possible that DNS just hasn't updated on my PC. I have flushed the DNS cache.
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33669914
It sounds like you have done it right if you can ping it and get the internal IP.  
There is no reason your browser should be going to the outside IP.  You don't have any proxy settings in your browser do you?
Try closing all browser windows.  Clean your cache out.
Go to CMD and do: ipconfig /flushdns
Then going to the site again.

If you DO have proxy settings in IE then you will find that your web browser will only use DNS results provided to it by the proxy server.
0
 

Author Comment

by:FattyPo
ID: 33669928
Sorry, i can nslookup and get the internal IP but if i ping i get the external. I have flushed the DNS cahce using ipconfig/flusdns but if i ping name.companyname.com it resolves to the external IP addres.
0
 

Author Comment

by:FattyPo
ID: 33669931
oh sorry, no proxy.
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33669932
wait a sec... I'm sorry.  If you are pinging and getting back the EXTERNAL IP then it is not right.
Do you have multiple DNS servers set on your PC?  (if you do ipconfig /all is one of the DNS servers an external DNS server or your firewall?)
Windows may take turns and use the secondary DNS server sometimes to query.  Do another nslookup and use the 'server xxx.xxx.xxx.xxx' command to change the server to be the second DNS server and retest your query.
0
 

Author Comment

by:FattyPo
ID: 33669939
ok 2 DNS servers both internal i will switch to the other DNS server and test
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33669941
You don't have any conflicting entries in your HOSTS file do you?
0
 
LVL 11

Expert Comment

by:elbereth21
ID: 33669958
No, in this case, if nslookup is correct, while ping isn't, it means that you have problems with netbios name resolution. Do you have WINS servers on your network? Let's try this: can you please create an item in your hosts file?
Like this: open %systemroot%/drivers/etc/hosts
create the object IP_internal_address    website.name
0
 

Author Comment

by:FattyPo
ID: 33669968
no conflicting entries dns appears to have replicated between the servers. but if i use nslookup server xxx.xxx.xxx.xxx i get a timeout.
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33669980
No, i'm sorry if your confused but if your internal domain and external domain are different as they appear to be then netbios has nothing to do with it.
Windows tries DNS before it tries NETBIOS in order of query attempts.  If you have any HOSTS file records for that DNS entry then remove them.

Start -> Run...
notepad c:\windows\system32\drivers\etc\hosts
0
 
LVL 11

Expert Comment

by:elbereth21
ID: 33669984
The IP you are querying is that of the second DNS server?
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33669995
when i said server xxx.xxx.xxx.xxx I mean the xxx.xx.xx.xxx should be the IP address of the second server, the one you wish to query.
if you did use the IP in that command and still you are getting timeouts then your DNS server is not responding and that's a good place to start troubleshooting.
Also in the DNS snap-in on your servers right-click on the server object and choose "Clear DNS Cache".
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670005
oh I just re-read your post.  "nslookup server xxx.xxx.xxx.xxx " is not one command.
open the CMD.
then type 'nslookup' by itself.
the prompt should change.
then do the 'server x.x.x.x' command where the x.x.x.x is the IP of the server you wish to query.
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670011
After 'server x.x.x.x' command then you will tell nslookup to change servers.  then (without exiting nslookup) just type the name you wish to query (name.companyname.com) and hit enter.
0
 

Author Comment

by:FattyPo
ID: 33670016
right both DNS servers resolve the name.companyname.com to the correct internal IP address. However when i ping i get the external IP
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670022
you should be doing these nslookup queries on your PC, right?
not the server...

and when you do ipconfig /all on your PC, the DNS servers you see displayed should be those two internal servers and not any others... right?
0
 

Author Comment

by:FattyPo
ID: 33670026
yep all correct on my PC, both IP's of the DNS servers have been checked using NSlookup and they both resolve to the internal IP.
0
 

Author Comment

by:FattyPo
ID: 33670069
also checked host files no records
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670082
Try it from the DNS server itself, that would rule the clients in or out.

0
 

Author Comment

by:FattyPo
ID: 33670095
DNS server has the same issue nslookup works but ping resolves to external.
0
 
LVL 11

Expert Comment

by:Ben Personick
ID: 33670110
@FP:  Run IPConfig /ALL

Check that the ONLY DNS Server IP Addresses listed are those of your two internal DNS servers.  I'm guessing that your probably on a wireless network or have an ISP DNS server configured on one of your NICs as a DNS Server.


0
 

Author Comment

by:FattyPo
ID: 33670129
the only DNS servers listed on my PC and all 3 servers are the internal IP addresses.
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670135
Flush the dns servers local cache, try again, if it is the same then check the servers config.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:FattyPo
ID: 33670163
i have flushed the local cache, still remains the same fine on nslookup but not ping. Where else should i be looking?
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670181
something is not making sense here...
wait a sec... are you connected to a VPN tunnel?  you're sure you don't have any other active network adapters on this PC?

you could also have spyware on your PC which is redirecting your DNS queries to an outside host via an infected winsock (tcp/ip stack).  Try a different PC.  If you think you do have a corrupted winsock then use one of the steps in the two solutions listed here: http://www.experts-exchange.com/Networking/Protocols/Transport/TCP-IP/Q_26273278.html

Please double-check that there is no proxy settings either by going to Control Panel -> Internet Options -> Connections tab -> LAN Settings -> everything should be unchecked.

Some viruses will also add proxy settings in there for you.
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670187
Open the DNS console, select view set it to "advanced" and checked "cached lookups", expand ".com" then look for "companyname", see if it exists if it does delete it.


0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670192
err not viruses so much as spyware will add those proxy settings anyway...
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670196
@MojoTech:  Yeah but I already told him above to right click on the server object and clear the entire cache and I think he did.
0
 

Author Comment

by:FattyPo
ID: 33670208
I cleared the cached however, i have looked under the advanced view on the companyname under .com and it has an A record with the external IP address in.

Should i delete this?
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670213
Yes
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670225
you should not see any entries in the cache at all for companyname.com unless you actually never cleared the server cache.  You should definitely delete it and the whole comanyname.com (under the cache only of course) but if you really did clear the server's cache before then it will probably reappear the next time you query it.

If it reappears in the cache then this means your zone you created is not working right or was improperly created.  A zone that exists on the DNS server will not show up in that cache.
0
 

Author Comment

by:FattyPo
ID: 33670226
ok i have cleared the cache again and the entry has gone. I have cleared the cache on all servers and flushed my PC it still all points to the external IP when i ping :-(
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670228
Did it re-cache it?
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670233
Also do a properties on your server name in the DNS snap-in and check if you have any DNS forwarders.  You should not have any, especially not a domain specific forwarder for companyname.com!
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670238
If it was re-chaced then it is being pulled externally so check that on your dns server you do actually have the zone that reads only as

"companyname.com"

and it that zone you have an a record that reads only "name" (or whatever you use) pointing to the internal IP
0
 

Author Comment

by:FattyPo
ID: 33670251
yes it has re-cached it. i have looked under forward lookup zones, domainname.co.uk and in there the is a com with a + beside it, i click the + and the external domainname is there (companyname)
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670252
Also could you post a pic of DNS for this zone+A record? if it checks out OK.

0
 
LVL 4

Assisted Solution

by:Sean_D76
Sean_D76 earned 333 total points
ID: 33670262
well if its returning that external IP then its not the records in the zone but the zone itself which is being ignored.
you sure there's no typo in the zone name or like MojoTech said, that it says exaclty "companyname.com" and nothing else?
0
 
LVL 24

Accepted Solution

by:
Mike Thomas earned 167 total points
ID: 33670278
"yes it has re-cached it. i have looked under forward lookup zones, domainname.co.uk and in there the is a com with a + beside it, i click the + and the external domainname is there (companyname)"

This is a config issue this zone should not appear as .com under the existing zone "domainname.co.uk "

You need to right click the DNS Server and select "new zone" run through the wizard, make it forward and AD Intergrated and create a new zone called "companyname.com" then create the A record in that zone.

0
 

Author Comment

by:FattyPo
ID: 33670288
should it be a primary, secondary or sub zone?
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670295
Primary or AD intergrated, once made as primary you can convert it so roll with Primary for now.
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670315
He's quite right.  It should be it's own entry in the DNS cache directly under "com" not under anything else.
Perhaps you accidentally created it as a subdomain to your primary domain...?

not sure why it would pass an nslookup test... primary domain suffix comes into play in an nslookup query...?

0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670318
BTW once done you will have to flush the caches again, but just start on the server to prove it is working then tackle the clients.

0
 

Author Comment

by:FattyPo
ID: 33670326
Ok i know were i went wrong i created just a new A record not a new zone first. I have created the new zone added an A record for the website! as i couldn't access that. Is there anything i need to add?
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670328
If it's 2003 server, choose Primary and there will be a checkbox below which says "store the zone in active directory".
If you instead see an option for active directory integrated by itself then choose that.  I forget at which versions they changed the wizard but it will be one or the other.
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670348
That should  be it FattyPo, unlees you need other records, if your company website is external you would need a www records in that zone pointing to the external IP and so on or any external recources, anything host externally for companyname.com will not get resolved now you have created a zone unless you have records for them, these records can point internal or external, but any client using your dns server to resolve anything for comapnname.com will only look at the zone you just created, so anything which does not have a record in that zone will not get resolved.


0
 
LVL 4

Assisted Solution

by:Sean_D76
Sean_D76 earned 333 total points
ID: 33670354
you will need to manually add A records for everything that your external DNS servers are taking care of for "companyname.com".  i.e. if there's a WWW.companyname.com then add that.  if there's a ftp.companyname.com then add that and so on.  Also you can make just plain "companyname.com" point to something by creating an A record and typing nothing in the "Name:" blank.  Probably you also want that to point to your company website.
0
 
LVL 4

Expert Comment

by:Sean_D76
ID: 33670361
okay... its been fun but i'm going to bed.  ;-)
0
 

Author Comment

by:FattyPo
ID: 33670368
cheers guys much appreciated :-) i little closer to understanding DNS always fun.
0
 
LVL 24

Expert Comment

by:Mike Thomas
ID: 33670381
You're welcome, I will be here for a good 10 hours yet having just started work on the other side of the planet, so any more questions just ask.

0
 

Author Closing Comment

by:FattyPo
ID: 33670389
All i can say guys is thanks for your help and apologies for starting in the wrong place by just creating an A record!
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Most DNS problems are VERY easily troubleshot and identifiable if you can follow the steps a DNS query takes. I would like to share the step-by-step a DNS query takes from the origin to the destination. _____________________________________________…
I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now