My embedded swf file is not working in my html

Hi,

My Swf logo on my home page is appearing really small and i cant for the life of me work out why.

it is 600 x 120 but you can barely see it.

code:

<object id="flashId" classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" width="600" height="120">
<param name="movie" value="logonew.swf" />
<param name="FlashVars" value="name=Dr.Solve"/>
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="logonew.swf" width="600" height="120">
<param name="FlashVars" value="name=Dr.Solve"/>
<!--<![endif]-->
<div>
<h1>Alternative content</h1>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>

the swf is in the root of my html folder along with the index.html page

Any clues?

THanks

here is a URL to the site so you can see:

http://thinkpod.ath.cx:81
ImagineITAsked:
Who is Participating?
 
ludofulopConnect With a Mentor Commented:
hi, your swf is not 600x120, but 550x400, that's the problem.
0
 
navinmohantaCommented:
Change the following to desired

width="600" height="120"

Thanks !!
0
 
navinmohantaCommented:
I mean add the following parameter scale="exactfit" to the object tag.
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
ImagineITAuthor Commented:
Hi there,

The problem of making that larger is that the area underneath gets pushed down and leaves too much white space.

The SWF was created at 600 x 120 - so in theory the size in the script is correct.

Any more ideas?


Capture.PNG
0
 
navinmohantaCommented:
I mean add the following parameter scale="exactfit" to the object tag.
0
 
ImagineITAuthor Commented:
Hi again,

I added the Parameter, hasn't made any difference.




<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
   codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0"
   width="600" height="120" id="Untitled-1" >
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="logonew.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<param name="scale" value="exactfit" />
<embed src="logonew.swf" quality="high" bgcolor="#ffffff" width="600"
   height="120" name="mymovie" align="middle" allowScriptAccess="sameDomain"
   type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" />
</object>

Open in new window

0
 
navinmohantaCommented:
It has to be the property of the object tag

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
   codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0"
   width="600" height="120" id="Untitled-1" scale="exactfit" >
0
 
_-MYFOX-_Commented:
Try removing the tags embed parameters width="600" height="120"
like this


<embed src="logonew.swf" quality="high" bgcolor="#ffffff"  name="mymovie" align="middle" allowScriptAccess="sameDomain"
   type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" />

Open in new window

0
 
ImagineITAuthor Commented:
Hello,

have tried making both of those changes, but still not working.

ludofulup: is there a way of changing the size of the swf without creating the movie again?

Thanks for help thus far...hopefully you have some more suggestions?

0
 
ludofulopCommented:
ImagineIT:
i think you can't change the swf dimensions without editing in flash

what you can do, is to place the swf into a div with specified dimensions and setting it's overflow to hidden:


<html>
<body>

<div style="height: 120px; width: 550px; overflow: hidden">

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width="550" height="400" id="logonew" align="middle">
	<param name="allowScriptAccess" value="sameDomain" />
	<param name="movie" value="logonew.swf" />
	<param name="quality" value="high" />
	<embed src="logonew.swf" quality="high" width="550" height="400" name="logonew" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
</div>
Lorem ipsum

</body>
</html>

Open in new window

0
 
navinmohantaConnect With a Mentor Commented:
Hi,

I missed one thing need to add this to the <embed> tag
<embed src="logonew.swf" quality="high" bgcolor="#ffffff" width="600"
   height="120" name="mymovie" align="middle" allowScriptAccess="sameDomain"
   type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" scale="exactfit" />

This should solve your case.
I tried this on mine.

Thanks !
0
 
ImagineITAuthor Commented:
Great support and also very quick too. Main problem was the swf size, by changing this i was able to rectify the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.