Solved

Problem with iphone 4 syncing with Exchange 2003

Posted on 2010-09-14
30
779 Views
Last Modified: 2012-05-10
Hi,

I have just defected from a windows mobile phone to an iphone 4 and cant quite get it to sync properly with exchange. I have upgraded it to 4.1.

Calender works fine
Contact works fine
Can send email no problem

Checking mail only partially works. The first time it synced it created the inbox with all the sub folders that i have and all the other folders like sent, junk etc.

I have it set to sync the inbox and the sent folder.

Most of the sub folders in the inbox sync fine but the inbox itself and a subfolder called work and sent folder do not.

Most of my mail goes into inbox or work folders so they are large folders. The other subfolders are relatively small so I am wondering if it is a timeout issue or something like that?

When I do a manual check mail when in inbox or work, it either checks mail and the busy thing goes round and then get nothing or I get an error saying Cannot Get Mail. Server error. Contact your server administrator.

The iphone is nice to use but already a bit frustrated that you don't have complete control over all settings like you do on the WM phones.

ANybody any ideas?

thanks,
Robert
0
Comment
Question by:realtimehosting
  • 14
  • 7
  • 6
  • +1
30 Comments
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 334 total points
ID: 33670195
Please check your iis settings against my Exchange 2003 / Activesync article, run the test on the test site and if you get stuck, please shout.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 
LVL 5

Expert Comment

by:delmc
ID: 33670385
Have you set the iPhone to sync all items, this can be done by going back into the settings on the iphone and changing what items sync. If it is set to the default 3 days, then it will sync the folder structure, but won't sync anything older than 3 days.  If you have already carried this out then I would suggest following Alan's link above, as it may be a problem with the IIS/ Activesync as I recently had to carry out a rebuild of the exchange-owa folder within IIS.
0
 

Author Comment

by:realtimehosting
ID: 33670771
thanks for comments.
I have looked and tried several of Alan's post. I am not using SSL by the way.
I have tried the activesync test app on my iphone and it passes the test.

I don't understand why some folders sync but not others. I have set it to sync mail up to 1 week old which it does for the folders that work.

I have gone through the rebuild of all the echange foldrs in the default folder following the microsoft kb article.

I am still getting loads of errors, code 3005 which are http 500 errors. The bit of  Alan's post for 500 errors is for setups using SSL, which I am not.

I have set the timeout for the default site to 480 from 120.

0
 

Author Comment

by:realtimehosting
ID: 33670812
i am not sure now that the push part of email is working. If I goto one of the folders it checks mail for that folder and new mail appears but it is not appearing as soon as it comes in
0
 
LVL 5

Expert Comment

by:delmc
ID: 33670830
You could try the following utility to check from internal and external sources to see if there are any errors on the system. https://store.accessmylan.com/main/diagnostic-tools it gives some good advice and links when it finds failures within the activesync.
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 334 total points
ID: 33670834
If all is working apart from some folders, it could me Mailstore corruption.
Please test with another user account and see if you can sync all mail correctly to the iPhone.
Is Exchange part of Small Business Server 2003?
0
 

Author Comment

by:realtimehosting
ID: 33670972
the accessmylan tool passes on my iphone and on my pc, as long as I leave ssl off. It still connects with ssl on but says the certificate is not trusted, which I would expect as I have not bought a certificate for it.

Exchange is part of SBS 2003.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33671047
Okay - with SBS - as long as the name on the certificate matches the Fully Qualified Domain Name you are trying to access Activesync with, then the magic should happen.
The cert should be named something like mail.yourdomain.com and you should be specifying mail.yourdomain.com when setting up the phones for the server address.
Is this the case?
0
 

Author Comment

by:realtimehosting
ID: 33671081
but I'm not using SSL?

btw the errors (3005) from the log are all:
Unexpected Exchange mailbox Server error: Server: [hp110.domain.local] User: [robert@otherdomain.com] HTTP status code: [500]. Verify that the Exchange mailbox Server is working correctly.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33671131
You have SBS - it has an SSL certificate - why are you not using it?  It will happily work with iPhones and will be a much more secure method of connecting.
Do you want your usernames and passwords transmitted insecurely across the internet?
0
 

Author Comment

by:realtimehosting
ID: 33671143
in answer to your question, when I view the certificate in the default website, the domain I connect to for exchange is not listed in subject or issuer.
There are several CN= records but not the one I use to connect through.

0
 

Author Comment

by:realtimehosting
ID: 33671157
will worry about ssl once it's working without though.
0
 

Author Comment

by:realtimehosting
ID: 33671201
been thinking about it and looked back at old logs. I was getting an http error 409 with my old windows mobile phone sometimes. It sometimes wouldn't get push email but synced manually ok.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33671302
It will be much easier to get it working with the SSL.
As you have SBS - you can just re-run the Connect to the Internet Wizard, change nothing apart from when you reach the certificate section, then re-issue a new certificate with something like mail.yourdomain.com as the name.  Complete the wizard changing nothing else and then you will have a correctly named certificate.
At that point, re-check all your IIS settings (some may have changed) and then test again on the test site.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33671650
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:realtimehosting
ID: 33672043
Hi,

ok, have run the wizard and testexchangeconnectivity.com now works fine.

Still get Cannot Get Mail Server Error Contact your system administrator on phone though when rty to sync one of the large folders
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33672067
Are your passwords correct :)
Are you using a proxy to connect to exchange ?

go here
www.mxtoolbox.com
enter your domain name
you have to enter the server name in iphone with the - results of the first MX

Is that what you are doing ? or are you trying to enter local / internal fqdn

0
 

Author Comment

by:realtimehosting
ID: 33672073
the testexchangeconnectivity.com managed to sync my inbox. My phone won't
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33672143
please post back your thoughts on my post above.
0
 

Author Comment

by:realtimehosting
ID: 33672145
I don't want to put the mx record in. My email is routed through a third party spam checker so the mx points to their server not mine.
0
 
LVL 5

Expert Comment

by:delmc
ID: 33672160
Does your self signed certificate match the external listner on the web, it should read mail.companyname.com or something similar, if these don't match then it could lead to issues when attempting to sync the iphone. As Alan suggests re-run the internet connection wizard and redo the certificate field. May also be worthwhile redoing the firewall settings as well to reflect the services which you require to be available from outside.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33672161
go here
www.canyouseeme.org

enter your IP address from there in your iPhone
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33672248
What details are you entering in to the iPhone specifically?
The servername should just be something like mail.yourdomain.com.  You should not be adding /owa /exchange or /anything.
The domain is the internal domain name and should be the 1st 15 characters only (if you have a long domain name).  Do not add the .local to the domain name.
Username should simply be your username, not domain\username and password - well, no clues there!
0
 

Author Comment

by:realtimehosting
ID: 33672289
I have rerun the connection wizard and the certificate now matches the domain name I connect with. I have turnded ssl on on my phone in the connection settings and it is still only syncing some mailboxes and still getting the error 3005 http 500 in the log file.

Have looked back at the log files and the problem started on the 7th Sept. Not aware of any changes then.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 33672351
Have you got Host Headers setup on the default website?
Is the IP Address set to All Unassigned and the port set to port 80?
0
 

Author Comment

by:realtimehosting
ID: 33675072
Hi,

thanks for all your suggestions but still banging head on wall.

I still cant understand why some folders sync away happily but others do not.

My settings on the iphone are:
Email: robert@mydomani.com
Server: www.mydomain.com
Domain: localdomain
username: robert
password: *********

Mail Days to Sync 1 week
Mail folders to Push: Inbox + 5 sub folders

4 of the sub folders all push and sync correctly but not inbox or work sub folder.

0
 

Author Comment

by:realtimehosting
ID: 33677526
Setup a test user and everything works perfectly. There are no errors in the Application Log when it syncs.

Is it just not handling very large folders? Or is there something corrupt with the inbox and work folders?

thanks Robert
0
 
LVL 28

Assisted Solution

by:sunnyc7
sunnyc7 earned 166 total points
ID: 33677687
robert
Rather than troubleshooting this at this stage - it's better that you setup another account for the user with a large folder - then exmerge the mailbox out as PST and then import it back as PST
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33699931
Magic !!
0
 

Author Comment

by:realtimehosting
ID: 33699932
Thanks for all your help. Don't know what the problem was but working now.

Robert
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now