Solved

as400 printing QL420plus

Posted on 2010-09-14
19
1,390 Views
Last Modified: 2016-09-22
Hi there,

I have a QL420 zebr4a wireless printer.

I have connected it to the network and it pings all is good.. it prints from windows.
But I cant get it to work when printing from as400/iseries..  it only prints blank pages..

Does anyone know if there are controll files sneeded to upload to printer, or
can anyone help me resolve my issue..

Following is the remote outq i created for it..

                          Change Output Queue (CHGOUTQ)                    
                                                                           
 Type choices, press Enter.                                                
                                                                           
 Output queue . . . . . . . . . . > SBWLES02      Name                    
   Library  . . . . . . . . . . . >   QGPL        Name, *LIBL, *CURLIB    
 Maximum spooled file size:                                                
   Number of pages  . . . . . . .   *NONE         Number, *SAME, *NONE    
   Starting time  . . . . . . . .                 Time                    
   Ending time  . . . . . . . . .                 Time                    
 Order of files on queue  . . . .   *FIFO         *SAME, *JOBNBR, *FIFO    
 Remote system  . . . . . . . . .   *INTNETADR    Character value, *SAME...
 Remote printer queue . . . . . .   'portLF1'     Character value, *SAME...
 Writers to autostart . . . . . .   1             1-10, *SAME, *NONE      
 Queue for writer messages  . . .   QSYSOPR       Name, *SAME              
   Library  . . . . . . . . . . .     QSYS        Name, *LIBL, *CURLIB    
 Connection type  . . . . . . . .   *IP           *SAME, *SNA, *IP, *IPX...
 Destination type . . . . . . . .   *OTHER        *SAME, *OS400, *OS400V2..
 Host print transform . . . . . .   *YES          *SAME, *YES, *NO        
0
Comment
Question by:AntonInf
  • 8
  • 5
  • 4
  • +2
19 Comments
 
LVL 38

Expert Comment

by:Herman D'Hondt
ID: 33670989
The blank pages are probably caused by the fact that the Zebra needs to be sent data in a language it can understand, in this case ZPL or EPL. The Windows driver handles this, but I don't know what facilities are available in AS400. However, the following link shows how to set up the queue:

http://tinyurl.com/2wm25gv
0
 
LVL 2

Author Comment

by:AntonInf
ID: 33671261
I tried this but blank pages came out still... bit weird..... it still prints blanks... do i have to set the printer to EPL
0
 
LVL 34

Expert Comment

by:Gary Patterson
ID: 33672870
No native ZPL or EPL driver exists for the AS/400.  

Your software needs to format the raw print stream.  AS/400 shops commonly use a package like TL Ashford's Barcode/400 to do this., or they hand-code EPL in their applications.

- Gary Patterson
0
 
LVL 2

Author Comment

by:AntonInf
ID: 33679402
Thank you for the update... we already printing on Zebra printers.... at the moment but for some reason this one wont accept anything..I research it again... last company i was at had to copy 2 config files to enable as4090 to read it properly..
0
 
LVL 34

Expert Comment

by:Gary Patterson
ID: 33681671
Here's IBM's "master" list of printers.  You'll see that none of the Zebra printers are directly supported.

http://www-01.ibm.com/support/docview.wss?uid=nas1b44a2cf4ba778d83862568250053649f

- Gary Patterson
0
 
LVL 2

Author Comment

by:AntonInf
ID: 33688986
Yes, I just had a break threw apparently i need to change the format and controll prefix..

controll prefix to AAH
COntrol Prefix to 7EH

but now the chalenge is, how to change it on this QL420plus printer...
0
 
LVL 34

Expert Comment

by:Gary Patterson
ID: 33690334
Glad you found a silution  

Sounds like a setting in one of your custom or third party applications - not an OS feature.

Gary
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 33692241
Hi AntonInf,

If the Zebra is programmed with ZPL from a program or tool, it is more efficient and error free to FTP it to the printer instead of use the printer connected to an outq.

Good luck.
 
0
 
LVL 2

Author Comment

by:AntonInf
ID: 33699974
Thank you but the problem is I not sure of the commands to change the format and control prefix..
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 34

Assisted Solution

by:Gary Patterson
Gary Patterson earned 500 total points
ID: 33702951
Doesn't really matter how you get the output to the printer: LPR/LPD from a remote outq, or FTP.  Mostly depends on how your applications are written.

This isn't really an issue of "commands" (at least not IBM AS/400 commands), since these control codes are probably embedded in your applications.  You'll need to find the AS/400 application that is generating these printer data streams, determine how they are configured (are they soft-coded in a file, or are they hard-coded in an RPG or COBOL program?), or if a third-party barcode program is used (like TL Ashford, or MarkMagic), you may just need to go into that application and change the printer that is defined for this particular print job.

There is no guarantee that you'll be able to use this printer without making application programming changes if the document was specifically coded for a particular printer/printer language.

This printer (QL420plus) supports several languages:   CPCL, ZPL, EPL2, and XML.  Maybe you can configure it to start up in a particular emulation mode?

- Gary Patterson


0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 33703290
Hi AntonInf, Gary,

Most of the time Gary is right, but..... it matters.
I connected dozens of Label printers (Zebra, Stripe, Esselte, UBI... etc) Almost all printer drivers I tried, inserted some unexpected/unwanted info in the print job, that will result in no- or  unexpected- output.
If you are sure that the driver is 100% transparent you can use it, otherwise go for the FTP option.
There are two advantages of using FTP
-- you can send it to an other (text) printer so that you get the label definition as text, this is a great help is you have problems with a label contents or layout.

-- You can type testlables yourself within an as/400 source file and print it by just ftp it to the printer.

Good luck,
Murph


0
 
LVL 34

Expert Comment

by:Gary Patterson
ID: 33703690
Like Murphy,  I've personally worked with a lot of label printers, and I agree that if everything is not configured properly, you can get "middleware interference" from print drivers, AS/400 Host Print transform, etc.

That said, a properly configured AS/400 LPD queue and printer file won't insert anything into the print stream - it just creates an LPR/LPD file containing the printer data stream, and sends it to the print server (which in this case looks like it is embedded in the wireless LAN card).

- Gary Patterson
0
 
LVL 2

Author Comment

by:AntonInf
ID: 33714288
Hi there,

Control and format Prefix to 7EH,AAH

I am pretty sure about changing the prefixes on the prionter itself..

But with this printer I am unable to change it for some reason would anyone know..

It looks like these are the charactors it throughs out to the printer... so it can understand
what is a control and hat is a format command..





0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 33714585
Hi AntonInf,

7Eh is a "~"
AAh = '¬'.

Some codepages in the as/400 are translating this to "wrong" substitution characters during the EBCDC > ASCII conversion.

As far as i know, Zebraprinters expect 5Eh instead of 7Eh as escape character
5Eh = '^'

So please check the codepage of your printer(driver)



0
 
LVL 2

Author Comment

by:AntonInf
ID: 33722683
Yes strange,

I was told by the Zebra technicall guy you have to change these codes as this is the setting for our system
0
 
LVL 2

Accepted Solution

by:
AntonInf earned 0 total points
ID: 33786328

here it is i found the ZPL command to allow AS400 to print directly to the Zebra printer..
Once I sent these files to the printer by copy or ftp then it started printing correctly..
~CC¬
¬XA¬JUS¬XZ

This is what was needed... i think its because going form EBCIDC to ASCII these characters change
0
 
LVL 16

Expert Comment

by:theo kouwenhoven
ID: 33786554
Close???

This was MY anwser (ID 33714585) where I told him to check the ASCII EBCDIC Conversion.....!!!
0
 
LVL 2

Author Comment

by:AntonInf
ID: 33805945
Further info for the QL420plus wireless on AS400

got it working..

I finally got the wireless printer to work without printing a blank label after each labell printed..
After all the research and trouble shooting to config the wireless printer on the AS400
You had to change on the printer..

   Control Prefix to :----- 7EH
   Format Prefix to  :----- AAH
 
The above changes allowed the printer to understand what the AS400 was giving it.
Then the next change was stopping the printer from printing a blank label after each labell printer.

This was done on the AS400 where I create my own drive from the *IBM4226 (AS400 standard) then
Renaming my copy of *IBM4226 to QL420plus.. Then I edited QL420plus and removed the Form Feed instruction from the driver, recompiling the driver, through command CRTWSCST.
 
Final step was to enter QL420plus into the outq as shown below. And the blank page stopped printing.
 
0
 

Expert Comment

by:Peter B
ID: 41810648
I know this is a old one but it helped us a lot!

We were very glad to find this answer regarding to the empty labels.

For us we had to do it a little bit different:
RTVWSCST DEVTYPE(*TRANSFORM) MFRTYPMDL(*NONE (instead of *IBM4226) )  
and then we removed the form feed lines.
CRTWSCST after that and everything worked just fine!

Thank you!
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

How to solve seemingly unsolvable printer issues. Users sometimes run into printing issues where all the normal steps do not seem to work. Well the steps below can show users how to take one extra step beyond the normal steps needed to remove old…
This seems to be a very common error related to the Samsung printer driver. First, this is the error we're talking about: Log: System Type: Error Event: 7000 Agent Time: 3:37:24 am 22-Apr-09 Event Time: 6:07:24 pm 21-Apr-09 UTC Source: Se…
This video discusses moving either the default database or any database to a new volume.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now