• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1124
  • Last Modified:

iPhone on WIFI doesn't sync Exchange mail when inside organisation

I have a number of iPhone's in my organisation that sync to the Exchange 2007 server. Outside using 3G the mail synchronises fine however when inside the office on the company WIFI the mail cannot be synchronised. This is due to not being able to go out of the firewall to come back in.

I understand I probably have to add a "A Host" record on the DNS server pointing my server address (example server.domain.com) to the server's internal address. However when I try to add the record domain.com the FQDN adds domain.local which makes the record incorrect (as far as I can tell).

Can anybody help with this please to get my mail synchronising when on the company WIFI?
Thanks,

Alex
0
asbowen
Asked:
asbowen
1 Solution
 
latchwaysCommented:
It appears to be an issue with DNs and the iPhone.

Take a look at http://discussions.apple.com/thread.jspa?threadID=2533433&tstart=0 

Hope this helps
0
 
uescompCommented:
I believe that you will need to add a new zone to your DNS server.  So you would add domain.com as the new zone and then add an A record to that zone.
0
 
latchwaysCommented:
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
woolnoirCommented:
Just add a firewall rule allowing connectivity between internal WIFI ip addresses and your frontend/owa/activesync server ? it shouldnt have to go out and back in again, im assuming your external server is on a DMZ ? if so the traffic will go from LAN (WIFI) -> DMZ and back again. As long as there is a hostname in the DNS i.e mail.company.x which is resolvable internally and externally it shouldnt be an issue.
0
 
Glen KnightCommented:
easiest way to do this is if your OWA URL (or the URL you use for activesync when outside your network is owa.domainname.com then create a forward lookup zone called owa.domainname.com on your internal DNS.

Then create a blank A record in your internal DNS and point it to the internal IP address of your Exchange server.

This will resolve the problems you are experiencing and I have done this at a number of clients of my own.
0
 
asbowenAuthor Commented:
latchways, thanks that may help I'll have a read.

uescomp, thanks, adding a new zone, would this be primary, secondary or stub?

woolnoir, thanks, the Exchange server is inside of our network so not on a DMZ. On the WIFI I can ping the external address using Ping Lite on my iPhone, however the mail will not sync when the same address is in the mail settings on the phone.
0
 
asbowenAuthor Commented:
demazter, thank you, worked perfectly and very easy to follow and implement.

As instructed I created a new primary forward lookup zone  called owa.domain.com, then created a blank A record pointing to the IP address of the Exchange server. Turned on wifi on my phone can now send and receive emails from my Exchange server.

Alex
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now