• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1111
  • Last Modified:

Upgrade to SQL Server 2008 having trouble with SSIS connections

I am getting this error in oneof my SSIS packages that was built in VS 2005 and I have upgraded to 2008 and now having trouble with some packages...

[Connection manager "Excel Connection Manager 2"] Error: SSIS Error Code DTS_E_OLEDB_EXCEL_NOT_SUPPORTED: The Excel Connection Manager is not supported in the 64-bit version of SSIS, as no OLE DB provider is available.

Any ideas?
0
johnnyaction
Asked:
johnnyaction
  • 11
  • 9
  • 2
  • +1
1 Solution
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
Since 64 bit Excel drivers are not available, you need to execute your procedure in 32 bit mode to get it work.
Detailed info below

http://sqlserver.posterous.com/excel-connections-in-ssis-64-b
0
 
johnnyactionAuthor Commented:
ok I seemed to get by that but now Im getting an access denied on my C:\ for one of my file system tasks? Could that be related? FYI...I am only getting the error when I run the sql job that calls the packages via steps. I can run it in BIDS
0
 
johnnyactionAuthor Commented:
I was reading about a checkbox on the job step portion of a sql job where you can select to run in 32 bit mode? I cant seem to find it though? Any ideas?
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
Reza RadCommented:
Is this problem only exists when you run ssis package as job?
or you get it when you run it from BIDS either?
0
 
johnnyactionAuthor Commented:
I can run the packages individually but not from a sql job?
0
 
Reza RadCommented:
did you deployed packages on same machine which you tested package on it with BIDS? or this is different machine which runs job under it?
0
 
johnnyactionAuthor Commented:
I upgraded to a new sql server 2008 box. I took all the jobs that were running under the old sql 05 server and I am now trying to run them on the new 08 box. I copied all the dtsx packages from the old server to the new and I copied all the jobs that call these dtsx packages and I am trying to run them from a sql job. Any thoughts?
0
 
Reza RadCommented:
if your new sql server 2008 box is 64 bit, try executing packages with DTEXEC 32 bit version.
you can find 32 bit DTEXEC here:

<drive>:\Program Files(x86)\Microsoft SQL Server\100\DTS\Binn

0
 
johnnyactionAuthor Commented:
I put this in the command line of my jobs step

/FILE "E:\Microsoft SQL Server\SSIS\Data Warehouse SSIS\Data Warehouse SSIS\Generate Net Position List.dtsx"  /X86  /CHECKPOINTING OFF /REPORTING E

Still will not work. I added the /x86 I saw in an article this was what I should do. Still doesnt work though
0
 
johnnyactionAuthor Commented:
And I have made everything 64bit=False
0
 
Reza RadCommented:
To run a package in 32-bit mode from a 64-bit version of SQL Server Agent, select Use 32 bit runtime on the Execution options tab of the New Job Step dialog box.
0
 
johnnyactionAuthor Commented:
I have tried to find where that option is in my job step but I cannot find it. See attached
EE.docx
0
 
Reza RadCommented:
amazing,
my configuration is different.
look at attachment!

1.jpg
0
 
johnnyactionAuthor Commented:
Do I have to install a 32 bit environment somehow? I have seen some articles where they tell me to check that checkbox but I dont know how to make it appear?
0
 
Reza RadCommented:
is your sql server agent under 2008?
0
 
johnnyactionAuthor Commented:
I am assuming so. Its a SQL Server 2008 R2 installation. I did not have any service packs installed so Im installing SP1 now.
0
 
Reza RadCommented:
a workaround for this :
use the Operating System type of job step, and refer to the 32-bit version of DTExec specifically in the command line that you use, and manually specify arguments to DTExec
32-bit DTExec is here:
<drive>:\Program Files(x86)\Microsoft SQL Server\100\DTS\Binn

reference:
http://toddmcdermid.blogspot.com/2009/10/quick-reference-ssis-in-32-and-64-bits.html



0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
Try this from command prompt:

"C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\dtexec.exe" /f "E:\Microsoft SQL Server\SSIS\Data Warehouse SSIS\Data Warehouse SSIS\Generate Net Position List.dtsx" /X86
0
 
johnnyactionAuthor Commented:
Ive tried all suggestions but I am still having issues. Anything else you could recommend?
0
 
Reza RadCommented:
what is your ssis package consists?
do you used execute process task?
do you used execute package task?
do you used script task?

in any of above tasks you need to do changes to run under 32 bit. you need to read this great article of Todd carefully line by line:

http://toddmcdermid.blogspot.com/2009/10/quick-reference-ssis-in-32-and-64-bits.html


0
 
novaspoonmanCommented:
Reza is correct. This is definitely a 32/64-bit issue. There is no 64-bit provider for Excel.

Did you happen to install a 64-bit version of BIDS with a 32-bit version of SQL Server and SSIS? That would explain why the 32-bit runtime checkbox is missing.

0
 
johnnyactionAuthor Commented:
thanks
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 11
  • 9
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now