Cluster service won't start on one node of cluster, error 1067

My apologies for re-posting something but nothing I've tried has helped so far.

I have 2, win 2k3 nodes in my cluster.   The one that won't start has a bunch of 1000 and 7031 errors.  when i try to start the service through the CLI or 'Services' I get the following message. "A system error has occurred" "the process terminated unexpectedly".

I get the same thing when adding the /fixquorum switch as suggested in this KB; http://support.microsoft.com/kb/923838.  I also checked to make sure the driver was set to system and started per the KB.

I also verified the user account for the cluster service had the required rights per this KB; http://support.microsoft.com/kb/269229/en-us

I'm not sure what else to do.  Array Configuration Utility on the server can see the shared storage.

c2mediaAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
c2mediaConnect With a Mentor Author Commented:
the cluster was at a remote location but we brought in a local tech.  the problem was due to a corrupt database.
0
 
novaspoonmanCommented:
How is the shared storage configured? FC/iSCSI? To what arrray configuration utility are you referring?
0
 
c2mediaAuthor Commented:
Array Configuration Utility is HP software that is used to manage storage.  We have a simple setup with 2 servers connected via SCSI to shared storage box.. (HP MSA500).  

0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
novaspoonmanCommented:
Can each node see and access the quorum disk with the other node shut down?
0
 
c2mediaAuthor Commented:
i won't be able to try that until after hours tonight.  i'll post the result in the morning.
0
 
65tdCommented:
Does the cluster service account have full control on the quorum and shared disks?
Had issues even when administrators have FC, added CSA issue went away (for us).
0
 
c2mediaAuthor Commented:
To answer above questions:
1. can each node see  and access the quorum disk with the other node shut down?
Even with the 2nd node shut down the problem node can't access either of the 2 disks.  They are visible through the HP Array Config Utility but windows only sees drives with no information.

maybe it's less a cluster issue and more of a hardware issue.  I'm more confused than before.

2. Does the cluster service have full control on the quorum and shared disks?  the CSA is a member of domain admins but I can't access the storage to see.
0
 
65tdCommented:
The CSA does not need to be apart of domain admins, does need to be a local admin on each node...
With good node down and rebooting the problem node, does it pickup the disks then?

Any events in the system log?
Hardware changes?
0
 
c2mediaAuthor Commented:
a few different errors in the system log.

7031 and 1000 on 1 node


on the other node I've got:
1069, Cluster resource 'Disk Q:' in Resource Group 'Cluster Group' failed.
 
1066, Cluster disk resource "Disk Q:" is corrupt. Run 'ChkDsk /F' to repair problems. The volume name for this resource is "\\?\Volume{7a15e43a-a19f-11df-b7e4-001438bde4f4}\".
 If available, ChkDsk output will be in the file "C:\WINDOWS\Cluster\ChkDsk_Disk4_Sig8B2E1C25.log".
 ChkDsk may write information to the Application Event Log with Event ID 26180.


I tried running chkdsk Q: /F but it fails with message "Can not open volume for direct access"

would I be better off getting rid of the cluster, getting it working on 1 node and then recreate the Q volume?
0
 
65tdCommented:
See MS's note re the 1069:
http://support.microsoft.com/kb/259237

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.