Solved

cisco 1481 router config for lan/voip link over T1

Posted on 2010-09-14
8
1,555 Views
Last Modified: 2012-05-10
Hi folks,
I sure hope one of you can see what the heck I'm doing wrong here and help me out of this nightmare lol   I am in the process of reversing a Voip / Lan setup.  My clients build a new office about a year ago, and originally we had things setup to provide a voip gateway via a T1 line from the old office to the new office, thus elimating moving trunks etc.
Well now they have moved the bulk of thier operations to the new building and along with this came moving the trunk lines and the BCM (Nortel BCM 400).   However I still need to provide access to both the computer network and the phone system for about a 1/2 dozen users at the old building.
I reconfigured their two Cisco 1841 routers, primarily just changing the ip addresses and routing commands to match thier new subnets.  Yes we traded them out as well.  However now, even if I manually configure the Nortel Ip phones they still come back with a sever unreachable message.  
I have also attempted to setup the routers to provide dhcp, but then I just get a dhcp parse error on the phones (something to do with the formating of DHCP Option 128?  Very wierd.
Here is a basic rundown on my current setup.

Main Office
Nortel BCM configured at ip 192.168.2.1 mask 255.255.255.0 running dhcp for local clients.  This is connected to a Nortel POE switch which goes out to all the local handsets (which all work just fine running dhcp) and to the first Cisco Router.
The cisco router at main office is configured as follows

Interface fastethernet0/0
Connection to the local Lan (Windows Server 2003 / Vista workstations).
Ip addrsss 192.168.4.254 255.255.255.0

Interface fastethernet0/1
Connection to BCM
Ip address 192.168.2.2 (originally had this set as 192.168.2.254 but there is some other device (which I have no clue what it is) using that address.  I'm still working on figuring out what that is.

Serial0/0/0
Connection to remote office
ip address 192.168.254.2

ip route 192.168.3.0 255.255.255.0 192.168.254.1
ip route 192.168.1.0 255.255.255.0 192.168.254.1
ip route 192.168.4.0 255.255.255.0 192.168.4.1
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.4.253 (Routes all internet traffic to local ADSL router)

Remote office Router Config

Interface Fastethernet0/0
Lan Link to Main office
ip address 192.168.3.254

Interface Fastethernet 0/0
Voip Link to BCM
Ip address 192.168.1.254

Serial0/0/0
T1 link to main office
Ip address 192.168.254.1

ip route 192.168.4.0 255.255.255.0 192.168.254.2
ip route 192.168.2.0 255.255.255.0 192.168.254.2
ip route 0.0.0.0 0.0.0.0 192.168.3.253 (Routes all internet traffic to local ADSL router)

I have also tried (without much success) seting up dhcp on the routers but keep running into that issue with DHCP Parse errors on the phones.  

Can anyone point me in the right direction here?  I should point out that the LAN side works fine.  I established a remote access link back to the main server without issues.  Also, from the remote router I can ping both the main router and the BCM, so the link seems solid, just have to get the right info to the phones at this point.

Thanks, any help will be Very much appreciated.

Brian
0
Comment
Question by:bmgcomp
  • 4
  • 3
8 Comments
 
LVL 10

Expert Comment

by:ddiazp
Comment Utility
What does your DHCP config look like?

Are you typing the FQDN or IP address of the TFTP server?

0
 
LVL 10

Accepted Solution

by:
ddiazp earned 500 total points
Comment Utility
Also, remember to use the ip helper-address command if the DHCP server is in a different segment from the phones.
0
 
LVL 1

Expert Comment

by:cdusio
Comment Utility
Start simple, can you ping the server from a subnet on the remote site to the main location?
To me this sounds like a routing issue right out of the gate.
0
 

Author Comment

by:bmgcomp
Comment Utility
My DHCP setup goes something like this

Main Router

service dhcp
ip dhcp pool bhmain
network 192.168.2.0 255.255.255.0
default-router 192.168.254.2
domain-name bhssa

Remote Router
service dhcp
ip dhcp pool bhremote
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.254.1

From the remote router I can ping both the main router, the BCM (192.168.2.1) and the file server (192.168.4.1)
From the BCM I can ping the remote router, and on the LAN side I have established a remote access connection so all that routing seems to be working fine.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 10

Assisted Solution

by:ddiazp
ddiazp earned 500 total points
Comment Utility
I see the default-router is on a different subnet than the IP pool -- have you double checked this? Is this what it's supposed to be?

what is the remote router connected to? what settings does it import from 'import all'?


You're missing the tftp option; all phones must be given a tftp ip address from DHCP; try adding this line to the router that serves your phone's DHCP:

option 128 ip <tftp server IP address>

put in the IP address of the router.
0
 

Author Comment

by:bmgcomp
Comment Utility
Thanks for all the suggestions guys, but I managed to get it working on my own.  Tftp address was a nice idea but just gave me more errors.  
In the end, I learned once again (beating head against wall) that one should never ever ever trust telecom techs when it comes to networking.   Silly twit was putting all the phones in different subnets ( ie. 192.168.101.1, 102.1 etc. lol
Once I got them all back on the right subnet they all work just fine.

Thanks again for the assistance.
0
 

Author Closing Comment

by:bmgcomp
Comment Utility
finally figured out the issue myself, but these comments were definately helpful.
0
 
LVL 10

Expert Comment

by:ddiazp
Comment Utility
Glad you got it down!
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
CUCM and two Polycom 7936 using 3 33
Porting numbers 3 29
SMB Routers with GB WAN 12 31
DHCP relay on an ASA 5505 8 16
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now