Configuring Wallpaper Group Policy on Terminal Server running Windows Server 2008 R2

Hi,

I'm having some issues configuring a group policy to set a certain wallpaper image for a new terminal server I'm building.  I have the theme configured with the Desktop Experience feature installed with the Windows 7 Basic look (without the Aero glass).  The wallpaer just shows up as black.  I'd like to change it to blue, but none of the Group Policy settings I've set work.    

I've tried setting the wallpaper and enabling the active desktop.  I do have it set to prevent users from changing the wallpaper and background.  Is there something I'm not setting correctly?

Any help would be great!
FlashJack9Asked:
Who is Participating?
 
Cláudio RodriguesConnect With a Mentor Founder and CEOCommented:
Group Police Preferences is a new feature of 2008. Explained here:
http://www.microsoft.com/downloads/en/details.aspx?familyid=42E30E3F-6F01-4610-9D6E-F6E0FB7A0790&displaylang=en

http://technet.microsoft.com/en-us/windows/ee405819.aspx

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
0
 
Cláudio RodriguesFounder and CEOCommented:
By defaul I think the Wallpaper is disabled over RDP.
So if you go to the Computer Settings policy, you will find Terminal Services or Remote Desktop Services and there I think there is a setting to enable wallpapers to be shown.
On the client side also make sure you select the highest settings for the connection (so it shows the wallpaper).

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
0
 
FlashJack9Author Commented:
Thanks for the response!  

Sorry, I actually did try that and still it didn't work.  If I change the theme to Windows Classic, the background will be blue, but I'd like them to have the Windows 7 experience like our laptop and desktop users have.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
FlashJack9Author Commented:
Also, I'm trying to figure out how to take the Administrative Tools menu off of the Start menu for all users.  Any help would be great with that as well.
0
 
Cláudio RodriguesFounder and CEOCommented:
For that you need to use a Group Policy Preference. That will take care of getting rid of the Administrative Tools.

Cláudio Rodrigues
Microsoft MVP - Remote Desktop Services
Citrix CTP
0
 
FlashJack9Author Commented:
What do you mean by "Group Policy Preference"?  Is there a setting in GP that lets me get rid of those?  I haven't been able to find one.

Thanks!
0
 
FlashJack9Author Commented:
Thank you, I was able to remove the Administrative Tools menu using the GP Preferences!

Any ideas on why that desktop still shows up as black though?

Also, do you know how to allow icons to be pinned to the taskbar, but not show the Server Manager and PowerShell icons?  I've set a policy to not allow icons to be pinned there, but I'd like them to be able to do that if they need to.  I just don't want those other two icons showing up.
0
 
FlashJack9Author Commented:
Ok, I figured out why the desktop is black.  That is the default color for the theme we picked, and since we had wallpaper disabled, and prevented changing the theme on, it wouldn't change.  So I created a new theme and saved it and it is working now.

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.