Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3615
  • Last Modified:

Can I prevent Windows from asking to initialize disk.

Can I prevent Windows from asking to initialize disk or hide disk management. I am using VCB to backup my Virtual Machines. In order for this to work you have to give your VCB server access to the LUNs on your SAN. If you click on disk management it ask you to initialize you LUNs this is bad! If someone inadvertently click on the Yes it would be catistrophic.
0
rorybrady
Asked:
rorybrady
  • 4
  • 2
  • 2
  • +1
1 Solution
 
Will SzymkowskiSenior Solution ArchitectCommented:
Take a look at this link as it provides a way to disable access to drives from Disk Management.
http://www.exnol.com/how-to-disable-access-to-drives-using-disk-management

Hope this helps~!
0
 
rorybradyAuthor Commented:
Thanks but this is not what I am looking for.

When Windows sees the new LUNs they don't show up as drive letters. Windows just thinks it is new disk that it needs to initialize. I need to either prevent it from asking to initialize the desk when you click on disk management or hide the disk management application all together.

Windows just sees the LUN from the SAN as a raw disk (do not have drive letters associated with them) and wants to initialize it. But really the LUNS are VMFS and have virtual machines on them, initializing these disk would make the LUNs unusable, destorying the VMs..... I think.
0
 
novaspoonmanCommented:
Initializing a disk *shouldn't* delete anything, assuming Windows can recognize the partitions.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
rorybradyAuthor Commented:
Yes, but initializing the disk creates a new signature on the disk. Does this make the disk un-readable for VMWare?
0
 
novaspoonmanCommented:
Ah, yes. If Windows writes a signature to the disk, VMware will no longer recognize them as VMFS.

You should consider disabling automount via the Windows DISKPART utility, and have a script ready to relabel the volumes on the ESX side, should something happen to the disk type labels.

http://www.yellow-bricks.com/2008/02/11/vcb-i-forgot-all-about-automount-disable-what-now/
0
 
rorybradyAuthor Commented:
Thanks.

We have disabled automount but if you open disk management Windows still asks if you want to initialize the drives.

I want to prevent someone from inadvertently click yes and initializing the drives. I was hoping to find a way hide disk mangement or prevent Windows from asking that question.
0
 
Robin CMSenior Security and Infrastructure EngineerCommented:
I have the same issue/concerns as rorybrady, all my VMFS LUNs are shortly going to be presented to our NetBackup 7 system, running on Windows Server 2008 R2. Our Symantec supplier is aware of the issue, and apparently so are Microsoft. If I get a solution I'll post it.
0
 
Robin CMSenior Security and Infrastructure EngineerCommented:
Workaround, though I've only done basic testing, is to stop the Virtual Disk service (if running) and change it's startup type from Manual to Disabled.
This obviously breaks the Disk Management MMC snapin, but once your disks are configured you shouldn't need it.
0
 
rorybradyAuthor Commented:
I have created a Goup Policy that prevents the disk management snap-in from being displayed in computer management when you run it. I also have created a GP that hides the Administrative tools from the control pannel.

You can still get to disk management of you load the mmc snap-in manually.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now