We help IT Professionals succeed at work.

Laptops don't get IP before logon, get "Domain not available"

661 Views
Last Modified: 2012-05-10
We have Active Directory Windows 2008. We have about 200 laptop that connect to our wireless Cisco access points.

The problem is when we have a classroom of kids starting laptops, about half of them will give the error "Domain is not available" when they log in. Wait on Network is enabled. It seems the computer does not get an IP before the login prompt, even though wait on network is enabled. Is there a way to force the laptop to get an IP before the login prompt?
Comment
Watch Question

sometimes the vendor management software for managing the software does this.

could you trying using the inbuilt wireless zero configuration service of windows to manage your wireless and see.

Commented:
There is a group policy setting that may help. See http://support.microsoft.com/kb/305293.

If that is not applicable, It might help to know which version of Windows is on the laptops.

Commented:
Make sure that you are using the Windows wireless connection service NOT the third part device driver software.

the way to do this varies with software installed but generally this will work...
1. go to Start Menu -> Control Panels -> Administrative -> Services and make sure that Wireless Zero Configuration service is started.
2. go to the Network Connections control panel rightclick on your wireless card and choose properties and check the 'use windows to manage my wireless' check box.
3. then you have to reconnect to the wireless network.

Now wireless will load with the OS and not wait for you to login.

Author

Commented:
The laptops all are using Windows Zero Connection and not the 3rd Party software.

We used the 3rd party software before and it does not work,

Author

Commented:
jlar310, The article you sent me is the Wait on Network policy, which we already are using.

Commented:
does the laptop itself have a software switch for turning on and off the wireless card? is it off before login?

Author

Commented:
All the laptops radios are enabled. The problem is the laptops are not waiting long enough to get an IP.

When you boot the laptops and have them wait at the login prompt for about 5 minutes, then have them all log in, all laptops login fine.

Commented:
ok, well MAYBE, just a thought, you could make a .bat file that runs    ipconfig /renew   then make a scheduled task that runs at boot that loads the batch file. run it as a local administrator with saved credentials. That will probably force the IP to load faster.
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
novaspoonman: I am investigating this method. Should I make the TCP/IP, and DHCP services depend on the Wireless  Zero as well?
I would consider that if the first doesn't work.

Author

Commented:
This worked great. I made a lot of network dependencies for the netlogon service.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.