Solved

Crystal Report Viewer buttons generate error

Posted on 2010-09-14
4
373 Views
Last Modified: 2012-05-10
I've got a crystal report viewer control on an aspx web form. The report displays correctlly but when I click any button on the control I get the following error

 
Server Error in '/sinot' Application.
Object reference not set to an instance of an object.

Description: 
An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: 
System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the
exception can be identified using the exception stack trace below.

Stack Trace:
NullReferenceException: Object reference not set to an instance of an object.]
CrystalDecisions.Web.ReportAgentBase.() +536
CrystalDecisions.Web.ReportAgent.get_RequestContext() +10
CrystalDecisions.Web.ReportAgent.get_{() +7
CrystalDecisions.Web.ReportAgent.(Booleani) +80
CrystalDecisions.Web.CrystalReportViewer.OnPreRender(EventArgs e) +474
System.Web.UI.Control.PreRenderRecursiveInternal() +62
System.Web.UI.Control.PreRenderRecursiveInternal() +125
System.Web.UI.Control.PreRenderRecursiveInternal() +125
System.Web.UI.Page.ProcessRequestMain() +1545

Version Information: Microsoft .NET Framework Version:1.1.4322.2407; ASP.NET Version:1.1.4322.2407

Open in new window


This error happens on the deployment environment and does not on my development environment. On development works as expected.
0
Comment
Question by:jose_rijos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 33677017
Sounds like something isn't being saved for the post back event.

mlmcc
0
 

Accepted Solution

by:
jose_rijos earned 0 total points
ID: 33710131
Recompiling again solved the problem.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 34308578
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question