Does anyone know how to setup TLS for a specific domain in Exchange 2010?

I need to setup TLS for one client only.  I can't find any documentation on how to do this in Exchange 2010.  We use Postini for filtering as well- so I am lokking how to make it work for both.
funkyone60Asked:
Who is Participating?
 
endital1097Connect With a Mentor Commented:
enabling a receive connector authentication with TLS allow for TLS communication
telnet into the recieve connector and send a ehlo and you will see the STARTTLS verb
0
 
funkyone60Author Commented:
this is done in exchange?  I need to send tls email to one client- this doesn't sound right to me
0
 
endital1097Commented:
for outbound make sure your certificate has a subject name that matches the fqdn of your send connector

get-sendconnector | fl name,fqdn

get-exchangecertificate | where { $_.services.tostring().contains("SMTP") -eq $true }
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
funkyone60Author Commented:
you are way past my understanding- where do I do this in exchange?
0
 
endital1097Connect With a Mentor Commented:
from the exchange managemnet shell
0
 
endital1097Connect With a Mentor Commented:
0
 
funkyone60Author Commented:
Made it to step 3b and I am getting this error

[PS] C:\Windows\system32>Set-SendConnector Internet -DomainSecureEnabled:$true
The operation couldn't be performed because object 'Internet' couldn't be found on 'ATL-ADS02.palaw.local'.
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-SendConnector], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 90B99986,Microsoft.Exchange.Management.SystemConfigurationTasks.SetSendConnector
0
 
endital1097Connect With a Mentor Commented:
run "get-sendconnector" first to verify the name
0
 
funkyone60Author Commented:
this is what i get

[PS] C:\Windows\system32> get-sendconnector

Identity                                AddressSpaces                           Enable
--------                                -------------                           ------
Internet Email                          {SMTP:*;1}                              True
0
 
endital1097Connect With a Mentor Commented:
Set-SendConnector "Internet Email" -DomainSecureEnabled:$true
0
 
funkyone60Author Commented:
Basically he walked me through seeting up TLS for Exchange 2010.  Thanks for the hwlp
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.