?
Solved

Cannot Lock Current drive...

Posted on 2010-09-14
11
Medium Priority
?
2,463 Views
Last Modified: 2012-05-10
I am getting the above error. I noticed it after I scheduled a routine maintenance disk Error Checking on my Windows 7 64-bit laptop and realized it was not running it on reboot.

I rebooted to the Windows 7 installation repair disk and from the Command prompt got this error: "Cannot Lock Current drive... Windows cannot run disk checking on this volume because it is write protected".

I have tried everything ... the drive was not giving any problems. I downloaded and installed the Seatools for Windows ... it runs the scans and does not report any problems on the drive.

Has anyone experienced this error on Windows 7?

0
Comment
Question by:BitsBytesandMore
  • 7
  • 4
11 Comments
 
LVL 22

Author Comment

by:BitsBytesandMore
ID: 33675589
Additional info: the drive is a Seagate ST9500420ASG (laptop) . No viruses. No spyware. It's clean - Really!!
0
 
LVL 22

Author Comment

by:BitsBytesandMore
ID: 33675714
In the BIOS there is no password set for anything, TPM is disabled. Also tested with HDD Regenerator and Spinrite ... I noticed though, that it seemed to be using PIO ... Not DMA (got to check again with Spinrite).....
0
 
LVL 6

Assisted Solution

by:Cesar Aracena
Cesar Aracena earned 2000 total points
ID: 33676098
Hi BitsBytesandMore,

Is that the only HDD on the laptop? Or is it a secondary drive? if it's the only drive (which is the more common situation) then the problem is either some buggy lock from the OS when partitioning occured or you have a faulty drive on your hands.

I would try and change it for a spare HDD and do a clean install on it (same Windows version) and then run the mainteinance tests. If everything works fine, try and backup and format the original HDD and do a clean install and re-test. If the problem persist, it's a fauly drive.

It could also be the drive controllers but it's not the most usual failure in those cases. If it doesn't work with a spare drive, then it could be your motherboard failing.

If you don't have a spare drive or can't get one cheap enough, then do a backup (urgent) and then format and test.
0
Meet the Family that is Made for Collaboration

The TeamConnect Family product group as part of the Sennheiser for Business Portfolio comprising high-quality, technically well-conceived meeting solutions for business communication – designed for any meeting room and any meeting situation.

 
LVL 22

Author Comment

by:BitsBytesandMore
ID: 33677100
Thanks Caracena... I have a full image of the drive and all the data backed up. What I really want is to find out what is causing this? and how to fix it?
I have already removed the drive from the laptop and I am testing it from another computer and getting the same error ....
Bits ...
0
 
LVL 22

Author Comment

by:BitsBytesandMore
ID: 33677349
Oh ... and just in case someone asks... yes... I did change to drive D before running chkdsk...
Also verified the drive status according to the following:

Here's the procedure for checking the disk status.
Open cmd window running as administrator
Run diskpart.exe
At the "DISKPART>" prompt enter the following commands. Text from // onwards is a descriptive comment
>list volume //shows volumes and drive letters
>select volume n //set focus on desired volume number n from list
>detail volume //gives detailed attribute list for selected volume
Here's the listing I get for my D-drive. (Note that extra spaces have been removed by the forum display.)
DISKPART> detail volume
Disk ### Status Size Free Dyn Gpt
-------- ---------- ------- ------- --- --- Disk 0 Online 190 GB 5812 KB

Read-only : No
Hidden : No
No Default Drive Letter: No
Shadow Copy : No
Dismounted : No
BitLocker Encrypted : No
Volume Capacity : 500 GB
Volume Free Space : 250 GB
0
 
LVL 6

Assisted Solution

by:Cesar Aracena
Cesar Aracena earned 2000 total points
ID: 33677374
It could be related to it's controller. I can't seem to find wheather this disk in particullar has S.M.A.R.T. but try it anyways. In the BIOS settings, enable the S.M.A.R.T. (Self-Monitoring, Analysis and Reporting Technology) and reboot.

If completely formatting it doesn't fix it, throw it away. The comtroller is damaged. If it does fix it, then it was something in the TOC telling the computer that the drive is protected somehow.

To format it and propperly test it, install it as a slave on a PC.

In my PC for example, I have all my data in a drive that can't be detected neither from the BIOS nor the Windows installation... I altered the TOC by hand to protect that drive from being formatted by mistake. I have it on a RAID 1 setup so I don't really care if what I did breaks it ;)
0
 
LVL 6

Expert Comment

by:Cesar Aracena
ID: 33677417
Try using "disk" instead of "volume" in DISKPART. Your problem is the disk. Not a particular partition inside of it. Post the results.
0
 
LVL 22

Author Comment

by:BitsBytesandMore
ID: 33678304
Yes... this disk has S.M.A.R.T. It is the first test the Seatools for Windows offers to run on this Seagate drive. As I mentioned before, I ran them all: S.M.A.R.T., Short DST (Drive Self Test), Long DST, Short Generic, Long Generic.
I didn't run any of the "Advanced Tests" since it would ruin the data (I will leave this for last in case I have no other option but to format the drive and just need to verify it is not a hardware problem). First I want to see if I can find out what the problem is and how to solve it without having to just restore the image, which would solve the problem but leave us without an answer as most who have encountered this same problem (If you do a Google search no one really has found out why this happens).
Bits ...
0
 
LVL 22

Accepted Solution

by:
BitsBytesandMore earned 0 total points
ID: 33692770
Ok... just an update:
I attempted to run chkdsk on the drive from another PC with Windows 7 (so I wouldn't have the problem of the files being locked in use and to eliminate variables)... I kept getting the same error.
Since I have an image of the drive and data, and there was so little feedback as to the source and repair of the problem (both Google and EE) , I decided to give up and hopefully narrow down the origin of the problem to a faulty hard drive... I had already tried every other conservative step.
Before re-imaging I had decided to format and Spinrite the drive, just to make sure it wasn't a hardware issue that would come back to haunt me. I moved the drive back to the laptop and as I was rebooting, the phone ringed, I got distracted and I missed the "Press any key to boot from CD...." prompt.
To my surprise, while booting, I now see the screen advising me that a disk check was about to be performed unless I pressed any key, and, all of the sudden chkdsk was working and the drive was being scanned. It found some free space being reported as used (I'm not sure if this error was created by me in my attempts to get chkdsk running in the first place or if it was present to begin with).
I tested multiple times, I scheduled a another disk check and booted. Every time it worked flawlessly. As before, I ran all the "Seatools for Windows" diagnostics and all came back "PASS".
Lastly, I still wanted to check the hardware, so I created a new image of the whole hard drive and formatted the drive. Tested extensively for errors with all the applications I could get my hands on. Nothing. I restored the image without problems.
I don't know what fixed it or what was preventing me from running a scheduled chkdsk in the first place. The more I tested, the worse it was getting (I believe that during the tests, I had created the only error found and corrected above by Chkdsk); It had reached a point where it wasn't allowing me to save or install anything on the drive (every time I saved or changed something to it, for example, changing the background wallpaper, saving a txt file on the desktop or installing any small app, it would behave normally and appear to save, but as soon as I rebooted, whatever I had saved or changed was gone). It got to a point of not even allowing me to boot, and worse yet: Startup Repair was reporting that it could not automatically fix the error.
This incident was becoming frustrating, especially because it appeared and disappeared in the same unexplained way.
I was hoping by asking the question, because it was very rare error, and so little feedback on it everywhere, that someone who had experienced this error, would shed some light into how/why it appears and how to solve it. It would be of great help to future victims of this issue.
From this experience, I gather that a partial solution would be (for those who don't have an image or data backed up) to keep tinkering with it, try to backup your data (just in case) and at some point it may fix itself.
Unless someone wants to add some useful and welcome comment, I guess I should now close the question. I am awarding points to Caracena for assisting. Thank You.
Bits ...
0
 
LVL 6

Assisted Solution

by:Cesar Aracena
Cesar Aracena earned 2000 total points
ID: 33692957
Hi Bits,

It is indeed strange. All I could think of is some weird problem or "mixup" in the disk controller inside the HDD. Good to see you solved it tho ;)

One big part of the solution might have been taking it to another computer and then back to the original one. That could have rebooted the controller. I really can't think on something else. Very weird case. If it happens to me, I would just throw away the disk and replace it. Good thing it happened to you hehe.

Cheers mate.
0
 
LVL 22

Author Comment

by:BitsBytesandMore
ID: 33693359
I guess I'm not used to asking and closing questions. I'm trying to Accept and Award Points on CommentID:33692770 and I keep getting an error saying "...
Each point split must be at least 20 points...". I am doing this (see attached pdf). I will request a moderator help me close it.
Bits ...

Close-Question-for-Cannot-Lock-C.pdf
0

Featured Post

Eye-catchers on the conference table

Challenge: The i-unit group was not satisfied with the audio quality during remote meetings. They were looking for a portable solution with excellent audio quality for use in their conference room but also at their client’s offices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many businesses neglect disaster recovery and treat it as an after-thought. I can tell you first hand that data will be lost, hard drives die, servers will be hacked, and careless (or malicious) employees can ruin your data.
Among the most obnoxious of Exchange errors is error 1216 – Attached Database Mismatch error of the Jet Database Engine. When faced with this error, users may have to suffer from mailbox inaccessibility and in worst situations, permanent data loss.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
Suggested Courses
Course of the Month9 days, 13 hours left to enroll

612 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question