Solved

How to setup a Postfix server to forward to Exchange server

Posted on 2010-09-14
11
2,414 Views
Last Modified: 2013-11-10
I have already asked this but I still cannot get it to work.  What Im trying to do is forward alerts from my nagios server to my exchange server.  The Nagios server has postfix installed and configured but I keep getting this message when sending

<cjameson@exchange.domainserver.net>: host 192.168.1.212[192.168.1.212] said:
    550 5.7.1 Unable to relay (in reply to RCPT TO command)

I followed these steps
http://technet.microsoft.com/en-us/library/bb232021(EXCHG.80).aspx

But I still cannot get a relay setup correctly for some reason.  Can anyone give me a headsup as to what I may be doing wrong?
0
Comment
Question by:cjameson74
  • 4
  • 3
  • 2
  • +2
11 Comments
 
LVL 4

Expert Comment

by:jlar310
ID: 33675755
How is postfix configured? Please post output of "postconf -n"

Have you tried setting postfix to behave as a simple client?

http://www.postfix.org/STANDARD_CONFIGURATION_README.html#null_client

0
 
LVL 1

Author Comment

by:cjameson74
ID: 33675811
No I havent tried setting it as a client, but here are the results of the conf file.  I have tried to telnet to the exchange server and send a test email msg and that went thru....its only when im using mailx it gets bounced

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
config_directory = /etc/postfix
default_transport = error
local_recipient_maps =
mailbox_size_limit = 0
mydestination = Monitor.DomainServer.net, localhost.DomainServer.net, localhost
myhostname = Monitor.DomainServer.net
mynetworks = 127.0.0.0/8 192.168.1.212/24
myorigin = domainserver.net
readme_directory = no
recipient_delimiter = +
relay_domains = domainserver.net
relay_transport = error
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = no
transport_maps = hash:/etc/postfix/transport
root@Monitor:~#
0
 
LVL 4

Expert Comment

by:vnicolae
ID: 33675840
in your transport file, make sure you the the following line:

exchange.domainserver.net:   smtp:[ip address of your exchange server]
0
 
LVL 16

Expert Comment

by:Enphyniti
ID: 33675850
Also, run the following from your postfix server and post the results (replace italicized text with valid info):
---------------------------------------------
telnet YourExchangeServer 25
helo PostfixServer
mail from: root@PostFixServer
rcpt to: YourExternal@EmailAddress.com (like gmail or yahoo)
data
From: Root
To: You
Subject: Testing Relay
message content
.
---------------------------------------------

Make sure you don't miss that last line.  (single period)

If you receive the message at your external address, then relaying is working fine and it is a postfix issue.  Otherwise it should give you an error.



0
 
LVL 16

Expert Comment

by:Enphyniti
ID: 33675865
Oh... typing too slow.

Here's a thought... do you have an MX record setup for your domain internally?   If postfix is trying to use your public MX, that might be the problem.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 1

Author Comment

by:cjameson74
ID: 33675877
I have the transport file configured like that already....
Telnet is working just fine
I received the email so it must be something else in postfix config
0
 
LVL 1

Author Comment

by:cjameson74
ID: 33675887
No the MX record is at our hosted site.  
0
 
LVL 16

Accepted Solution

by:
Enphyniti earned 500 total points
ID: 33675914
Or just tell your postfix install to use your exchange server as a smarthost:

relayhost=YourExchangeServer

restart postfix

More info from main.cf:

# The relayhost parameter specifies the default host to send mail to
# when no entry is matched in the optional transport(5) table. When
# no relayhost is given, mail is routed directly to the destination.
#
# On an intranet, specify the organizational domain name. If your
# internal DNS uses no MX records, specify the name of the intranet
# gateway host instead.
#
# In the case of SMTP, specify a domain, host, host:port, [host]:port,
# [address] or [address]:port; the form [host] turns off MX lookups.
#
# If you're connected via UUCP, see also the default_transport parameter.
#
#relayhost = $mydomain
#relayhost = [gateway.my.domain]
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]
0
 
LVL 1

Author Comment

by:cjameson74
ID: 33675942
Just for reference
I did get a reply here on exchange


root@Monitor:/etc/postfix# telnet exchange.domainserver.net 25
Trying 192.168.1.212...
Connected to exchange.domainserver.net.
Escape character is '^]'.
220 exchange.DomainServer.net Microsoft ESMTP MAIL Service ready at Tue, 14 Sep 2010 14:24:55 -0500
helo
250 exchange.DomainServer.net Hello [192.168.1.100]
mail from:root@monitor.domainserver.net
250 2.1.0 Sender OK
rcpt to:cjameson@americanriskins.com
250 2.1.5 Recipient OK
data
354 Start mail input; end with <CRLF>.<CRLF>
Testing relay
.
250 2.6.0 <a9c76d0e-9ef5-4f64-9e19-b2a94e1eebeb@exchange.DomainServer.net> Queued mail for delivery
0
 
LVL 10

Expert Comment

by:ddiazp
ID: 33688935
You need the following (2) entries on your transport file:

.domainserver.net:   smtp:[ip address of your exchange server]
domainserver.net:   smtp:[ip address of your exchange server]

dont forget to postmap that transport file, restart postfix and try again.
0
 
LVL 10

Expert Comment

by:ddiazp
ID: 33712072
It's been 4 days, how did it go?
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

Easy CSR creation in Exchange 2007,2010 and 2013
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
In this video we show how to create a Distribution Group in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >>…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now